Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1075696 - OpenIPMI rawhide build failed unpackaged files
Summary: OpenIPMI rawhide build failed unpackaged files
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: OpenIPMI
Version: rawhide
Hardware: Unspecified
OS: Linux
unspecified
medium
Target Milestone: ---
Assignee: Jaromír Cápík
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1077922 (view as bug list)
Depends On: 1079635
Blocks: F-ExcludeArch-ppc64le, PPC64LETracker
TreeView+ depends on / blocked
 
Reported: 2014-03-12 15:32 UTC by Michel Normand
Modified: 2016-02-01 01:59 UTC (History)
7 users (show)

Fixed In Version: OpenIPMI-2.0.21-2.fc21
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-13 18:10:35 UTC


Attachments (Terms of Use)

Description Michel Normand 2014-03-12 15:32:48 UTC
Description of problem:
Trying to build OpenIMPI package on ppc64le


Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1. fedpkg clone -a OpenIMPI
2. cd OpenIMPI
3. fedpkg mockbuild

Actual results:
...
Checking for unpackaged file(s): /usr/lib/rpm/check-files /builddir/build/BUILDROOT/OpenIPMI-2.0.21-1.fc21.ppc64le
RPM build errors:
error: Installed (but unpackaged) file(s) found:
   /etc/ipmi/ipmisim1.emu
   /etc/ipmi/lan.conf
   /usr/bin/ipmi_sim
   /usr/bin/sdrcomp
   /usr/share/man/man1/ipmi_sim.1.gz
   /usr/share/man/man5/ipmi_lan.5.gz
   /usr/share/man/man5/ipmi_sim_cmd.5.gz
    Installed (but unpackaged) file(s) found:
   /etc/ipmi/ipmisim1.emu
   /etc/ipmi/lan.conf
   /usr/bin/ipmi_sim
   /usr/bin/sdrcomp
   /usr/share/man/man1/ipmi_sim.1.gz
   /usr/share/man/man5/ipmi_lan.5.gz
   /usr/share/man/man5/ipmi_sim_cmd.5.gz
Child return code was: 1

Comment 1 Menanteau Guy 2014-03-21 10:41:55 UTC
fot info, I built OpenIMPI on ppc64le using following spec patch:

--- OpenIPMI.spec.ori
+++ OpenIPMI.spec
@@ -235,9 +235,16 @@ fi

 %files lanserv
 %defattr(-,root,root)
+%config(noreplace) %{_sysconfdir}/ipmi/ipmisim1.emu
+%config(noreplace) %{_sysconfdir}/ipmi/lan.conf
 %{_bindir}/ipmilan
+%{_bindir}/ipmi_sim
+%{_bindir}/sdrcomp
 %{_libdir}/libIPMIlanserv.so.*
 %doc %{_mandir}/man8/ipmilan.8*
+%doc %{_mandir}/man1/ipmi_sim.1*
+%doc %{_mandir}/man5/ipmi_lan.5*
+%doc %{_mandir}/man5/ipmi_sim_cmd.5*

 %files modalias
 %config(noreplace) %{_sysconfdir}/modprobe.d/OpenIPMI.conf

Comment 2 Ville Skyttä 2014-03-22 10:16:18 UTC
*** Bug 1077922 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.