Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1075665 - dwh installation failed in av2
Summary: dwh installation failed in av2
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: 3.4.0
Assignee: Yaniv Lavi
QA Contact: Barak Dagan
URL:
Whiteboard: infra
Depends On:
Blocks: 1057239
TreeView+ depends on / blocked
 
Reported: 2014-03-12 14:39 UTC by Petr Beňas
Modified: 2016-02-10 19:38 UTC (History)
9 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-17 09:42:54 UTC
oVirt Team: Infra


Attachments (Terms of Use)

Description Petr Beňas 2014-03-12 14:39:05 UTC
Description of problem:
it looks like ovirt package was not properly renamed to rhevm

Version-Release number of selected component (if applicable):
av2


Actual results:
[root@pb-rh34 ~]# rhevm-setup
[ INFO  ] Stage: Initializing
[ INFO  ] Stage: Environment setup
          Configuration files: ['/etc/ovirt-engine-setup.conf.d/10-packaging-reports.conf', '/etc/ovirt-engine-setup.conf.d/10-packaging.conf', '/etc/ovirt-engine-setup.conf.d/20-setup-ovirt-post.conf']
          Log file: /var/log/ovirt-engine/setup/ovirt-engine-setup-20140312152803.log
          Version: otopi-1.2.0_master (otopi-1.2.0-0.0.master.el6_5)
[ INFO  ] Stage: Environment packages setup
[ INFO  ] Stage: Programs detection
[ INFO  ] Stage: Environment setup
[ INFO  ] Stage: Environment customization
         
          --== PRODUCT OPTIONS ==--
         
          Install Data Warehouse on this host (Yes, No) [Yes]: Yes
          Install Reports on this host (Yes, No) [Yes]: Yes
         
          --== PACKAGES ==--
         
[ INFO  ] Checking for product updates...
[ ERROR ] Yum: Cannot queue package ovirt-engine-dwh: No package(s) available to install
[ INFO  ] Yum: Performing yum transaction rollback
[ ERROR ] Failed to execute stage 'Environment customization': No package(s) available to install
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20140312152803.log
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed
[root@pb-rh34 ~]# yum list "*reports*"
Loaded plugins: product-id, rhnplugin, security, subscription-manager, versionlock
This system is not registered to Red Hat Subscription Management. You can use subscription-manager to register.
This system is receiving updates from RHN Classic or RHN Satellite.
Installed Packages
jasperreports-server-pro.noarch          5.5.0-8.el6ev                                   @rhevm34                    
rhevm-reports.noarch                     3.4.0-0.4.master.20140226133324.el6ev           @rhevm34                    
rhevm-reports-setup.noarch               3.4.0-0.4.master.20140226133324.el6ev           @rhevm34                    
Available Packages
ocsinventory-reports.noarch              1.3.3-5.el6                                     epel                        
rhevm-reports-dwh.noarch                 3.0.8-2                                         rhel-x86_64-server-6-rhevm-3
rhevm-reports-server.noarch              3.0.2-3                                         rhel-x86_64-server-6-rhevm-3

Comment 1 Yaniv Lavi 2014-03-12 14:46:14 UTC
Use the workaround in the dup.


Yaniv

*** This bug has been marked as a duplicate of bug 1065730 ***

Comment 2 Petr Beňas 2014-03-12 15:22:32 UTC
(In reply to Yaniv Dary from comment #1)
> Use the workaround in the dup.
If you mean https://bugzilla.redhat.com/show_bug.cgi?id=1065730#c2 , I'm still unable to install reports with it. 

          Please confirm installation settings (OK, Cancel) [OK]: OK
[ INFO  ] Cleaning async tasks and compensations
[ INFO  ] Checking the Engine database consistency
[ INFO  ] Stage: Transaction setup
[ INFO  ] Stopping engine service
[ INFO  ] Stopping websocket-proxy service
[ INFO  ] Stage: Misc configuration
[ INFO  ] Stage: Package installation
[ INFO  ] Stage: Misc configuration
[ INFO  ] Creating PostgreSQL 'ovirt_engine_history' database
[ INFO  ] Configuring PostgreSQL
[ INFO  ] Creating PostgreSQL 'ovirt_engine_reports' database
[ INFO  ] Configuring PostgreSQL
[ INFO  ] Backing up database localhost:engine to '/var/lib/ovirt-engine/backups/engine-20140312161544._oNgjx.sql'.
[ INFO  ] Updating Engine database schema
[ INFO  ] Creating DWH database schema
[ ERROR ] Failed to execute stage 'Misc configuration': [Errno 2] No such file or directory
[ INFO  ] Rolling back database schema
[ INFO  ] Clearing Engine database engine
[ INFO  ] Restoring Engine database engine
[ INFO  ] Rolling back DWH database schema
[ INFO  ] Clearing DWH database ovirt_engine_history
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20140312161424.log
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ ERROR ] Execution of setup failed

Comment 3 Yaniv Lavi 2014-03-12 15:30:09 UTC
This is a different issue. Always attach logs and please note that you opened this bug on reports when the error was on dwh initially. 



Yaniv

Comment 6 Yaniv Lavi 2014-03-12 17:36:24 UTC
this is the error:
otopi.plugins.ovirt_engine_setup.ovirt_engine_dwh.db.connection.Plugin._customization
2014-03-12 16:39:14 DEBUG otopi.ovirt_engine_setup.database database.execute:132 Database: 'ovirt_engine_history', Statement: '
                select count(*) as count
                from information_schema.tables
                where table_schema = 'public';
            ', args: {}
2014-03-12 16:39:14 DEBUG otopi.ovirt_engine_setup.database database.execute:137 Creating own connection
2014-03-12 16:39:14 DEBUG otopi.plugins.ovirt_engine_setup.ovirt_engine_dwh.db.connection connection._customization:286 database connection failed
Traceback (most recent call last):
  File "/usr/share/ovirt-engine/setup/bin/../plugins/ovirt-engine-setup/ovirt-engine-dwh/db/connection.py", line 284, in _customization
    ] = dbovirtutils.isNewDatabase()
  File "/usr/share/ovirt-engine/setup/ovirt_engine_setup/database.py", line 452, in isNewDatabase
    transaction=False,
  File "/usr/share/ovirt-engine/setup/ovirt_engine_setup/database.py", line 159, in execute
    sslmode=sslmode,
OperationalError: FATAL:  password authentication failed for user "ovirt_engine_history"
FATAL:  password authentication failed for user "ovirt_engine_history"


AlonAny idea why it fails?


Yaniv

Comment 7 Yaniv Lavi 2014-03-12 17:39:17 UTC
The log you attached doesn't match the error you posted. Please recheck this is the correct log.



Yaniv

Comment 8 Alon Bar-Lev 2014-03-12 17:40:46 UTC
Please wait for next build, or test with 3.4.0 master.

Comment 10 Petr Beňas 2014-03-13 09:01:58 UTC
(In reply to Alon Bar-Lev from comment #8)
> Please wait for next build, or test with 3.4.0 master.

Will there be any related patch in next build?

Comment 11 Alon Bar-Lev 2014-03-13 09:34:18 UTC
(In reply to Petr Beňas from comment #10)
> (In reply to Alon Bar-Lev from comment #8)
> > Please wait for next build, or test with 3.4.0 master.
> 
> Will there be any related patch in next build?

There were significant changes in setup database access. If there are other issues we will fix on top.

Comment 12 Yaniv Lavi 2014-03-16 14:01:21 UTC
Please test upgrade using av3 (run setup twice).
Closing for now and reopen if you hit this after this test.


Yaniv

Comment 13 Petr Beňas 2014-03-17 09:24:46 UTC
I was able to upgrade to av3 from av2 with using the --offline parameter and saying "No" to reports and dwh installation. 

Then with re-running the rhevm-setup, I'm getting following yum error (not very well formatted thought). The error is gone when "--offline" parameter is used, but the setup does not ask for installing dwh and reports. 

Don't consider the difficult upgrade from av2 to av3 a problem, since it won't be performed by customers, but I see a real problem here in the failure to install the dwh and reports. 

If you claim it works for you, please provide exact steps how you managed to make it working. 

[ INFO  ] Checking for product updates...
[ ERROR ] Yum: [u'rhevm-jboss-deps-3.0.8_0001-1.el6_3.x86_64 requires jbossas', 'rhevm-setup-plugin-ovirt-engine conflicts with rhevm-3.0.8_0001-1.el6_3.x86_64', u'rhevm-jboss-deps-3.0.8_0001-1.el6_3.x86_64 requires jbossas-messaging', u'rhevm-jboss-deps-3.0.8_0001-1.el6_3.x86_64 requires jakarta-commons-discovery >= 1:0.4-7', u'rhevm-jboss-deps-3.0.8_0001-1.el6_3.x86_64 requires jbossas-ws-cxf']
[ INFO  ] Yum: Performing yum transaction rollback

Comment 14 Yaniv Lavi 2014-03-17 09:27:37 UTC
(In reply to Petr Beňas from comment #13)
> I was able to upgrade to av3 from av2 with using the --offline parameter and
> saying "No" to reports and dwh installation. 
> 
> Then with re-running the rhevm-setup, I'm getting following yum error (not
> very well formatted thought). The error is gone when "--offline" parameter
> is used, but the setup does not ask for installing dwh and reports. 
> 
> Don't consider the difficult upgrade from av2 to av3 a problem, since it
> won't be performed by customers, but I see a real problem here in the
> failure to install the dwh and reports. 
> 
> If you claim it works for you, please provide exact steps how you managed to
> make it working. 
> 
> [ INFO  ] Checking for product updates...
> [ ERROR ] Yum: [u'rhevm-jboss-deps-3.0.8_0001-1.el6_3.x86_64 requires
> jbossas', 'rhevm-setup-plugin-ovirt-engine conflicts with
> rhevm-3.0.8_0001-1.el6_3.x86_64',
> u'rhevm-jboss-deps-3.0.8_0001-1.el6_3.x86_64 requires jbossas-messaging',
> u'rhevm-jboss-deps-3.0.8_0001-1.el6_3.x86_64 requires
> jakarta-commons-discovery >= 1:0.4-7',
> u'rhevm-jboss-deps-3.0.8_0001-1.el6_3.x86_64 requires jbossas-ws-cxf']
> [ INFO  ] Yum: Performing yum transaction rollback

This is not related to history and reports and not to the topic. Open a separate bug.


Yaniv


Note You need to log in before you can comment on or make changes to this bug.