Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1075533 - Installer claims some packages are not installed although they are
Summary: Installer claims some packages are not installed although they are
Keywords:
Status: CLOSED DUPLICATE of bug 1416447
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Installer
Version: 560
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
Assignee: Jan Dobes
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2014-03-12 10:46 UTC by Jiří Mikulka
Modified: 2017-03-06 09:55 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2017-03-06 09:55:04 UTC


Attachments (Terms of Use)

Description Jiří Mikulka 2014-03-12 10:46:46 UTC
Description of problem:
Satellite 5.6.0 installer on s390x claims that some packages are not installed although these packages are installed.

Version-Release number of selected component (if applicable):
Satellite 5.6.0 (Satellite-5.6.0-RHEL6-re20130927.0) @ s390x @ EmbPostgreSQL

How reproducible:
always

Steps to Reproduce:
1. install Satellite 5.6.0 @ s390x
2. check the output + /var/log/rhn/rhn_installation.log
3. check "not-installed" packages by `rpm -q ...`

Actual results:
[...]
* Checking for uninstalled prerequisites.
There are some packages from Red Hat Enterprise Linux that are not part
of the @base group that Satellite will require to be installed on this
system. The installer will try resolve the dependencies automatically.
* Installing RHN packages.
Warning: yum did not install the following packages:
        antlr
        jakarta-commons-codec
        jakarta-commons-el
        jakarta-commons-lang
        jakarta-oro
        jdom
        mtools
        objectweb-asm
        perl-Class-MethodMaker
        perl-Class-Singleton
        perl-DateTime
        perl-List-MoreUtils
        perl-Params-Validate
        perl-TermReadKey
        syslinux
        xalan-j2
* Now running spacewalk-setup.
[...]

$ rpm -q ...
antlr-2.7.7-7.ep5.el6.noarch
jakarta-commons-codec-1.3-11.7.el6.s390x
jakarta-commons-el-1.0-19.2.1.1.ep5.el6.noarch
jakarta-commons-lang-2.4-1.1.el6.noarch
jakarta-oro-2.0.8-6.6.el6.s390x
jdom-1.1.1-1.el6.noarch
package mtools is not installed
objectweb-asm-3.2-2.1.el6.noarch
perl-Class-MethodMaker-2.16-4.el6.s390x
perl-Class-Singleton-1.4-6.el6.noarch
perl-DateTime-0.5300-1.el6.s390x
perl-List-MoreUtils-0.22-10.el6.s390x
perl-Params-Validate-0.92-3.el6.s390x
perl-TermReadKey-2.30-13.el6.s390x
package syslinux is not installed
xalan-j2-2.7.0-9.8.el6.noarch

Expected results:
All needed packages are installed and the installer knows about it.

Additional info:
only mtools and syslinux weren't installed

Comment 4 Tomas Lestach 2017-03-06 09:55:04 UTC

*** This bug has been marked as a duplicate of bug 1416447 ***


Note You need to log in before you can comment on or make changes to this bug.