Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1074418 - Review Request: nodejs-superagent - A small, progressive client-side HTTP request library
Summary: Review Request: nodejs-superagent - A small, progressive client-side HTTP req...
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: Package Review
Version: rawhide
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mukundan Ragavan
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On: 1074412 1074414 1074416
Blocks: nodejs-reviews 1074420
TreeView+ depends on / blocked
 
Reported: 2014-03-10 07:27 UTC by Jamie Nguyen
Modified: 2014-03-18 10:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-18 10:49:45 UTC
nonamedotc: fedora-review+
gwync: fedora-cvs+


Attachments (Terms of Use)

Description Jamie Nguyen 2014-03-10 07:27:31 UTC
Spec URL: http://jamielinux.fedorapeople.org/supertest/nodejs-superagent.spec
SRPM URL: http://jamielinux.fedorapeople.org/supertest/SRPMS/nodejs-superagent-0.17.0-1.fc21.src.rpm
Fedora Account System Username: jamielinux

Description:
A small, progressive client-side HTTP request library crafted for flexibility, readability, and a low learning curve.

Comment 1 Jamie Nguyen 2014-03-10 07:36:18 UTC
All tests pass when using npm installed express@3.5.0.

Comment 2 Mukundan Ragavan 2014-03-10 20:20:25 UTC
I guess, I should wait to review this package because of 1074411?

Comment 3 Jamie Nguyen 2014-03-10 20:22:48 UTC
(In reply to Mukundan Ragavan from comment #2)
> I guess, I should wait to review this package because of 1074411?

Hi! Generally a review request should only be tackled once the list of bugs in the "Depends On" field have been addressed:

#1074412 #1074414 #1074416

With regards to #1074411 I will be patching out the dependency on this module.

Comment 4 Mukundan Ragavan 2014-03-10 20:28:24 UTC
Sorry - I guess I was not clear. I saw Tom's review (+) for 1074412 and 1074416. I am looking at 1074414 now.

That's why I was asking! :)

Comment 5 Jamie Nguyen 2014-03-10 20:32:50 UTC
Oh, sorry, my bad! I hadn't spotted that Tom had already approved them :)

Comment 6 Jamie Nguyen 2014-03-10 20:42:31 UTC
Spec URL: http://jamielinux.fedorapeople.org/supertest/nodejs-superagent.spec
SRPM URL: http://jamielinux.fedorapeople.org/supertest/SRPMS/nodejs-superagent-0.17.0-2.fc21.src.rpm

* Mon Mar 10 2014 Jamie Nguyen <jamielinux@fedoraproject.org> - 0.17.0-2
- remove dependency on npm(extend)

Comment 7 Mukundan Ragavan 2014-03-15 18:12:12 UTC
(In reply to Jamie Nguyen from comment #6)
> Spec URL: http://jamielinux.fedorapeople.org/supertest/nodejs-superagent.spec
> SRPM URL:
> http://jamielinux.fedorapeople.org/supertest/SRPMS/nodejs-superagent-0.17.0-
> 2.fc21.src.rpm
> 
> * Mon Mar 10 2014 Jamie Nguyen <jamielinux@fedoraproject.org> - 0.17.0-2
> - remove dependency on npm(extend)

I cannot build this package in mock because of npm(extend) dependency.

$ mock -r fedora-rawhide-x86_64 rebuild nodejs-superagent-0.17.0-2.fc21.src.rpm
INFO: mock.py version 1.1.36 starting...
Start: init plugins
INFO: selinux enabled
Finish: init plugins
Start: run
INFO: Start(nodejs-superagent-0.17.0-2.fc21.src.rpm)  Config(fedora-rawhide-x86_64)
Start: lock buildroot
Start: clean chroot
INFO: chroot (/var/lib/mock/fedora-rawhide-x86_64) unlocked and deleted
Finish: clean chroot
Finish: lock buildroot
Start: chroot init
Start: lock buildroot
Mock Version: 1.1.36
INFO: Mock Version: 1.1.36
INFO: calling preinit hooks
INFO: enabled root cache
Start: unpacking root cache
Finish: unpacking root cache
INFO: enabled yum cache
Start: cleaning yum metadata
Finish: cleaning yum metadata
INFO: enabled ccache
Start: device setup
Finish: device setup
Start: yum update
Start: Outputting list of available packages
Finish: Outputting list of available packages
Finish: yum update
Finish: lock buildroot
Finish: chroot init
INFO: Installed packages:
Start: build phase for nodejs-superagent-0.17.0-2.fc21.src.rpm
Start: device setup
Finish: device setup
Start: build setup for nodejs-superagent-0.17.0-2.fc21.src.rpm
ERROR: Exception(nodejs-superagent-0.17.0-2.fc21.src.rpm) Config(fedora-rawhide-x86_64) 2 minutes 13 seconds
INFO: Results and/or logs in: /var/lib/mock/fedora-rawhide-x86_64/result
ERROR: Command failed: 
 # ['/usr/bin/yum-builddep', '--installroot', '/var/lib/mock/fedora-rawhide-x86_64/root/', '--releasever', '21', '/var/lib/mock/fedora-rawhide-x86_64/root///builddir/build/SRPMS/nodejs-superagent-0.17.0-2.fc21.src.rpm', '--setopt=tsflags=nocontexts']
Getting requirements for nodejs-superagent-0.17.0-2.fc21.src
 --> nodejs-packaging-4-1.fc20.noarch
 --> mocha-1.12.0-1.fc20.noarch
 --> nodejs-better-assert-1.0.0-3.fc20.noarch
 --> nodejs-component-emitter-1.1.2-1.fc21.noarch
 --> nodejs-cookiejar-1.3.1-1.fc21.noarch
 --> nodejs-debug-0.7.4-2.fc21.noarch
 --> nodejs-express-3.3.5-1.fc21.noarch
 --> nodejs-formidable-1.0.14-3.fc20.noarch
 --> nodejs-methods-0.0.1-4.fc20.noarch
 --> nodejs-mime-1.2.11-1.fc21.noarch
 --> nodejs-qs-0.6.6-1.fc21.noarch
 --> nodejs-reduce-component-1.0.1-1.fc21.noarch
 --> nodejs-should-3.1.3-1.fc21.noarch
Error: No Package found for npm(extend)

Comment 8 Jamie Nguyen 2014-03-15 18:16:22 UTC
Oops, sorry! I patched out the use of extend, but forgot to remove BR: npm(extend).

Spec URL: http://jamielinux.fedorapeople.org/supertest/nodejs-superagent.spec
SRPM URL: http://jamielinux.fedorapeople.org/supertest/SRPMS/nodejs-superagent-0.17.0-2.fc21.src.rpm

* Sat Mar 15 2014 Jamie Nguyen <jamielinux@fedoraproject.org> - 0.17.0-3
- remove BR: npm(extend)

Comment 10 Jamie Nguyen 2014-03-15 18:19:22 UTC
Spec URL: http://jamielinux.fedorapeople.org/supertest/nodejs-superagent.spec
SRPM URL: http://jamielinux.fedorapeople.org/supertest/SRPMS/nodejs-superagent-0.17.0-4.fc21.src.rpm

* Sat Mar 15 2014 Jamie Nguyen <jamielinux@fedoraproject.org> - 0.17.0-4
- temporarily disable tests


(Broken deps on rawhide.)

Comment 11 Mukundan Ragavan 2014-03-15 18:35:13 UTC
Some issues (broken deps?) to be taken care of. Detailed review below - 


Package Review
==============

Legend:
[x] = Pass, [!] = Fail, [-] = Not applicable, [?] = Not evaluated
[ ] = Manual review needed


Issues:
=======
- Package installs properly.
  Note: Installation errors (see attachment)
  See: https://fedoraproject.org/wiki/Packaging:Guidelines


===== MUST items =====

Generic:
[x]: Package is licensed with an open-source compatible license and meets
     other legal requirements as defined in the legal section of Packaging
     Guidelines.
[x]: License field in the package spec file matches the actual license.
     Note: Checking patched sources after %prep for licenses. No licenses
     found. Please check the source files for licenses manually.
[x]: Package contains no bundled libraries without FPC exception.
[!]: Changelog in prescribed format.

---> Most recent changes are not documented.

[x]: Sources contain only permissible code or content.
[-]: Package contains desktop file if it is a GUI application.
[-]: Development files must be in a -devel package
[x]: Package uses nothing in %doc for runtime.
[x]: Package consistently uses macros (instead of hard-coded directory names).
[x]: Package is named according to the Package Naming Guidelines.
[x]: Package does not generate any conflict.
[x]: Package obeys FHS, except libexecdir and /usr/target.
[-]: If the package is a rename of another package, proper Obsoletes and
     Provides are present.
[x]: Requires correct, justified where necessary.
[x]: Spec file is legible and written in American English.
[-]: Package contains systemd file(s) if in need.
[x]: Package is not known to require an ExcludeArch tag.
[-]: Large documentation must go in a -doc subpackage. Large could be size
     (~1MB) or number of files.
     Note: Documentation size is 30720 bytes in 6 files.
[!]: Package complies to the Packaging Guidelines
[x]: Package successfully compiles and builds into binary rpms on at least one
     supported primary architecture.
[x]: Rpmlint is run on all rpms the build produces.
     Note: There are rpmlint messages (see attachment).
[x]: If (and only if) the source package includes the text of the license(s)
     in its own file, then that file, containing the text of the license(s)
     for the package is included in %doc.
[x]: Package requires other packages for directories it uses.
[x]: Package must own all directories that it creates.
[x]: Package does not own files or directories owned by other packages.
[x]: All build dependencies are listed in BuildRequires, except for any that
     are listed in the exceptions section of Packaging Guidelines.
[x]: Package uses either %{buildroot} or $RPM_BUILD_ROOT
[x]: Package does not run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
     beginning of %install.
[x]: Macros in Summary, %description expandable at SRPM build time.
[x]: Package does not contain duplicates in %files.
[x]: Permissions on files are set properly.
[x]: Package use %makeinstall only when make install' ' DESTDIR=... doesn't
     work.
[x]: Package is named using only allowed ASCII characters.
[x]: Package do not use a name that already exist
[x]: Package is not relocatable.
[x]: Sources used to build the package match the upstream source, as provided
     in the spec URL.
[x]: Spec file name must match the spec package %{name}, in the format
     %{name}.spec.
[x]: File names are valid UTF-8.
[x]: Packages must not store files under /srv, /opt or /usr/local

===== SHOULD items =====

Generic:
[x]: If the source package does not include license text(s) as a separate file
     from upstream, the packager SHOULD query upstream to include it.
[x]: Final provides and requires are sane (see attachments).
[?]: Package functions as described.
[x]: Latest version is packaged.
[x]: Package does not include license text files separate from upstream.
[-]: Patches link to upstream bugs/comments/lists or are otherwise justified.
[x]: SourceX tarball generation or download is documented.
     Note: Package contains tarball without URL, check comments
[x]: Description and summary sections in the package spec file contains
     translations for supported Non-English languages, if available.
[?]: %check is present and all tests pass.

---> Temporarily disabled.

[x]: Packages should try to preserve timestamps of original installed files.
[x]: Packager, Vendor, PreReq, Copyright tags should not be in spec file
[x]: Sources can be downloaded from URI in Source: tag
[x]: Reviewer should test that the package builds in mock.
[x]: Buildroot is not present
[x]: Package has no %clean section with rm -rf %{buildroot} (or
     $RPM_BUILD_ROOT)
[x]: Dist tag is present (not strictly required in GL).
[x]: No file requires outside of /etc, /bin, /sbin, /usr/bin, /usr/sbin.
[x]: SourceX is a working URL.
[x]: Package should compile and build into binary rpms on all supported
     architectures.
[x]: Spec use %global instead of %define unless justified.

===== EXTRA items =====

Generic:
[!]: Rpmlint is run on all installed packages.
     Note: Mock build failed
     See: http://fedoraproject.org/wiki/Packaging/Guidelines#rpmlint
[x]: Spec file according to URL is the same as in SRPM.


Installation errors
-------------------
INFO: mock.py version 1.1.36 starting...
Start: init plugins
INFO: selinux enabled
Finish: init plugins
Start: run
Mock Version: 1.1.36
INFO: Mock Version: 1.1.36
Start: lock buildroot
INFO: installing package(s): /home/mukundan/personal/pkgs/reviews/1074418-nodejs-superagent/results/nodejs-superagent-0.17.0-4.fc21.noarch.rpm
ERROR: Command failed: 
 # ['/usr/bin/yum', '--installroot', '/var/lib/mock/fedora-rawhide-x86_64/root/', '--releasever', '21', 'install', '/home/mukundan/personal/pkgs/reviews/1074418-nodejs-superagent/results/nodejs-superagent-0.17.0-4.fc21.noarch.rpm', '--setopt=tsflags=nocontexts']
Error: Package: nodejs-superagent-0.17.0-4.fc21.noarch (/nodejs-superagent-0.17.0-4.fc21.noarch)
           Requires: npm(methods) >= 0.1
           Installing: nodejs-methods-0.0.1-4.fc20.noarch (fedora)
               npm(methods) = 0.0.1
 You could try using --skip-broken to work around the problem
 You could try running: rpm -Va --nofiles --nodigest



Rpmlint
-------
Checking: nodejs-superagent-0.17.0-4.fc21.noarch.rpm
          nodejs-superagent-0.17.0-4.fc21.src.rpm
nodejs-superagent.noarch: W: only-non-binary-in-usr-lib
nodejs-superagent.noarch: W: dangling-symlink /usr/lib/node_modules/superagent/node_modules/component-emitter /usr/lib/node_modules/component-emitter
nodejs-superagent.noarch: W: dangling-symlink /usr/lib/node_modules/superagent/node_modules/debug /usr/lib/node_modules/debug
nodejs-superagent.noarch: W: dangling-symlink /usr/lib/node_modules/superagent/node_modules/methods /usr/lib/node_modules/methods
nodejs-superagent.noarch: W: dangling-symlink /usr/lib/node_modules/superagent/node_modules/mime /usr/lib/node_modules/mime
nodejs-superagent.noarch: W: dangling-symlink /usr/lib/node_modules/superagent/node_modules/qs /usr/lib/node_modules/qs
nodejs-superagent.noarch: W: dangling-symlink /usr/lib/node_modules/superagent/node_modules/cookiejar /usr/lib/node_modules/cookiejar
nodejs-superagent.noarch: W: dangling-symlink /usr/lib/node_modules/superagent/node_modules/formidable /usr/lib/node_modules/formidable
nodejs-superagent.noarch: W: dangling-symlink /usr/lib/node_modules/superagent/node_modules/reduce-component /usr/lib/node_modules/reduce-component

--->

$ rpmlint -I dangling-symlink
dangling-symlink:
The target of the symbolic link does not exist within this package or its file
based dependencies.  Verify spelling of the link target and that the target is
included in a package in this package's dependency chain.

nodejs-superagent.src: W: invalid-url Source1: tests-0.17.0.tar.bz2
2 packages and 0 specfiles checked; 0 errors, 10 warnings.




Requires
--------
nodejs-superagent (rpmlib, GLIBC filtered):
    nodejs(engine)
    npm(component-emitter)
    npm(cookiejar)
    npm(debug)
    npm(formidable)
    npm(methods)
    npm(mime)
    npm(qs)
    npm(reduce-component)



Provides
--------
nodejs-superagent:
    nodejs-superagent
    npm(superagent)



Source checksums
----------------
http://registry.npmjs.org/superagent/-/superagent-0.17.0.tgz :
  CHECKSUM(SHA256) this package     : 60dc2109e39025a6539b4f5bb3b6aefef9b017ce01ae32c066c70bcbea286a88
  CHECKSUM(SHA256) upstream package : 60dc2109e39025a6539b4f5bb3b6aefef9b017ce01ae32c066c70bcbea286a88


Generated by fedora-review 0.5.1 (bb9bf27) last change: 2013-12-13
Command line :/usr/bin/fedora-review -m fedora-rawhide-x86_64 -b 1074418
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, Shell-api
Disabled plugins: Java, C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, PHP, Ruby
Disabled flags: EXARCH, EPEL5, BATCH, DISTTAG

Comment 12 Mukundan Ragavan 2014-03-15 18:37:00 UTC
[x]: Changelog in prescribed format.

This is correct. No issues. I looked at the wrong leafpad window!

Comment 13 Jamie Nguyen 2014-03-15 18:40:10 UTC
(In reply to Mukundan Ragavan from comment #11)
> Error: Package: nodejs-superagent-0.17.0-4.fc21.noarch
> (/nodejs-superagent-0.17.0-4.fc21.noarch)
>            Requires: npm(methods) >= 0.1
>            Installing: nodejs-methods-0.0.1-4.fc20.noarch (fedora)
>                npm(methods) = 0.0.1

nodejs-methods-0.1.0 is already built for rawhide, so once the mirrors catch up then this won't be a problem.
http://koji.fedoraproject.org/koji/packageinfo?packageID=15568


> $ rpmlint -I dangling-symlink
> dangling-symlink:
> 
> nodejs-superagent.src: W: invalid-url Source1: tests-0.17.0.tar.bz2
> 2 packages and 0 specfiles checked; 0 errors, 10 warnings.

This happens for all Node.js packages and can safely be ignored.

Comment 14 Mukundan Ragavan 2014-03-15 18:42:48 UTC
I will check the package installation again a later today and approve this package

Once this is go, I will finish the review of 1074420 also.

Comment 15 Mukundan Ragavan 2014-03-16 01:46:12 UTC
The package installs properly. I got tired of waiting for mirrors to sync. I just installed nodejs-methods manually and tested it.

Package installs without problems.


# rpm -qa nodejs* | sort
nodejs-0.10.26-1.fc21.x86_64
nodejs-component-emitter-1.1.2-1.fc21.noarch
nodejs-cookiejar-1.3.1-1.fc21.noarch
nodejs-debug-0.7.4-2.fc21.noarch
nodejs-formidable-1.0.14-3.fc20.noarch
nodejs-methods-0.1.0-1.fc21.noarch
nodejs-mime-1.2.11-1.fc21.noarch
nodejs-qs-0.6.6-1.fc21.noarch
nodejs-reduce-component-1.0.1-1.fc21.noarch
nodejs-superagent-0.17.0-4.fc21.noarch


Upon further reading (other reviews basically) and based on c#13, dangling-symlink is not an issue.

Please add the tests back when the dependencies are resolved. Package APPROVED.

Comment 16 Jamie Nguyen 2014-03-16 08:18:33 UTC
Thanks very much for the review Mukundan! :-)

Comment 17 Jamie Nguyen 2014-03-16 08:19:16 UTC
New Package SCM Request
=======================
Package Name: nodejs-superagent
Short Description: A small, progressive client-side HTTP request library
Owners: jamielinux patches
Branches: f19 f20 el6
InitialCC:

Comment 18 Gwyn Ciesla 2014-03-17 11:52:05 UTC
Git done (by process-git-requests).


Note You need to log in before you can comment on or make changes to this bug.