Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1074062 - syncErrata clones wrong packages, messes up cloned channel
Summary: syncErrata clones wrong packages, messes up cloned channel
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: API
Version: 560
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Stephen Herr
QA Contact: Dimitar Yordanov
URL:
Whiteboard:
Depends On: 1073652
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2014-03-07 20:22 UTC by Stephen Herr
Modified: 2014-03-13 08:19 UTC (History)
4 users (show)

Fixed In Version: spacewalk-java-2.0.2-63-sat
Doc Type: Bug Fix
Doc Text:
Clone Of: 1073652
Environment:
Last Closed: 2014-03-13 08:19:24 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0290 normal SHIPPED_LIVE Red Hat Network Satellite server spacewalk-java bug fix update 2014-03-13 12:19:07 UTC

Description Stephen Herr 2014-03-07 20:22:20 UTC
+++ This bug was initially created as a clone of Bug #1073652 +++

Description of problem:
The channel.software.syncErrata API method does not work correctly. It's current behavior is:
1) Update the details of the cloned errata to match their originals (fine)
2) Clone packages into the cloned channel that are:
  a) in the original channel
  b) delivered by an erratum that has a clone

The 2b portion is the problem. The behavior should be "2b: delivered by an erratum that has a clone in this cloned channel"

If you have multiple clones of the same channel this bug can cause the wrong packages to be imported into your cloned channel. This is especially problematic since spacewalk-clone-by-date now calls this method by default.

Version-Release number of selected component (if applicable):
2.1

How reproducible:
always

Steps to Reproduce:
1. Clone a channel with all errata with spacewalk-clone-by-date
2. Clone the original channel again with spacewalk-clone-by-date, this time with only some of the errata

Actual results:
The second clone contains all the packages that the original did.

Expected results:
The second clone should contain only packages relevant to the errata it contains.

--- Additional comment from Stephen Herr on 2014-03-07 15:20:58 EST ---

Committing to Spacewalk master:
b5c81d89d6c5699c7e94778545c9f284b73349ac

Comment 5 errata-xmlrpc 2014-03-13 08:19:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0290.html


Note You need to log in before you can comment on or make changes to this bug.