Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1073989 - "data has no embedded checksum" warning when attaching new storage domain
Summary: "data has no embedded checksum" warning when attaching new storage domain
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
high
Target Milestone: ---
: 3.5.0
Assignee: Allon Mureinik
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Depends On:
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-07 15:45 UTC by akotov
Modified: 2018-12-04 17:45 UTC (History)
10 users (show)

Fixed In Version: vt1.3, 4.16.0-1.el6_5
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-11 21:10:27 UTC
oVirt Team: Storage
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0159 normal SHIPPED_LIVE vdsm 3.5.0 - bug fix and enhancement update 2015-02-12 01:35:58 UTC
oVirt gerrit 27528 master MERGED persistentDict: Do not warn about missing checksum when metadata is empty Never

Description akotov 2014-03-07 15:45:08 UTC
Description of problem:

Thread-19::WARNING::2014-03-07 00:29:52,994::persistentDict::256::Storage.PersistentDict::(refresh) data has no embedded checksum - trust it as it is

Version-Release number of selected component (if applicable):

3.2 3.3 rhev-next

How reproducible:

Attaching new storage domain

Steps to Reproduce:
1. Attach new storage domain

Actual results:

Thread-33::WARNING::2014-02-14 10:44:03,784::persistentDict::256::Storage.PersistentDict::(refresh) data has no embedded checksum - trust it as it is

Thread-33::DEBUG::2014-02-14 10:44:03,785::persistentDict::299::Storage.PersistentDict::(flush) about to write lines (VGTagMetadataRW)=['CLASS=Data', 'DESCRIPTION=test-fc-1', 'IOOPTIMEOUTSEC=10', 'LEASERETRIES=3', 'LEASETIMESEC=60', 'LOCKPOLICY=', 'LOCKRENEWALINTERVALSEC=5', 'LOGBLKSIZE=512', 'PHYBLKSIZE=4096', 'POOL_UUID=', 'PV0=pv:360a9800042473342783f44367156686c,uuid:K9Fd5y-eBVW-vWHo-F78s-pOf5-Z17I-dL47BD,pestart:0,pecount:797,mapoffset:0', 'ROLE=Regular', 'SDUUID=ea9d7ddd-7d66-4280-b591-d964edde5eb3', 'TYPE=FCP', 'VERSION=3', 'VGUUID=BCngzJ-sVHg-guWR-tADg-Bv04-QejO-aGurL8', '_SHA_CKSUM=84d96d34b2f063b0da0b1d44d149719ae7d8c263']



Expected results:

We need is a class method that creates the initial metadata. Then we can assume that empty metadata is always invalid.

Additional info:

Upstream link:

https://github.com/oVirt/vdsm/blob/40a46f1659ef9185f4916ef81cfe00c6d4b85846/vdsm/storage/persistentDict.py#L251

Comment 1 Allon Mureinik 2014-04-08 10:51:18 UTC
Xavi, please review this case and analyze what should be done here (and then proceed to doing it :-))

Comment 3 Raz Tamir 2014-08-12 08:56:10 UTC
Verified - followed the steps to reproduce
ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch

Output:
Thread-41::DEBUG::2014-08-12 11:49:06,339::persistentDict::234::Storage.PersistentDict::(refresh) read lines (VGTagMetadataRW)=['LEASETIMESEC=60', 'IOOPTIMEOUTSEC=10', 'CLASS=Data', u'PV0=p
v:36006016012823000d867a2d139dce311,uuid:1rNj9T-WtAa-AHoX-9r1K-Xskm-UXn3-JOOsoP,pestart:0,pecount:317,mapoffset:0', 'TYPE=ISCSI', 'DESCRIPTION=ISCSI', 'LOGBLKSIZE=512', 'SDUUID=f9c3ed46-c11
0-43f2-9e64-776bd64f09d6', 'LEASERETRIES=3', 'VGUUID=J9WY3O-zfgd-vMJi-cBWi-a581-HiC4-mP6LF5', 'LOCKRENEWALINTERVALSEC=5', 'ROLE=Regular', 'PHYBLKSIZE=512', '_SHA_CKSUM=09a2d6f06a5c9bc86195d
1aae5f07f46e50edd04', 'POOL_UUID=', 'LOCKPOLICY=', 'VERSION=3']
Thread-41::DEBUG::2014-08-12 11:49:06,339::persistentDict::167::Storage.PersistentDict::(transaction) Starting transaction
Thread-41::DEBUG::2014-08-12 11:49:06,340::persistentDict::173::Storage.PersistentDict::(transaction) Flushing changes
Thread-41::DEBUG::2014-08-12 11:49:06,340::persistentDict::305::Storage.PersistentDict::(flush) about to write lines (VGTagMetadataRW)=['CLASS=Data', 'DESCRIPTION=ISCSI', 'IOOPTIMEOUTSEC=10
', 'LEASERETRIES=3', 'LEASETIMESEC=60', 'LOCKPOLICY=', 'LOCKRENEWALINTERVALSEC=5', 'LOGBLKSIZE=512', 'PHYBLKSIZE=512', 'POOL_UUID=f603339e-c4aa-474c-bb83-df768af662c8', u'PV0=pv:36006016012
823000d867a2d139dce311,uuid:1rNj9T-WtAa-AHoX-9r1K-Xskm-UXn3-JOOsoP,pestart:0,pecount:317,mapoffset:0', 'ROLE=Regular', 'SDUUID=f9c3ed46-c110-43f2-9e64-776bd64f09d6', 'TYPE=ISCSI', 'VERSION=
3', 'VGUUID=J9WY3O-zfgd-vMJi-cBWi-a581-HiC4-mP6LF5', '_SHA_CKSUM=833c21f34b5042499590dcee4213ac70377e9bae']

Comment 5 errata-xmlrpc 2015-02-11 21:10:27 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0159.html


Note You need to log in before you can comment on or make changes to this bug.