Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1073961 - [RFE] Support for performing sysprep operations from the RHEV API
Summary: [RFE] Support for performing sysprep operations from the RHEV API
Keywords:
Status: CLOSED DUPLICATE of bug 1080002
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: RFEs
Version: 3.3.0
Hardware: All
OS: Linux
high
high
Target Milestone: ---
: 3.5.0
Assignee: Shahar Havivi
QA Contact: meital avital
URL:
Whiteboard: virt
Depends On: 1080002
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-07 15:03 UTC by Allan Voss
Modified: 2018-12-05 17:37 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-05-13 10:26:58 UTC
oVirt Team: ---
Target Upstream Version:
sherold: Triaged+


Attachments (Terms of Use)

Description Allan Voss 2014-03-07 15:03:13 UTC
- What is the nature and description of the request?

Support for the performing sysprep operations such as attaching the sysprep "floppy image" from the RHEV API.

- Why does the customer need this? (List the business requirements here)

To make proper sysprep file, VM needs access to those sysprep file templates in /etc/ovirt-engine/sysprep on RHEV-M host, but and application that uses REST API does not have such access. The application runs on separate isolated host.
From the RHEV-M admin web interface there is access to the option to attach the xml file to any VM on demand using "Run once", and it will be generated from /etc/ovirt-engine/sysprep automatically. It should be possible to provide those generated xml files on demand in similar manner to any VM using RHEV REST API only.

- For each functional requirement listed in question 4, specify how Red Hat
and the customer can test to confirm the requirement is successfully
implemented.

Sysprep a VM using the RHEV REST API

Comment 2 Michal Skrivanek 2014-03-17 10:48:44 UTC
we planned to have an option to pass a custom sysprep file to be used instead of the system-wide file. Would it satisfy the requirement? It won't allow you to get the generated output as is generated in UI, but it allows you to specify and generate exactly what you want
In other words supply a custom template sysprep file.

Comment 3 Allan Voss 2014-03-18 17:36:48 UTC
As long as it's fully controllable from the API, then the customer's needs would be met.

Comment 4 Michal Skrivanek 2014-03-25 09:14:19 UTC
hopefully will be addressed by bug 1080002

Comment 6 Michal Skrivanek 2014-05-13 10:26:58 UTC
this issue has been addressed as part of the sysprep custom script feature, in 3.5.

Also when talking about API it has already been possible using the VM payload

*** This bug has been marked as a duplicate of bug 1080002 ***


Note You need to log in before you can comment on or make changes to this bug.