Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1073724 - [RFE] Add --update option to edit-node
Summary: [RFE] Add --update option to edit-node
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-node
Version: unspecified
Hardware: Unspecified
OS: Unspecified
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Fabian Deutsch
QA Contact: Virtualization Bugs
URL:
Whiteboard: node
Depends On: 1073720 rebase-ovirt-node-3.1
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-07 03:02 UTC by haiyang,dong
Modified: 2016-02-10 20:09 UTC (History)
18 users (show)

Fixed In Version:
Doc Type: Enhancement
Doc Text:
The 'edit-node --update' command can now be used to update individual packages in a Red Hat Enterprise Virtualization Hypervisor ISO.
Clone Of: 1073720
Environment:
Last Closed: 2015-02-11 20:53:40 UTC
oVirt Team: Node
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0160 normal SHIPPED_LIVE ovirt-node bug fix and enhancement update 2015-02-12 01:34:52 UTC

Description haiyang,dong 2014-03-07 03:02:22 UTC
+++ This bug was initially created as a clone of Bug #1073720 +++

Description of problem:
Better to add --update option to edit-node to support update packages
by using edit-node tools

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 haiyang,dong 2014-03-07 03:03:29 UTC
clone this REF bug form upstream to also track it in rhevh

Comment 4 haiyang,dong 2014-10-11 07:56:48 UTC
Test version:
ovirt-node-tools-3.1.0-0.20.20141006gitc421e04.el7.noarch
ovirt-node-minimizer-3.1.0-0.20.20141006gitc421e04.el7.noarch
rhevh-7.0-20141006.0.el7ev.iso

Test step:
1. [root@dhcp-8-228 home]# edit-node --repo=edit-node.repo --install=oovirt-node-plugin-ipmi-3.1.0-0.20.20141006gitc421e04.el7.noarch.rpm rhevh-7.0-20141006.0.el7ev.iso 
rhevh-7.0-20141006.0.el7ev.iso
Warning: the state of SELinux is disabled
Installing Packages
Setting Up DNS For Chroot
Configuring Yum Repo
Setting pki entitlement
WARNING: rpm directory None does not exist
Running Yum Install
['ovirt-node-plugin-ipmi-3.1.0-0.20.20141006gitc421e04.el7.noarch.rpm']
..
fragmd5 = cda67547fbedcd2c69231457e4b765b3b88ae7e7485ae633a7962a7681dc
frags = 20
Setting supported flag to 0
Moving 'rhevh-7.0-20141006.0.el7ev.iso.edited.iso' to 'rhevh-7.0-20141006.0.ipmi.el7ev.iso'

2. [root@dhcp-8-228 home]# edit-node --repo=edit-node.repo --update=ovirt-node-plugin-ipmi-3.1.0-0.22.20141010git96b7ca3.el7.noarch.rpm rhevh-7.0-20141006.0.ipmi.el7ev.iso 
rhevh-7.0-20141006.0.ipmi.el7ev.iso
Warning: the state of SELinux is disabled
Updating packages: ovirt-node-plugin-ipmi-3.1.0-0.22.20141010git96b7ca3.el7.noarch.rpm
Setting Up DNS For Chroot
Configuring Yum Repo
Setting pki entitlement
WARNING: rpm directory None does not exist
Running Yum Install
['ovirt-node-plugin-ipmi-3.1.0-0.22.20141010git96b7ca3.el7.noarch.rpm']
..
  Updating   : ovirt-node-plugin-ipmi-3.1.0-0.22.20141010git96b7ca3.el7.n   1/2 
  Cleanup    : ovirt-node-plugin-ipmi-3.1.0-0.20.20141006gitc421e04.el7.n   2/2 
  Verifying  : ovirt-node-plugin-ipmi-3.1.0-0.22.20141010git96b7ca3.el7.n   1/2 
  Verifying  : ovirt-node-plugin-ipmi-3.1.0-0.20.20141006gitc421e04.el7.n   2/2 

Updated:
  ovirt-node-plugin-ipmi.noarch 0:3.1.0-0.22.20141010git96b7ca3.el7             

Complete!

done
Running Minimizer
..
fragmd5 = 6a59327e584761482f53d1e63b316fe7f27e171b46859d5a4ac76516e715
frags = 20
Setting supported flag to 0
Moving 'rhevh-7.0-20141006.0.ipmi.el7ev.iso.edited.iso' to 'rhevh-7.0-20141006.0.ipmi.el7ev.iso.edited.iso'

Now edit-node tools support "--update" parameter.

So this bug has been fixed,change the status into "VERIFIED".

Comment 5 Doron Fediuck 2014-12-07 15:03:28 UTC
Fabian,
can you please provide the relevant doc text?

Comment 7 errata-xmlrpc 2015-02-11 20:53:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0160.html


Note You need to log in before you can comment on or make changes to this bug.