Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1073590 - [rhevm-reports\dwh] log locations were moved to independent directories.
Summary: [rhevm-reports\dwh] log locations were moved to independent directories.
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-log-collector
Version: 3.4.0
Hardware: Unspecified
OS: Unspecified
urgent
medium
Target Milestone: ---
: 3.4.0
Assignee: Sandro Bonazzola
QA Contact: Jiri Belka
URL:
Whiteboard: integration
Depends On: 1074460 1074468
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-03-06 18:36 UTC by Yaniv Lavi
Modified: 2014-09-18 12:24 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Previously, the engine sos plug-in for the engine-log-collector tool would not collect logs for the Reports or Data Warehouse features under certain conditions. This was caused by the Reports and Data Warehouse having been moved to independent locations, which prevented the data for these features from being collected. Now, two new sos plug-ins have been added that make it possible to collect data for the Reports and Data Warehouse features correctly.
Clone Of:
Environment:
Last Closed: 2014-06-09 14:06:24 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0668 normal SHIPPED_LIVE rhevm-log-collector bug fix and enhancement update 2014-06-09 18:03:59 UTC
oVirt gerrit 25518 None None None Never
oVirt gerrit 25519 None None None Never
Red Hat Bugzilla 1086942 None None None Never

Internal Links: 1086942

Description Yaniv Lavi 2014-03-06 18:36:08 UTC
Description of problem:
log locations were moved to independent directories. Logs are save in:
/var/log/ovirt-engine-reports
/var/log/ovirt-engine-dwh


Please make sure we collect these.


Yaniv

Comment 1 Sandro Bonazzola 2014-03-07 09:37:51 UTC
Yaniv, I think it may make sense to have specific sos plugins for reports and DWH.
Looking forward, we have to support dwh and reports running on hosts not running engine.

Can you:
- open one bug on sos for adding a plugin for dwh
- open another one for adding a plugin for reports
- have those 2 bugs bloking this one
- set me as assignee on those 2 bugs
- detail all things that must be collected by single plugin

Thanks

Comment 2 Sandro Bonazzola 2014-03-07 12:30:25 UTC
Keith, I guess this will impact also on support plugin.

Comment 3 Sandro Bonazzola 2014-03-10 09:57:45 UTC
(In reply to Sandro Bonazzola from comment #1)
> Yaniv, I think it may make sense to have specific sos plugins for reports
> and DWH.
> Looking forward, we have to support dwh and reports running on hosts not
> running engine.
> 
> Can you:
> - open one bug on sos for adding a plugin for dwh
> - open another one for adding a plugin for reports
> - have those 2 bugs bloking this one
> - set me as assignee on those 2 bugs

I'll take care of the above.


> - detail all things that must be collected by single plugin
> 
> Thanks

Comment 5 Jiri Belka 2014-03-13 11:36:45 UTC
ok, rhevm-log-collector-3.4.0-2.el6ev.noarch

# tar tJf /tmp/sosreport-LogCollector-20140313121132.tar.xz | egrep '/var/log/ovirt-engine-(reports|dwh)'
./jb-rhevm34-2014031312101394709043/var/log/ovirt-engine-reports/
./jb-rhevm34-2014031312101394709043/var/log/ovirt-engine-reports/jasperserver.log
./jb-rhevm34-2014031312101394709043/var/log/ovirt-engine-dwh/
./jb-rhevm34-2014031312101394709043/var/log/ovirt-engine-dwh/ovirt-engine-dwhd.log

# for i in reports dwh; do rpm -ql rhevm-$i ; done | grep /var/log
/var/log/ovirt-engine-reports
/var/log/ovirt-engine-dwh

Comment 7 errata-xmlrpc 2014-06-09 14:06:24 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0668.html


Note You need to log in before you can comment on or make changes to this bug.