Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1073 - Bad locERROR: X: Unable to open font "vga"ERROR: , trying "vga"...
Summary: Bad locERROR: X: Unable to open font "vga"ERROR: , trying "vga"...
Keywords:
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: dosemu
Version: 5.2
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
: 181 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-02-08 15:38 UTC by petr_kristof
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-04-01 23:35:40 UTC


Attachments (Terms of Use)

Description petr_kristof 1999-02-08 15:38:18 UTC
Dosemu (xdos) lookink for vga font in
 /usr/X11R6/lib/fonts/misc/
directory, but RedHats package places this font to
/usr/X11R6/lib/X11/fonts/misc/ directory.

Workaround:

mkdir -p /usr/X11R6/lib/fonts/misc
cd /usr/X11R6/lib/fonts/misc
cp ../../X11/fonts/misc/vga.pcf .
mkfontdir .
xset fp+ /usr/X11R6/lib/fonts/misc

HINT: Try to recompile it with right path ;-)

Comment 1 David Lawrence 1999-04-01 23:35:59 UTC
I was unable to replicate this problem in dosemu-0.98.1-2

Comment 2 Jeff Johnson 1999-06-03 09:17:59 UTC
*** Bug 181 has been marked as a duplicate of this bug. ***

vga.pcf (in .../X11/.../font/misc/) directory is not
recognized by X11, so when you execute xdos or xtermdos the
font is not used.  (So, e.g. you don't have the nice dos
border character)
This happens to unresolved dependencies with the rpm
containing the X11 font!
in the font/misc directory, the vga.pcf file exists but is
NOT mentioned in font.alias.

To fix it:  Edit the font.alias file, replace "72" with "73"
in the first line and add a line "vga.pcf vga" at the end of
the file.

Dear Redhat RPM-Maintainer, pls. add this to you future
dosemu rpms, thanks.


------- Additional Comments From pbrown@redhat.com  11/24/98 16:34 -------
This probably won't get fixed until 6.0, when the X11 font directories
gain the ability to be rebuilt automatically by RPM whenever they are
"touched" by a package being installed or uninstalled.


Note You need to log in before you can comment on or make changes to this bug.