Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1072357 - [Setup] - when clean install fails after war is deployed it remains in the file system and not deleted
Summary: [Setup] - when clean install fails after war is deployed it remains in the fi...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-reports
Version: 3.4.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: ---
: 3.5.0
Assignee: Shirly Radco
QA Contact: Petr Matyáš
URL:
Whiteboard: integration
Depends On: 1139225
Blocks: 1112305 1124383 rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-03-04 12:57 UTC by Yaniv Lavi
Modified: 2015-02-11 18:16 UTC (History)
10 users (show)

Fixed In Version: vt10
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1112305 (view as bug list)
Environment:
Last Closed: 2015-02-11 18:16:53 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2015:0176 normal SHIPPED_LIVE rhevm-reports 3.5 bug fix and enhancement update 2015-02-11 23:11:58 UTC
oVirt gerrit 28653 master MERGED reports: remove war file for new db Never
oVirt gerrit 29071 ovirt-engine-reports-3.4 MERGED reports: remove war file for new db Never
oVirt gerrit 30967 master MERGED reports: remove war file for new db Never

Description Yaniv Lavi 2014-03-04 12:57:00 UTC
Description of problem:
when clean install fails after war is deployed it remains in the file system and not deleted.

Version-Release number of selected component (if applicable):
3.4.0

How reproducible:
Always

Steps to Reproduce:
1. run engine-setup with reports plugin
2. fail install after war is deployed.

Actual results:
War remain in file system

Expected results:
War should be clean to return system to the previous state 

Additional info:

Comment 1 Yaniv Lavi 2014-06-23 12:47:14 UTC
Please manually cherry pick to 3.4 branch there is a merge conflict.



Yaniv

Comment 7 Petr Matyáš 2014-11-20 13:44:51 UTC
Still can't test this due to bug 1130764.

Comment 8 Shirly Radco 2014-11-23 08:01:23 UTC
This bug is blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1130764.
The bug you refer to is an otopi bug. 
We verified this bug for 3.4. as well and opened the bug for otopi.
Please test this.

Comment 9 Shirly Radco 2014-11-23 08:02:50 UTC
Sorry correction:
This bug is *not* blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1130764.

(In reply to Shirly Radco from comment #8)
> This bug is blocked by https://bugzilla.redhat.com/show_bug.cgi?id=1130764.
> The bug you refer to is an otopi bug. 
> We verified this bug for 3.4. as well and opened the bug for otopi.
> Please test this.

Comment 10 Shirly Radco 2015-01-13 11:59:59 UTC
Please do not test during "Creating PostgreSQL 'engine' database", press ^C.
At specific point in time it might fail due to https://bugzilla.redhat.com/show_bug.cgi?id=1130764.

It is a yum limitation that can not be fixed at this point.

Comment 12 errata-xmlrpc 2015-02-11 18:16:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0176.html


Note You need to log in before you can comment on or make changes to this bug.