Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1072313 - OVIRT35 - [RFE] Allow to edit VM properties that need VM to be down to apply, just mark it as such and apply on VM shutdown
Summary: OVIRT35 - [RFE] Allow to edit VM properties that need VM to be down to apply,...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-core
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: 3.5.0
Assignee: Omer Frenkel
QA Contact: Ilanit Stein
URL: http://www.ovirt.org/Features/Edit_Ru...
Whiteboard: virt
: 1098114 (view as bug list)
Depends On:
Blocks: 922377 1022041 1047522
TreeView+ depends on / blocked
 
Reported: 2014-03-04 11:16 UTC by Michal Skrivanek
Modified: 2016-02-10 19:49 UTC (History)
17 users (show)

Fixed In Version: ovirt-3.5.0-beta2
Doc Type: Enhancement
Doc Text:
Clone Of: 922377
Environment:
Last Closed: 2014-10-17 12:26:28 UTC
oVirt Team: Virt


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 26758 master MERGED core: add support to update running vm Never
oVirt gerrit 27369 master MERGED webadmin: edit running vm Never
oVirt gerrit 27382 master MERGED rest api: edit running vm Never

Description Michal Skrivanek 2014-03-04 11:16:21 UTC
+++ This bug was initially created as a clone of Bug #922377 +++

Description of problem:
It's quite inconvenient not to be able to edit all VM properties anytime. The old way of being to able to edit the VM properties anytime and applying some of them on VM shutdown is the best behaviour from administrator POV.

The only thing that may be missing is a note to user (admin) that the changes will be applied later.

Expected results:
update the VM properties in the database and the next time the VM is run, use them

Additional info:


--- Additional comment from Omer Frenkel on 2013-06-19 16:00:34 CEST ---

some more details on what is planned, no patches available yet:
when vm is run, new snapshot will be taken, for configutation only,
this will be special "running snapshot".
when vm is edited while running, changes will be saved to the snapshot.
this way when frontend get a vm object from db, it always reflect the 'real' state of the vm.
(general subtab of vm in ui, for example).
when vm goes down, all information from the snapshot will be saved to the vm table, to be used on next run.
the "next run configuration" will be available when querying the snapshot, as querying any other snapshot.

Comment 1 Michal Skrivanek 2014-05-16 07:00:53 UTC
*** Bug 1098114 has been marked as a duplicate of this bug. ***

Comment 2 Sandro Bonazzola 2014-10-17 12:26:28 UTC
oVirt 3.5 has been released and should include the fix for this issue.

Comment 3 Ilanit Stein 2014-11-25 09:31:54 UTC
Put Triaged, since this bug was verified on rhevm VT5 & VT6 (see Bug #922377)


Note You need to log in before you can comment on or make changes to this bug.