Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1071260 - Misleading error message reported on timed out migrations
Summary: Misleading error message reported on timed out migrations
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: vdsm
Classification: oVirt
Component: General
Version: ---
Hardware: Unspecified
OS: Unspecified
high
unspecified vote
Target Milestone: ---
: ---
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Pavel Novotny
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-28 11:43 UTC by Vinzenz Feenstra [evilissimo]
Modified: 2016-04-22 14:50 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-22 14:50:04 UTC
oVirt Team: Virt
ylavi: ovirt-4.0.0?
rule-engine: planning_ack?
rule-engine: devel_ack?
rule-engine: testing_ack?


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 970645 None None None Never

Internal Links: 970645

Description Vinzenz Feenstra [evilissimo] 2014-02-28 11:43:54 UTC
Description of problem:
When a migration times out and gets cancelled a misleading message is reported.


How reproducible:
Always

Steps to Reproduce:
1. Change migration_max_time_per_gib_mem in VDSM to a smaller value (5) 
2. Start a migration
3. When it fails due to timeout you'll find the following message in the event log of the RHEVM Webadmin: 

> Migration failed due to Error: Migration not in progress (VM: a, Source: host1, Destination: host2). 

Actual results:
The error messages says that the migration failed because it is not in progress.
> Migration failed due to Error: Migration not in progress (VM: a, Source: host1, Destination: host2). 

Expected results:
Migration failed due to Error: The migration timed out and has been cancelled. (VM: a, Source: host1, Destination: host2).

Comment 1 Vinzenz Feenstra [evilissimo] 2014-02-28 11:46:12 UTC
A bit more clarification: "When a migration times out and gets cancelled"
Should be "When a migration gets cancelled because it timed out"

Comment 2 Michal Skrivanek 2014-10-30 09:48:49 UTC
didn't make 3.5

Comment 3 Michal Skrivanek 2015-09-04 10:02:04 UTC
we still didn't really figure out how to approach this

Comment 4 Michal Skrivanek 2016-04-22 14:50:04 UTC
hopefully wont' happen so much once migration improvements are done in 4.0


Note You need to log in before you can comment on or make changes to this bug.