Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1071220 - Satellite 5.6: cobbler triggers are not working
Summary: Satellite 5.6: cobbler triggers are not working
Keywords:
Status: CLOSED DUPLICATE of bug 1057785
Alias: None
Product: Red Hat Satellite 5
Classification: Red Hat
Component: Provisioning
Version: 560
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ---
Assignee: Stephen Herr
QA Contact: Red Hat Satellite QA List
URL:
Whiteboard:
Depends On:
Blocks: sat560-triage
TreeView+ depends on / blocked
 
Reported: 2014-02-28 10:16 UTC by Jiří Mikulka
Modified: 2014-10-06 13:46 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-13 17:44:58 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 1091478 None None None Never

Internal Links: 1091478

Description Jiří Mikulka 2014-02-28 10:16:00 UTC
Description of problem:
Execution of (pre/post install) trigger scripts fails with traceback on Satellite 5.6.

Version-Release number of selected component (if applicable):
Satellite 5.6.0 (Satellite-5.6.0-RHEL6-re20130927.0)
cobbler-2.0.7-39.el6sat.noarch

How reproducible:
always

Steps to Reproduce:
1) create pre/post install script
       echo -e '#!/bin/bash\necho "Hello world"' >  /var/lib/cobbler/triggers/install/{pre,post}/run.sh
       chmod 0755  /var/lib/cobbler/triggers/install/{pre,post}/run.sh
2) schedule machaine provisioning
3) check cobbler log
       tail -f /var/log/cobbler/cobbler.log
[...]
Fri Feb 28 05:06:03 2014 - INFO | REMOTE run_install_triggers; user(?)
Fri Feb 28 05:06:03 2014 - DEBUG | running python triggers from /var/lib/cobbler/triggers/install/pre/*
Fri Feb 28 05:06:03 2014 - DEBUG | running python trigger cobbler.modules.install_pre_log
Fri Feb 28 05:06:03 2014 - INFO | Exception occured: <type 'exceptions.IndexError'>
Fri Feb 28 05:06:03 2014 - INFO | Exception value: list index out of range
Fri Feb 28 05:06:03 2014 - INFO | Exception Info:
  File "/usr/lib/python2.6/site-packages/cobbler/remote.py", line 1759, in _dispatch
    return method_handle(*params)
   File "/usr/lib/python2.6/site-packages/cobbler/remote.py", line 1210, in run_install_triggers
    utils.run_triggers(self.api, None, "/var/lib/cobbler/triggers/install/%s/*" % mode, additional=[objtype,name,ip],logger=self.logger)
   File "/usr/lib/python2.6/site-packages/cobbler/utils.py", line 861, in run_triggers
    rc = m.run(api, arglist, logger)
   File "/usr/lib/python2.6/site-packages/cobbler/modules/install_pre_log.py", line 23, in run
    ip      = args[2] # ip or "?"
[...]

Actual results:
traceback

Expected results:
no traceback, but the trigger script is executed

Additional info:
* this was fixed for Satellite 5.5 reported as bug 1028525
* probably a regression because the bug 1028525 fixed the issue for Satellite 5.6 during the stage validation

Comment 1 Stephen Herr 2014-08-13 17:44:58 UTC
Duplicate of bug 1057785 which is closed currentrelease.

*** This bug has been marked as a duplicate of bug 1057785 ***


Note You need to log in before you can comment on or make changes to this bug.