Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1070674 - Provide informations about fencing in RHEV-M
Summary: Provide informations about fencing in RHEV-M
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.5.0
Assignee: Eli Mesika
QA Contact: sefi litmanovich
URL:
Whiteboard: infra
: 1090520 (view as bug list)
Depends On: 1090520
Blocks: rhev3.5beta 1156165
TreeView+ depends on / blocked
 
Reported: 2014-02-27 10:56 UTC by Fabian Deutsch
Modified: 2016-02-10 19:25 UTC (History)
11 users (show)

Fixed In Version: org.ovirt.engine-root-3.5.0-9
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-02-17 17:09:27 UTC
oVirt Team: Infra
Target Upstream Version:


Attachments (Terms of Use)
engine log (deleted)
2014-08-21 12:34 UTC, sefi litmanovich
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 27706 master MERGED core: Provide informations about fencing in oVirt Never
oVirt gerrit 31886 master MERGED core: fixing a missing fencing audit log message Never
oVirt gerrit 31952 ovirt-engine-3.5 MERGED core: fixing a missing fencing audit log message Never
Red Hat Bugzilla 951267 None None None Never

Internal Links: 951267

Description Fabian Deutsch 2014-02-27 10:56:07 UTC
Description of problem:
Currently it's not obvious why a fencing event occucred.

To give the user a hint it would be better to display/gather more informations about the fencing events.

This would also help GSS to analyze the incident.

Comment 1 Barak 2014-04-13 11:50:34 UTC
Eli please make sure we have the folowing in the event log:
- host enetered connecting status (+ timeout calculated)
- host became non-responsive
- all the fencing attempts (including the proxy selected)

Ar

Comment 2 Barak 2014-04-24 07:36:58 UTC
*** Bug 1090520 has been marked as a duplicate of this bug. ***

Comment 3 sefi litmanovich 2014-08-21 12:33:23 UTC
attempt to verify with ovirt-engine-3.5.0-0.0.master.20140804172041.git23b558e.el6.noarch.

1. install 2 hosts, at least 1 with pm.
2. stop network for host with pm.
3.verify all the messages as described in comment #1 are issued.

failed:

regarding the new message added in this patch:

VDS_HOST_NOT_RESPONDING_CONNECTING=Host ${VdsName} is not responding. It will stay in Connecting sta
te for a grace period of ${Seconds} seconds and after that an attempt to fence the host will be issu
ed.

the message appears in engine.log but not issued in events in ui.

from engine.log:

2014-08-21 14:54:30,194 WARN  [org.ovirt.engine.core.vdsbroker.VdsManager] (DefaultQuartzScheduler_Worker-69) Host {hostname} is not responding. It will stay in Connecting state for a grace period of $120 seconds and after that an attempt to fence the host will be issued.

Comment 4 sefi litmanovich 2014-08-21 12:34:07 UTC
Created attachment 929190 [details]
engine log

Comment 5 sefi litmanovich 2014-09-10 10:07:21 UTC
Verified with rhevm-3.5.0-0.10.master.el6ev.noarch.

1. install 2 hosts, at least 1 with pm.
2. stop network for host with pm.
3. all the messages as described in comment #1 were issued on audit log and appeared in ui as well as engine.log.

Comment 6 Eyal Edri 2015-02-17 17:09:27 UTC
rhev 3.5.0 was released. closing.


Note You need to log in before you can comment on or make changes to this bug.