Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1070036 - values entered on "Power Config" tab are not preserved when validation fails
Summary: values entered on "Power Config" tab are not preserved when validation fails
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Beaker
Classification: Community
Component: web UI
Version: 0.15
Hardware: Unspecified
OS: Unspecified
medium
medium vote
Target Milestone: 19.0
Assignee: Dan Callaghan
QA Contact: tools-bugs
URL:
Whiteboard:
Depends On: 1014438
Blocks: 1059535
TreeView+ depends on / blocked
 
Reported: 2014-02-26 06:20 UTC by xjia
Modified: 2018-02-06 00:41 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-25 07:18:24 UTC


Attachments (Terms of Use)

Description xjia 2014-02-26 06:20:31 UTC
Description of problem:
For instance: on "System Config" tab, input non-integer value in "Quiescent Period" column and save. It tells "Please enter an integer value". At that moment, input valid value and save. But all the information on that tab is gone.

Version-Release number of selected component (if applicable):
0.16

How reproducible:
100%

Steps to Reproduce:
1.On "system config" tab, input "a" in "Quiescent Period" column and save
2.input 5 in "Quiescent Period" column and save

Actual results:
All the information is gone

Expected results:
The content should be correct and shown up.


Additional info:

Comment 2 Dan Callaghan 2014-02-26 07:08:00 UTC
Rather than fixing up the TG validation, which is a bit of a nightmare on the system page due to widget nesting, it will probably be simpler to port this form to Backbone targetting 0.17.

Comment 3 Dan Callaghan 2014-03-03 06:43:44 UTC
On Gerrit: http://gerrit.beaker-project.org/2865

Comment 4 Dan Callaghan 2014-09-18 05:44:02 UTC
This was merged to develop as part of the new-system-page branch.

Comment 7 Dan Callaghan 2014-11-25 07:18:24 UTC
Beaker 19.0 has been released.


Note You need to log in before you can comment on or make changes to this bug.