Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1069220 - migration_timeout not honoured, live migration goes on beyond it
Summary: migration_timeout not honoured, live migration goes on beyond it
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.1.4
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
: 3.3.2
Assignee: Vinzenz Feenstra [evilissimo]
QA Contact: Lukas Svaty
URL:
Whiteboard: virt
Depends On: 970645 1069731 1078793
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-24 13:45 UTC by rhev-integ
Modified: 2018-12-05 17:24 UTC (History)
19 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Live migration operations now respect the 300 second limit, and live migration operations continue for only 300 seconds.
Clone Of: 970645
: 1069731 1078793 (view as bug list)
Environment:
Last Closed: 2014-04-09 17:41:53 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Knowledge Base (Solution) 390493 None None None Never
Red Hat Product Errata RHBA-2014:0392 normal SHIPPED_LIVE vdsm 3.3.2 bug fix update 2014-04-09 21:40:59 UTC
oVirt gerrit 16382 None None None Never
oVirt gerrit 21708 None None None Never
oVirt gerrit 25022 None MERGED Introduce a maximum time limit a migration may take Never
oVirt gerrit 25929 None MERGED Use the correct configuration value for ovirt-3.3 Never

Comment 3 Lukas Svaty 2014-03-19 16:18:35 UTC
tested this in is35
Seems like migration_max_time_per_gib_mem is not counted in timeout

Steps to reproduce:
1. Set migration_max_time_per_gib_mem to 1 on hosts in vdsm config
2. service restart vdsm
3. Start VM in WA (VM with ~1GB of memory)
4. Migrate to other host

result events:
1st test:
2014-Mar-19, 17:10
Migration started (VM: a, Source: host2, Destination: host1, User: admin@internal).

2014-Mar-19, 17:11	
Migration completed (VM: a, Source: host2, Destination: host1, Duration: 56 sec).
	


2nd test:
2014-Mar-19, 17:06
Migration started (VM: a, Source: host1, Destination: host2, User: admin@internal).
	
2014-Mar-19, 17:06
Migration completed (VM: a, Source: host1, Destination: host2, Duration: 32 sec).


In both cases time of migration is bigger than 1s (56s, 32s) and migration finished successfully.

Comment 4 Vinzenz Feenstra [evilissimo] 2014-03-20 11:54:22 UTC
Regression patch merged to ovirt-3.3 as http://gerrit.ovirt.org/gitweb?p=vdsm.git;a=commit;h=188f72dd0d5bd0fc724e9ba08aff8a2b9a7ec6fc

Comment 8 Zac Dover 2014-04-03 02:54:28 UTC
This bug is currently attached to errata RHBA-2014:17276. If this change is not to be documented in the text for this errata please either remove it from the errata, set the requires_doc_text flag to minus (-), or leave a "Doc Text" value of "--no tech note required" if you do not have permission to alter the flag.

Otherwise to aid in the development of relevant and accurate release documentation, please fill out the "Doc Text" field above with these four (4) pieces of information:

* Cause: What actions or circumstances cause this bug to present.

* Consequence: What happens when the bug presents.

* Fix: What was done to fix the bug.

* Result: What now happens when the actions or circumstances above occur. (NB: this is not the same as 'the bug doesn't present anymore')

Once filled out, please set the "Doc Type" field to the appropriate value for the type of change made and submit your edits to the bug.

For further details on the Cause, Consequence, Fix, Result format please refer to:

https://bugzilla.redhat.com/page.cgi?id=fields.html#cf_release_notes

Thanks in advance.

Comment 10 errata-xmlrpc 2014-04-09 17:41:53 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0392.html


Note You need to log in before you can comment on or make changes to this bug.