Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1067673 - rhevm-dwh-setup error on a system installed in Brazilian Portuguese
Summary: rhevm-dwh-setup error on a system installed in Brazilian Portuguese
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine-dwh
Version: 3.3.0
Hardware: All
OS: Linux
high
medium
Target Milestone: ---
: 3.4.0
Assignee: Yedidyah Bar David
QA Contact: Barak Dagan
URL:
Whiteboard: integration
Depends On:
Blocks: 1073467 rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-02-20 20:24 UTC by Amador Pahim
Modified: 2018-12-05 17:22 UTC (History)
12 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1073467 (view as bug list)
Environment:
Last Closed: 2014-06-09 15:18:22 UTC
oVirt Team: ---
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHEA-2014:0601 normal SHIPPED_LIVE rhevm-dwh 3.4 bug fix and enhancement update 2014-06-09 19:15:53 UTC
oVirt gerrit 25455 None None None Never

Description Amador Pahim 2014-02-20 20:24:48 UTC
Description of problem:
After install a system in in Brazilian Portuguese, rhevm-dwh-setup fails with error:

 psql: FATAL:  autenticação do tipo Ident falhou para usuário "engine_history"

Version-Release number of selected component (if applicable):

 rhevm-dwh-3.3.0-29.el6ev.noarch

How reproducible:

 100%

Steps to Reproduce:
1. Install RHEL in Brazilian Portuguese
2. Install and setup rhevm
3. Install rhevm-dwh:

 # yum install rhevm-dwh

4. Run dwh-setup:

 # rhevm-dwh-setup

5. Answer the questions. Setup will fail with:

2014-02-19 20:39:50::DEBUG::decorators::18::root:: running createDbSchema
2014-02-19 20:39:50::DEBUG::rhevm-dwh-setup::141::root:: installing ovirt_engine_history db
2014-02-19 20:39:50::DEBUG::rhevm-dwh-setup::144::root:: ovirt engine history db creation is logged at /var/log/ovirt-engine/ovirt-history-db-install-2014_02_19_20_39_50.log
2014-02-19 20:39:50::DEBUG::common_utils::907::root:: Executing command --> '/usr/share/ovirt-engine-dwh/db-scripts/create_schema.sh -l /var/log/ovirt-engine/ovirt-history-db-install-2014_02_19_20_39_50.log -u engine_history -s localhost -p 5432 -g' in working directory '/root'
2014-02-19 20:39:50::DEBUG::common_utils::962::root:: output =
2014-02-19 20:39:50::DEBUG::common_utils::963::root:: stderr = psql: FATAL:  autenticação do tipo Ident falhou para usuário "engine_history"

2014-02-19 20:39:50::DEBUG::common_utils::964::root:: retcode = 2
2014-02-19 20:39:50::ERROR::decorators::27::root:: Traceback (most recent call last):
  File "/usr/share/ovirt-engine-dwh/decorators.py", line 20, in wrapped_f
    output = f(*args)
  File "/usr/bin/rhevm-dwh-setup", line 160, in createDbSchema
    envDict={'ENGINE_PGPASS': PGPASS_TEMP},
  File "/usr/share/ovirt-engine-dwh/common_utils.py", line 967, in execCmd
    raise Exception(msg)
Exception: Error while trying to create ovirt_engine_history db

2014-02-19 20:39:50::ERROR::rhevm-dwh-setup::691::root:: Exception caught!
2014-02-19 20:39:50::ERROR::rhevm-dwh-setup::692::root:: Traceback (most recent call last):
  File "/usr/bin/rhevm-dwh-setup", line 637, in main
    createDbSchema(db_dict)
  File "/usr/share/ovirt-engine-dwh/decorators.py", line 28, in wrapped_f
    raise Exception(instance)
Exception: Error while trying to create ovirt_engine_history db


Additional info:

Affected system:
# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC=pt_BR.utf8
LC_TIME=pt_BR.utf8
LC_COLLATE="en_US.UTF-8"
LC_MONETARY=pt_BR.utf8
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT=pt_BR.utf8
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=

Healthy system (installed in English/US, rhevm-dwh-setup successful):
# locale
LANG=en_US.utf8
LC_CTYPE="en_US.utf8"
LC_NUMERIC=pt_BR.utf8
LC_TIME=pt_BR.utf8
LC_COLLATE="en_US.utf8"
LC_MONETARY=pt_BR.utf8
LC_MESSAGES="en_US.utf8"
LC_PAPER="en_US.utf8"
LC_NAME="en_US.utf8"
LC_ADDRESS="en_US.utf8"
LC_TELEPHONE="en_US.utf8"
LC_MEASUREMENT=pt_BR.utf8
LC_IDENTIFICATION="en_US.utf8"
LC_ALL=


Workarround:

Install system-config-language:
 # yum install -y system-config-language

Execute:
 # system-config-language

  Select "English (USA)" then "OK"

Run setup again:
 # rhevm-dwh-setup

Setup now is expected to finish successfully.

Comment 1 Amador Pahim 2014-02-21 17:16:25 UTC
pg_hba.conf after the error:


# TYPE  DATABASE    USER        CIDR-ADDRESS          METHOD

# "local" is for Unix domain socket connections only
local   all         all                               ident
host    all             engine_history  0.0.0.0/0               md5
host    all             engine_history  ::0/0                   md5
host    engine          engine          0.0.0.0/0               md5
host    engine          engine          ::0/0                   md5
# IPv4 local connections:
host    all         all         127.0.0.1/32          ident
# IPv6 local connections:
host    all         all         ::1/128               ident



Executing `create_schema.sh` manually:

# /usr/share/ovirt-engine-dwh/db-scripts/create_schema.sh -l /var/log/ovirt-engine/ovirt-history-db-install-2014_02_20_16_38_07.log -u engine_history -s localhost -p 5432 -g
psql: FATAL:  autenticação do tipo Ident falhou para usuário "engine_history"

The same command executed on a system installed in English/USA:

# /usr/share/ovirt-engine-dwh/db-scripts/create_schema.sh -l /var/log/ovirt-engine/ovirt-history-db-install-2014_02_20_16_38_07.log -u engine_history -s localhost -p 5432 -g
psql: fe_sendauth: no password supplied


Seems like an issue in postgres authentication in pt_BR.

Comment 3 Yedidyah Bar David 2014-03-06 08:43:57 UTC
The bug here is in the function that checks if a service is up. This causes setup, after editing pg_hba, to not restart postgresql.

Comment 5 Yedidyah Bar David 2014-03-09 06:44:02 UTC
Moving to QA as this bug should not affect 3.4.

Comment 6 Barak Dagan 2014-03-11 12:38:24 UTC
Verified on av2.1

[root@fire31-rep ~]# locale
LANG=en_US.UTF-8
LC_CTYPE="en_US.UTF-8"
LC_NUMERIC="en_US.UTF-8"
LC_TIME="en_US.UTF-8"
LC_COLLATE="en_US.UTF-8"
LC_MONETARY="en_US.UTF-8"
LC_MESSAGES="en_US.UTF-8"
LC_PAPER="en_US.UTF-8"
LC_NAME="en_US.UTF-8"
LC_ADDRESS="en_US.UTF-8"
LC_TELEPHONE="en_US.UTF-8"
LC_MEASUREMENT="en_US.UTF-8"
LC_IDENTIFICATION="en_US.UTF-8"
LC_ALL=


# locale -a | grep BR
pt_BR
pt_BR.iso88591
pt_BR.utf8

# LANG=pt_BR.utf8

# locale
LANG=pt_BR.utf8
LC_CTYPE="pt_BR.utf8"
LC_NUMERIC="pt_BR.utf8"
LC_TIME="pt_BR.utf8"
LC_COLLATE="pt_BR.utf8"
LC_MONETARY="pt_BR.utf8"
LC_MESSAGES="pt_BR.utf8"
LC_PAPER="pt_BR.utf8"
LC_NAME="pt_BR.utf8"
LC_ADDRESS="pt_BR.utf8"
LC_TELEPHONE="pt_BR.utf8"
LC_MEASUREMENT="pt_BR.utf8"
LC_IDENTIFICATION="pt_BR.utf8"
LC_ALL=

# rhevm-setup 
...


[ INFO  ] Starting engine service
[ INFO  ] Restarting httpd
[ INFO  ] Starting dwh service
[ INFO  ] Generating answer file '/var/lib/ovirt-engine/setup/answers/20140311141637-setup.conf'
[ INFO  ] Stage: Clean up
          Log file is located at /var/log/ovirt-engine/setup/ovirt-engine-setup-20140311135924.log
[ INFO  ] Stage: Pre-termination
[ INFO  ] Stage: Termination
[ INFO  ] Execution of setup completed successfully

Comment 9 errata-xmlrpc 2014-06-09 15:18:22 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0601.html


Note You need to log in before you can comment on or make changes to this bug.