Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1067290 - [virtio-win][balloon]value guest memeory stats does not update after S3
Summary: [virtio-win][balloon]value guest memeory stats does not update after S3
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virtio-win
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: ---
Assignee: Gal Hammer
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks: 1131838
TreeView+ depends on / blocked
 
Reported: 2014-02-20 06:45 UTC by Mike Cao
Modified: 2015-11-23 03:37 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Cause: Balloon memory statistics does not work after resuming guest from sleep state (S3 state). Consequence: balloon service cannot update memory statistics after resuming from the system sleep state Fix: Rebuild virtio queues on resuming. Result: Now memory statistics can work properly after resuming from system sleep state.
Clone Of:
Environment:
Last Closed: 2015-03-05 05:33:47 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2015:0289 normal SHIPPED_LIVE virtio-win bug fix and enhancement update 2015-03-05 10:32:54 UTC

Description Mike Cao 2014-02-20 06:45:09 UTC
Description of problem:


Version-Release number of selected component (if applicable):
win7-32 guest
qemu-kvm-rhev-1.5.3-48.el7.x86_64
seabios-1.7.2.2-10.el7.x86_64
3.10.0-86.el7.x86_64

How reproducible:
100%

Steps to Reproduce:
1.Start VM with CLI:
/usr/libexec/qemu-kvm -M pc -cpu SandyBridge -enable-kvm -m 2G -smp 4,cores=2,threads=1,sockets=2 -name bcao_win-7-32-netkvm -uuid `uuidgen` -rtc base=localtime,clock=host,driftfix=slew -drive file=win7-32.qcow2,if=none,media=disk,serial=aaabbbccc,werror=stop,rerror=stop,cache=none,format=qcow2,id=drive-disk0 -device ide-drive,physical_block_size=4096,bus=ide.0,unit=1,logical_block_size=512,drive=drive-disk0,id=disk0 -drive file=en_windows_7_ultimate_with_sp1_x86_dvd_u_677460.iso,if=none,media=cdrom,id=aa -device ide-drive,id=aa1,drive=aa,bootindex=1 -drive media=cdrom,if=none,id=bb -device ide-drive,id=bb1,drive=bb -netdev tap,vhost=on,id=netdev0 -device e1000,netdev=netdev0,id=nic1,mac=1a:46:11:4a:bc:7a -vnc :2 -monitor stdio -usb -device usb-tablet,id=tablet0 -global PIIX4_PM.disable_s3=0 -global PIIX_PM.disable_s4=0 -monitor unix:/tmp/tt,server,nowait -boot menu=on -device virtio-balloon-pci,id=balloon0 -qmp tcp:0:5888,server,nowait -global PIIX4_PM.disable_s4=0
2.install VirtIO balloon driver and blnsrv.exe
3.{ "execute": "qom-get",
  "arguments": { "path": "/machine/peripheral/balloon0",
  "property": "guest-stats" } }

4.do s3 in the guest 
5.resume guest 
6.(qemu)balloon 512
7,repeat step3 

Actual Results:
After step 3
{"return": {"stats": {"stat-swap-out": 0, "stat-free-memory": 1678331904, "stat-minor-faults": 221, "stat-major-faults": 0, "stat-total-memory": 2147074048, "stat-swap-in": 0}, "last-update": 1392873981}}

After step 7
The return value is exactly same w/ step3


Expected Results:
After step7 ,the return values should changed and same as the guest shows 


Additional info :
after s3  ,qom-get still can return values after #blnsrv -u/-s/-p

Comment 3 Gal Hammer 2014-08-10 10:55:26 UTC
What is the balloon driver version? Is it still reproducible?

Comment 4 Mike Cao 2014-08-12 09:30:42 UTC
(In reply to Gal Hammer from comment #3)
> What is the balloon driver version? Is it still reproducible?

Re-Test this issue on virtio-win-prewhql-89 
3.10.0-121.el7.x86_64
qemu-kvm-1.5.3-62.el7.x86_64

Steps same as comment #0

Actual Results:
After step3 :
{"return": {"stats": {"stat-swap-out": 0, "stat-free-memory": 1606569984, "stat-minor-faults": 12, "stat-major-faults": 0, "stat-total-memory": 2147074048, "stat-swap-in": 0}, "last-update": 1407835556}}

After 7
{"return": {"stats": {"stat-swap-out": 0, "stat-free-memory": 172953600, "stat-minor-faults": 300, "stat-major-faults": 0, "stat-total-memory": 2147074048, "stat-swap-in": 0}, "last-update": 1407835629}}

in the guest the free mem is 164G

Based on above ,this issue does not exists in virtio-win-prewhql-89

Comment 5 Mike Cao 2014-08-12 10:06:51 UTC
(In reply to Mike Cao from comment #4)
> (In reply to Gal Hammer from comment #3)
> > What is the balloon driver version? Is it still reproducible?
> 
> Re-Test this issue on virtio-win-prewhql-89 
> 3.10.0-121.el7.x86_64
> qemu-kvm-1.5.3-62.el7.x86_64
> 
> Steps same as comment #0
> 
> Actual Results:
> After step3 :
> {"return": {"stats": {"stat-swap-out": 0, "stat-free-memory": 1606569984,
> "stat-minor-faults": 12, "stat-major-faults": 0, "stat-total-memory":
> 2147074048, "stat-swap-in": 0}, "last-update": 1407835556}}
> 
> After 7
> {"return": {"stats": {"stat-swap-out": 0, "stat-free-memory": 172953600,
> "stat-minor-faults": 300, "stat-major-faults": 0, "stat-total-memory":
> 2147074048, "stat-swap-in": 0}, "last-update": 1407835629}}
> 
> in the guest the free mem is 164G

This line should be "in the guest the free mem is 164M"
> 
> Based on above ,this issue does not exists in virtio-win-prewhql-89

Comment 6 Gal Hammer 2014-08-21 11:09:43 UTC
Moving to ON_QA based on comment #4.

Comment 7 Mike Cao 2014-09-01 05:15:04 UTC
Move status to Verified based on comment #4

Comment 9 errata-xmlrpc 2015-03-05 05:33:47 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2015-0289.html


Note You need to log in before you can comment on or make changes to this bug.