Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1067117 - horizon: we are able to extend the description box over other fields
Summary: horizon: we are able to extend the description box over other fields
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon
Version: 4.0
Hardware: x86_64
OS: Linux
unspecified
medium
Target Milestone: rc
: 5.0 (RHEL 7)
Assignee: Matthias Runge
QA Contact: Amit Ugol
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-19 18:12 UTC by Dafna Ron
Modified: 2014-09-08 05:42 UTC (History)
6 users (show)

Fixed In Version: python-django-horizon-2014.1-5.el6ost
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-07-08 15:41:40 UTC


Attachments (Terms of Use)
screen shot (deleted)
2014-02-19 18:12 UTC, Dafna Ron
no flags Details


Links
System ID Priority Status Summary Last Updated
Launchpad 1282196 None None None Never
Red Hat Product Errata RHEA-2014:0855 normal SHIPPED_LIVE Red Hat Enterprise Linux OpenStack Platform Enhancement - Dashboard 2014-07-08 19:33:24 UTC

Description Dafna Ron 2014-02-19 18:12:12 UTC
Created attachment 865175 [details]
screen shot

Description of problem:

we can extend the description box over other fields (see screen shot)

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. open the new volume dialogue
2. extend the description box over other fields 
3. write in the box

Actual results:

we are able to extend the box over other fields 

Expected results:

we should limit the borders of the box 

Additional info:screen shot

upstream bug also opened - this is probably documentation only...

Comment 1 Matthias Runge 2014-03-04 07:30:08 UTC
From upstream bug tracker:

You are expanding the text input to create more space to type in. When doing this you are not extending over the other fields you are forcing them into their minimum width, which compresses the text and forces a scroll bar. Nothing is overlaying the help text.

Comment 2 Dafna Ron 2014-03-04 09:54:48 UTC
Sean, please look at the screen shot.

Comment 3 Matthias Runge 2014-03-04 11:12:29 UTC
Dafna, you can enlarge the textbox, and this will break the layout. Nevertheless, that will happen with each enlarged object. For example, when enlarging the logo, you'll get an ugly look as well. 

When typing in a description here, you wont get text written over the rest. OK, while playing around with the textbox there, it may be possible to make it either not scalable in width or to move the right side (descriptions) to the right.

Comment 4 Matthias Runge 2014-03-04 11:14:03 UTC
Yeah, and upstream confirmed this as a bug. I must admit, I mixed up the two attached screen shots.

Comment 5 Matthias Runge 2014-03-14 08:53:41 UTC
A fix was merged upstream before Icehouse rc1 (so is included in icehouse rc1).

Comment 6 Amit Ugol 2014-06-19 04:55:23 UTC
verified on python-django-horizon-2014.1-7.el7ost.noarch, those fields now have a max width which looks OK to me.

Comment 7 Amit Ugol 2014-06-19 04:57:41 UTC
also note that in edit mode there is no max width, but the window handles it OK.

Comment 9 errata-xmlrpc 2014-07-08 15:41:40 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2014-0855.html


Note You need to log in before you can comment on or make changes to this bug.