Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1067113 - kernel OOPS at boot on ARM (3.14)
Summary: kernel OOPS at boot on ARM (3.14)
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: rawhide
Hardware: arm
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kyle McMartin
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-19 17:49 UTC by Paul Whalen
Modified: 2015-09-01 03:54 UTC (History)
7 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-20 17:42:26 UTC


Attachments (Terms of Use)
kernel-3.14.0-0.rc3 OOPS (deleted)
2014-02-19 17:49 UTC, Paul Whalen
no flags Details
wandboard-3.14.0-0.rc3.git0.1.fc21.armv7hl (deleted)
2014-02-19 21:03 UTC, Paul Whalen
no flags Details

Description Paul Whalen 2014-02-19 17:49:08 UTC
Created attachment 865172 [details]
kernel-3.14.0-0.rc3 OOPS

Description of problem:
Kernel oops at boot on ARM, in most cases the network is down. 

Version-Release number of selected component (if applicable):
kernel-3.14.0-0.rc3.git0.1.fc21

How reproducible:
everytime.

Additional info:
Log attached.

Comment 1 Kyle McMartin 2014-02-19 20:11:47 UTC
It'd be helpful if you included which board{s} you're seeing this on, and such...
Also, to include the full log, as there should be at least one other oops in there as well...

Comment 2 Kyle McMartin 2014-02-19 20:15:46 UTC
In any case, we can turn off CONFIG_JUMP_LABEL for now to work around the problem.

Comment 3 Kyle McMartin 2014-02-19 20:25:47 UTC
Also, what was the last working version?

Comment 4 Peter Robinson 2014-02-19 20:55:12 UTC
It's been on all the 3.14 kernels I believe and I've seen it on BeagleBone Black, and the trimslice and Paul has seen it on the Wandboard Quad. It seems to be a generic ARM issue.

Comment 5 Paul Whalen 2014-02-19 21:02:47 UTC
All boards using the multiplatform kernel in my testing (beaglebone, trimslice, highbank, wandboard and in qemu). It seems to have started around kernel-3.14.0-0.rc0.git8.1.fc21. I did not see this on midway (LPAE).

Comment 6 Paul Whalen 2014-02-19 21:03:30 UTC
Created attachment 865226 [details]
wandboard-3.14.0-0.rc3.git0.1.fc21.armv7hl

Comment 7 Kyle McMartin 2014-02-20 16:49:56 UTC
So the problem here is that once CONFIG_DEBUG_SET_MODULE_RONX marks the module text readonly, we're unable to patch the instructions (which is done through a mucky call chain via do_one_initcall through the module init and netfilter code.)

Basically as it stands right now, CONFIG_DEBUG_SET_MODULE_RONX and kprobes/jump labels are mutually exclusive. ARM needs to grow some manner of method of either re-mapping the page at a new vaddr and modifying it through there, then flushing. Or simply cache the state, flip it back, and flush it twice.

In any case, simply turning it off for now seems sensible.

regards, Kyle

Comment 8 Kyle McMartin 2014-02-20 17:42:26 UTC
Committed a config change for now.


Note You need to log in before you can comment on or make changes to this bug.