Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1067103 - [engine-webadmin] unclear error message when starting a VM with disk that located on a domain in maintenance
Summary: [engine-webadmin] unclear error message when starting a VM with disk that loc...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-webadmin
Version: 3.4
Hardware: x86_64
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.4.0
Assignee: Allon Mureinik
QA Contact: Elad
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-19 17:13 UTC by Elad
Modified: 2016-02-10 18:25 UTC (History)
9 users (show)

Fixed In Version: ovirt-3.4.0-rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:31:31 UTC
oVirt Team: Storage


Attachments (Terms of Use)
engine.log and screenshot (deleted)
2014-02-19 17:13 UTC, Elad
no flags Details


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24840 None None None Never
oVirt gerrit 24846 None MERGED core: Fix CDA message to include status Never

Description Elad 2014-02-19 17:13:23 UTC
Created attachment 865166 [details]
engine.log and screenshot

Description of problem:
I tried to start a VM that has disk which located on a domain in maintenance. The operation was blocked with CanDoAction failure, but the error message on UI is not clear:

Cannot run VM. The relevant Storage Domain's status is ${status}. 
Maintenance

Version-Release number of selected component (if applicable):
ovirt-engine-3.4.0-0.11.beta3.el6.noarch

How reproducible:
Always

Steps to Reproduce:
Shared DC with 2 storage domains
1. Create a VM with 2 disks located on different SDs 
2. Put one of the domains to maintenance
3. Try to start the VM

Actual results:
Operation is blocked with CanDoAction failure:
2014-02-19 18:35:15,332 WARN  [org.ovirt.engine.core.bll.RunVmCommand] (ajp--127.0.0.1-8702-4) [939ef2a] CanDoAction of action RunVm failed. Reasons:VAR__ACTION__RUN,VAR__TYPE__VM,ACTION_TYPE_FAILED_STORAGE_DOMAIN
_STATUS_ILLEGAL2,Maintenance

Error on UI is unclear:
Cannot run VM. The relevant Storage Domain's status is ${status}. 
Maintenance

Expected results:
The error message on UI should be informative

Additional info:
engine.log and screenshot

Comment 1 Sandro Bonazzola 2014-03-03 14:40:16 UTC
This BZ should be fixed in oVirt 3.4.0 RC

Comment 2 Elad 2014-03-18 09:19:04 UTC
Trying to run a VM while one of its attached disks's storage domain is in maintenance fails with a proper error message:
 Cannot run VM. The relevant Storage Domain's status is Maintenance.

Verified using RHEV3.4-AV3

Comment 3 Sandro Bonazzola 2014-03-31 12:31:31 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.