Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1067058 - [database] old psycopg2 does not accept unicode string as port name
Summary: [database] old psycopg2 does not accept unicode string as port name
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: oVirt
Classification: Retired
Component: ovirt-engine-installer
Version: 3.4
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Alon Bar-Lev
QA Contact: Barak Dagan
URL:
Whiteboard: integration
: 1073827 (view as bug list)
Depends On:
Blocks: 1024889
TreeView+ depends on / blocked
 
Reported: 2014-02-19 15:15 UTC by Alon Bar-Lev
Modified: 2014-07-13 23:20 UTC (History)
7 users (show)

Fixed In Version: ovirt-engine-3.4.0_rc
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-31 12:24:33 UTC
oVirt Team: ---


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24788 None None None Never
oVirt gerrit 24790 None None None Never
oVirt gerrit 25325 None MERGED packaging: setup: database: move connect to database library Never
oVirt gerrit 25331 None MERGED packaging: setup: database: move connect to database library Never
oVirt gerrit 25332 None MERGED packaging: setup: database: move connect to database library Never

Description Alon Bar-Lev 2014-02-19 15:15:09 UTC
Using:

python-psycopg2-2.0.14-2.el6.x86_64

TypeError: port must be a string or int

Comment 1 Sandro Bonazzola 2014-03-03 14:40:34 UTC
This BZ should be fixed in oVirt 3.4.0 RC

Comment 2 Alon Bar-Lev 2014-03-04 13:07:47 UTC
we have more places connect is used.

Comment 3 Yaniv Lavi 2014-03-11 07:25:17 UTC
*** Bug 1073827 has been marked as a duplicate of this bug. ***

Comment 4 Barak Dagan 2014-03-20 07:15:08 UTC
Verified on AV3.

Seems that the patches are in, and no problems where detected during installations.

Comment 5 Sandro Bonazzola 2014-03-31 12:24:33 UTC
this is an automated message: moving to Closed CURRENT RELEASE since oVirt 3.4.0 has been released


Note You need to log in before you can comment on or make changes to this bug.