Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1067048 - Error when process is exported to PDF/PNG
Summary: Error when process is exported to PDF/PNG
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: jBPM Designer
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ER2
: 6.0.1
Assignee: Roger Martínez
QA Contact: Marek Baluch
URL:
Whiteboard:
: 1069651 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-19 14:56 UTC by Sona Mala
Modified: 2014-08-26 15:28 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:03:32 UTC
Type: Bug


Attachments (Terms of Use)
Screen shot: Error stack trace from window (deleted)
2014-02-19 14:56 UTC, Sona Mala
no flags Details


Links
System ID Priority Status Summary Last Updated
Red Hat Bugzilla 976473 None None None Never
Red Hat Bugzilla 1031155 None None None Never

Internal Links: 976473 1031155

Description Sona Mala 2014-02-19 14:56:28 UTC
Created attachment 865101 [details]
Screen shot: Error stack trace from window

Description of problem:
When export PDF / PNG (both cause same error message) then an error is shown in new window and server.log. Screen shot with stack trace is attached.

Version-Release number of selected component (if applicable):
6.0.1 ER1 BPMS

How reproducible:


Steps to Reproduce:
1. Choose "{Download|Share} process {PNG|PDF}" item in toolbar.

Actual results:
New window is shown and contains error (attached).


Expected results:
PDF or PNG is generated into particular package.



Additional info:
This is some kind of regression. This feature works in 6.0.0 GA. Exceptions from previous reported issues are different.

Comment 1 Tihomir Surdilovic 2014-02-24 16:04:01 UTC
Is it possible to attach the server logs. They might show something more than whats on the screenshow. This seems to work fine on kie-wb and designer standalone. will keep testing to try to reproduce.

Comment 2 Sona Mala 2014-02-24 18:04:03 UTC
I have already checked that same exception is in server.log. But for sure. I will reproduce this issue tomorrow. The server.log will be attached.

Comment 3 Kris Verlaenen 2014-02-25 05:26:35 UTC
I was able to reproduce this in the community on 6.0.2-SNAPSHOT using modules.  It works fine in the version without modules (fat wars).

Comment 4 Roger Martínez 2014-02-25 20:52:32 UTC
Currently the module org.jboss.solder does NOT contain the artifact org.jboss.solder:solder-impl:jar as a resource because this artifact contains a webfragment 3.0 descriptor, and is known that webfragments are not loaded from module's resources (but do in the webapp classloader) in Jboss EAP/AS.

In the other hand, this issue occurs because some classes from org.jboss.solder:solder-impl:jar artifact are accessing methods from classes in artifact org.jboss.solder:solder-api:jar using "package protected" access modifiers.

If both classes are located in same classloader, the "package protected" access modifier allows the method access, but if these classes are located in different modules classloaders (in this case, solder and webapp modules), an IllegalArgumentException is thrown because the access modifier does not allow the method call (although they're in same packages).

So this fix does:
- Add solder-impl jar artifact as a module resource for org.jboss.solder module
- Generate a jar artifact "on the fly" with the webfragment descriptor that contains the solder-impl  artifact and add this generated into the resulting webapp.

In addittion, some issue have been detected due to missing module dependencies to javax.api.

Some javax.api classes are located in the jdk runtime jar, so they cannot be detected using the maven dependency pom files.

In order to ensure the runtime stability for the distribution a dependency to javax.api module has been added in all static modules.

Commit in 6.0.x -> https://github.com/droolsjbpm/kie-wb-distributions/commit/186f79a071749d3cf5eb1ffc424df8b316462826

Comment 5 Jiri Svitak 2014-02-27 17:45:49 UTC
*** Bug 1069651 has been marked as a duplicate of this bug. ***

Comment 6 Marek Baluch 2014-03-09 10:57:36 UTC
Verified on 6.0.1.ER2.

"{Download|Share} process {PNG|PDF}" item in toolbar now produces the expected result with no exceptions present in the log.


Note You need to log in before you can comment on or make changes to this bug.