Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066997 - geo-rep package should be dependent on libxml2-devel package
Summary: geo-rep package should be dependent on libxml2-devel package
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: GlusterFS
Classification: Community
Component: geo-replication
Version: mainline
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
Assignee: David J. Mac Donald
QA Contact: David J. Mac Donald
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-19 13:27 UTC by Vijaykumar Koppad
Modified: 2014-11-11 08:28 UTC (History)
3 users (show)

Fixed In Version: glusterfs-3.6.0beta1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-11-11 08:28:09 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Vijaykumar Koppad 2014-02-19 13:27:51 UTC
Description of problem: geo-rep package should be dependent on libxml2-devel package 

Version-Release number of selected component (if applicable): 


How reproducible: Happends always


Steps to Reproduce:
1.try to install geo-rep rpms on fedora which doesn't have libxml2-devel installed 
2. Check if it succeeds 
3.

Actual results: It succeeds even if the libxml2-devel is not installed


Expected results: It shouldn't succeed if the libxml2-devel is not installed


Additional info:

Comment 1 Anand Avati 2014-02-19 13:36:29 UTC
REVIEW: http://review.gluster.org/7131 (spec: add libxml2-devel as dependency for Geo-replication) posted (#1) for review on master by Vijaykumar Koppad (vkoppad@redhat.com)

Comment 2 Anand Avati 2014-02-20 07:23:58 UTC
REVIEW: http://review.gluster.org/7131 (spec: add libxml2-devel as dependency in configure.ac) posted (#2) for review on master by Vijaykumar Koppad (vkoppad@redhat.com)

Comment 3 Anand Avati 2014-02-20 12:14:13 UTC
REVIEW: http://review.gluster.org/7131 (build: fail configure if the libxml2 devel package is missing) posted (#3) for review on master by Vijaykumar Koppad (vkoppad@redhat.com)

Comment 4 Anand Avati 2014-02-22 17:59:38 UTC
REVIEW: http://review.gluster.org/7131 (build: fail configure if the libxml2 devel package is missing.) posted (#4) for review on master by Vijaykumar Koppad (vkoppad@redhat.com)

Comment 5 Anand Avati 2014-02-25 09:21:50 UTC
REVIEW: http://review.gluster.org/7131 (build: fail configure if the libxml2 devel package is missing.) posted (#5) for review on master by Vijaykumar Koppad (vkoppad@redhat.com)

Comment 6 Anand Avati 2014-02-26 04:28:40 UTC
COMMIT: http://review.gluster.org/7131 committed in master by Vijay Bellur (vbellur@redhat.com) 
------
commit 64079f83528edb4cc4ae1a85a8633fd578b6e393
Author: Vijaykumar Koppad <vkoppad@redhat.com>
Date:   Wed Feb 19 18:51:26 2014 +0530

    build: fail configure if the libxml2 devel package is missing.
    
    Problem:
    Geo-replication uses volume info xml output.
    While installing glusterfs through build+install from source,
    and if the libxml2-devel package is not present in the system,
    build will succeed with just warning and XML output : no.
    If user fails to observe this and doesn't know that
    geo-rep is dependent on xml output, user won't be able use
    geo-rep.
    
    Solution:
    If libxml2-devel is unavailable, and if geo-rep is enabled error out in configure,
    otherwise just warn with XML_OUTPUT = no.
    If the xml-output is disabled while configuring, error out if
    geo-rep is enabled, otherwise just warn.
    
    Change-Id: Icde5d0c1e5f3b869e7db6ed6a046bdc49b450fcb
    BUG: 1066997
    Signed-off-by: Vijaykumar Koppad <vkoppad@redhat.com>
    Reviewed-on: http://review.gluster.org/7131
    Reviewed-by: Niels de Vos <ndevos@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>

Comment 10 Niels de Vos 2014-09-22 12:36:16 UTC
A beta release for GlusterFS 3.6.0 has been released. Please verify if the release solves this bug report for you. In case the glusterfs-3.6.0beta1 release does not have a resolution for this issue, leave a comment in this bug and move the status to ASSIGNED. If this release fixes the problem for you, leave a note and change the status to VERIFIED.

Packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update (possibly an "updates-testing" repository) infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-September/018836.html
[2] http://supercolony.gluster.org/pipermail/gluster-users/

Comment 13 Niels de Vos 2014-11-11 08:28:09 UTC
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.6.1, please reopen this bug report.

glusterfs-3.6.1 has been announced [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://supercolony.gluster.org/pipermail/gluster-users/2014-November/019410.html
[2] http://supercolony.gluster.org/mailman/listinfo/gluster-users


Note You need to log in before you can comment on or make changes to this bug.