Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066837 - File creation on cifs mount of a gluster volume fails
Summary: File creation on cifs mount of a gluster volume fails
Keywords:
Status: CLOSED UPSTREAM
Alias: None
Product: GlusterFS
Classification: Community
Component: libgfapi
Version: pre-release
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Poornima G
QA Contact: Sudhir D
URL:
Whiteboard:
Depends On:
Blocks: 1067930
TreeView+ depends on / blocked
 
Reported: 2014-02-19 08:09 UTC by Poornima G
Modified: 2014-04-09 06:56 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
: 1067930 (view as bug list)
Environment:
Last Closed: 2014-04-09 06:56:59 UTC
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:


Attachments (Terms of Use)

Description Poornima G 2014-02-19 08:09:50 UTC
Description of problem:
Create, write of any file fails on a cifs mount of a gluster volume.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Cifs mount a gluster volume
2. Echo to a new file fails


Actual results:
[root@vm2 cifs]# echo "kjdshjfds" > test
-bash: test: Cannot allocate memory
[root@vm2 cifs]# 


Expected results:


Additional info:
This is a regression caused by the patch http://review.gluster.org/#/c/6931/

Comment 1 Anand Avati 2014-02-19 08:57:30 UTC
REVIEW: http://review.gluster.org/7125 (libgfapi: In glfs_resolve_at(), do not overrite the previous return value.) posted (#1) for review on master by Poornima G (pgurusid@redhat.com)

Comment 2 Anand Avati 2014-02-19 09:15:06 UTC
REVIEW: http://review.gluster.org/7125 (libgfapi: In glfs_resolve_at(), do not override the previous return value.) posted (#2) for review on master by Poornima G (pgurusid@redhat.com)

Comment 3 Anand Avati 2014-02-20 01:10:06 UTC
COMMIT: http://review.gluster.org/7125 committed in master by Anand Avati (avati@redhat.com) 
------
commit ff0cd7c4e326d848d5fa6591c7cc8ce54711d2d7
Author: Poornima G <pgurusid@redhat.com>
Date:   Wed Feb 19 14:12:29 2014 +0530

    libgfapi: In glfs_resolve_at(), do not override the previous return value.
    
    Overriding ret to contain glfs_loc_touchup()s' return value implies that
    if glfs_loc_touchup() is successful, glfs_resolve_at() is also successful
    which is not necessarily true. This was causing glfs_resolve_at() to
    succeed even if it couldn't resolve, thus create and other fops would
    fail. Hence overriding ret only if glfs_loc_touchup() fails.
    
    Change-Id: I0804afbd120b3798abe07e870bfc40bf162bc289
    BUG: 1066837
    Signed-off-by: Poornima G <pgurusid@redhat.com>
    Reviewed-on: http://review.gluster.org/7125
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Anand Avati <avati@redhat.com>


Note You need to log in before you can comment on or make changes to this bug.