Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066834 - [engine-backend] Can add multiple boot disks to a vm
Summary: [engine-backend] Can add multiple boot disks to a vm
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
: 3.4.0
Assignee: Liron Aravot
QA Contact: Carlos Mestre González
URL:
Whiteboard: storage
Depends On:
Blocks: rhev3.4beta 1142926
TreeView+ depends on / blocked
 
Reported: 2014-02-19 08:04 UTC by Liron Aravot
Modified: 2016-02-10 20:21 UTC (History)
10 users (show)

Fixed In Version: ovirt-engine-3.4.0_av2
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed:
oVirt Team: Storage


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
oVirt gerrit 24715 None None None Never

Description Liron Aravot 2014-02-19 08:04:20 UTC
Description of problem:
Few boot disks can be added to a vm through rest-api (can't be done through UI as the button is blocked, the problem is in the backend)

How reproducible:
always


Steps to Reproduce:
1.Create a vm with bootable disk,
2.try to add another new bootable disk to the vm

Actual results:
the operation is succesful and the vm has 2 bootable disks attached


Expected results:
CDA message should be returned

Comment 1 Leonid Natapov 2014-03-13 09:09:18 UTC
only one boot disk can be added to VM. 3.4.0-0.3.master.el6ev

Comment 2 Leonid Natapov 2014-03-13 09:22:11 UTC
moved to verified by mistake. should be tested with REST.

Comment 3 Carlos Mestre González 2014-03-19 10:41:04 UTC
<?xml version="1.0" encoding="UTF-8" standalone="yes"?>
    <fault>
    <reason>Operation Failed</reason>
    <detail>[Cannot add Virtual Machine Disk. Disk vm_multiple_bootable_disks_Disk1 in VM vm_multiple_bootable_disks is already marked as boot.]</detail>
</fault>

Verified in: rhevm 3.4.0-0.3.master.el6ev

Comment 4 Itamar Heim 2014-06-12 14:10:19 UTC
Closing as part of 3.4.0


Note You need to log in before you can comment on or make changes to this bug.