Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066783 - [abrt] dnf: base.py:136:_add_repo_to_sack:RuntimeException: load_yum_repo() failed: 3.
Summary: [abrt] dnf: base.py:136:_add_repo_to_sack:RuntimeException: load_yum_repo() f...
Keywords:
Status: CLOSED DUPLICATE of bug 1047087
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:f2f1b87e76c9edb3659c066a146...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-19 05:58 UTC by s-worm
Modified: 2014-02-19 10:26 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-19 10:23:19 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2014-02-19 05:58 UTC, s-worm
no flags Details
File: environ (deleted)
2014-02-19 05:58 UTC, s-worm
no flags Details
hawkey.log (deleted)
2014-02-19 08:31 UTC, s-worm
no flags Details

Description s-worm 2014-02-19 05:58:19 UTC
Version-Release number of selected component:
dnf-0.4.11-1.fc20

Additional info:
reporter:       libreport-2.1.12
cmdline:        /usr/bin/python /usr/bin/dnf -v makecache timer
executable:     /usr/bin/dnf
kernel:         3.11.6-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            0

Truncated backtrace:
base.py:136:_add_repo_to_sack:RuntimeException: load_yum_repo() failed: 3.

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 240, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 63, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 122, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1456, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 798, in run
    self.base.fill_sack() # performs the md sync
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 212, in fill_sack
    self._add_repo_to_sack(r.id)
  File "/usr/lib/python2.7/site-packages/dnf/base.py", line 136, in _add_repo_to_sack
    self._sack.load_yum_repo(hrepo, build_cache=True, load_filelists=True)
RuntimeException: load_yum_repo() failed: 3.

Local variables in innermost frame:
repo: <Repo fedora>
hrepo: <_hawkey.Repo object at 0x2742078>
self: <dnf.cli.cli.BaseCli object at 0x265ac10>
name: 'fedora'

Comment 1 s-worm 2014-02-19 05:58:25 UTC
Created attachment 864971 [details]
File: backtrace

Comment 2 s-worm 2014-02-19 05:58:27 UTC
Created attachment 864972 [details]
File: environ

Comment 3 Parag Nemade 2014-02-19 06:18:11 UTC
try the latest dnf-0.4.14 from http://koji.fedoraproject.org/koji/buildinfo?buildID=498009 and see if this traceback occurs again.

I can't reproduce this bug on my f20 with command "dnf -v makecache timer"

Comment 4 Ales Kozumplik 2014-02-19 07:46:31 UTC
comment 3.

Comment 5 Ales Kozumplik 2014-02-19 07:49:09 UTC
Also, please try with the latest hawkey.

Comment 6 Ales Kozumplik 2014-02-19 07:52:54 UTC
Oh, and since this seems as an error propagated from libsolv, can you please attach /var/cache/dnf/x86_64/20/hawkey.log first?

Comment 7 s-worm 2014-02-19 08:31:13 UTC
Created attachment 865000 [details]
hawkey.log

requested file

Comment 8 Ales Kozumplik 2014-02-19 10:23:19 UTC
Thanks.

Judging from these lines in the log:

INFO Jan-20 17:48:27 using cached fedora
LSERROR Jan-20 17:48:27 expanding strings size mismatch
ERROR Jan-20 17:48:27 repo_add_solv() has failed.

it is a duplicate of previous bug 1047087. Please reopen this if you observe the problem again with dnf-0.4.10 or more recent and libsolv-0.4.1-1 or more recent. Attach 'rpm -q libsolv hawkey' then, along with the current hawkey.log.

*** This bug has been marked as a duplicate of bug 1047087 ***

Comment 9 Ales Kozumplik 2014-02-19 10:26:54 UTC
(In reply to Ales Kozumplik from comment #8)

> the problem again with dnf-0.4.10 or more recent and libsolv-0.4.1-1 or more

should be hawkey-0.4.10!


Note You need to log in before you can comment on or make changes to this bug.