Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066767 - core upload fails: release 'fedora-%{bug_version}-x86_64' is not supported by the Retrace server
Summary: core upload fails: release 'fedora-%{bug_version}-x86_64' is not supported by...
Keywords:
Status: CLOSED DUPLICATE of bug 1062156
Alias: None
Product: Fedora
Classification: Fedora
Component: abrt
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: abrt
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-19 05:00 UTC by Paul DeStefano
Modified: 2014-02-19 09:27 UTC (History)
6 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-19 09:27:36 UTC


Attachments (Terms of Use)

Description Paul DeStefano 2014-02-19 05:00:40 UTC
Description of problem:

abrt failed to upload core because server rejected it.  This is the full event log:

2014-02-18-20:39:23> ('report_uReport' completed successfully)
2014-02-18-20:39:23> Ok to upload core dump? (It may contain sensitive data). If your answer is 'No', a stack trace will be generated locally. (It may download a huge amount of data). 'YES'
2014-02-18-20:39:23  Querying server settings
2014-02-18-20:39:43  The release 'fedora-%{bug_version}-x86_64' is not supported by the Retrace server.
2014-02-18-20:39:43  The server is not able to handle your request.
2014-02-18-20:39:43  Do you want to generate a stack trace locally? (It may download a huge amount of data but reporting can't continue without stack trace). 'YES'
2014-02-18-20:39:43  Analyzing coredump 'coredump'
2014-02-18-20:39:43  Missing build id: libatiuki.so.1
2014-02-18-20:39:43  Missing build id: libGL.so.1
2014-02-18-20:39:43  Coredump references 249 debuginfo files, 249 of them are not installed
2014-02-18-20:39:43  Setting up yum repositories
2014-02-18-20:39:55* ('analyze_CCpp' was killed by signal 15)

Version-Release number of selected component (if applicable):
abrt-2.1.11-1.fc19.x86_64

How reproducible:
This is the first time I've seen this, but I this happens all the time on this particular crash.  This is the most recent crash, so I'm worried this is a new trend.

Steps to Reproduce:
1.
2.
3.

Actual results:
Cannot submit coredump to retrace server

Expected results:
Should upload core file

Additional info:

Comment 1 Jakub Filak 2014-02-19 09:27:36 UTC
Thank you for the report. This is a bug in fedora-release package which has already been reported into Bugzilla (bug #1062156). '/etc/os-release' file contains unexpanded rpm macro which is not defined in fedora-release's F19 spec file. You can fix this issue on your own by replacing '%{bug_version}' string with '19' string.

Unfortunately, the solution for the fedora-release bug won't help in case of the failure while crash reporting. ABRT creates a copy of '/etc/os-release' file for each detected crash and these file copies contain the unexpanded macro too. In order to re-enabled reporting, you have to find all 'os_info' files in /var/tmp/abrt subdirectories and replace the unexpanded macro by '19' string.

The following command should help (please run it as root):

$ find /var/tmp/abrt -mindepth 2 -maxdepth 2 -name "os_info" -exec sed -i 's,%{bug_version},19,' {} \;

*** This bug has been marked as a duplicate of bug 1062156 ***


Note You need to log in before you can comment on or make changes to this bug.