Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066750 - JBDSIS 7.0.0 fails to install Teiid, Designer, Client into JBDS 8.0.0.alpha2
Summary: JBDSIS 7.0.0 fails to install Teiid, Designer, Client into JBDS 8.0.0.alpha2
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: JBoss Fuse Service Works 6
Classification: JBoss
Component: Tooling
Version: unspecified
Hardware: Unspecified
OS: Unspecified
unspecified
urgent
Target Milestone: ---
: ---
Assignee: Rob Cernich
QA Contact: Len DiMaggio
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-19 02:59 UTC by Len DiMaggio
Modified: 2014-08-15 02:18 UTC (History)
2 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-15 02:18:08 UTC
Type: Bug


Attachments (Terms of Use)

Description Len DiMaggio 2014-02-19 02:59:37 UTC
Description of problem:

With JBDS 8.0.0.alpha2:

Version: 8.0.0.Alpha2
Build id: Alpha2-v20140214-1707-B71
Build date: 20140214-1707

And JBDSIS 7.0.0:
http://download.jboss.org/jbosstools/updates/stable/kepler/integration-stack

These plugins fail to install:
* Teiid Designer
* Teiid Designer Runtime
* Teiid Runtime Clients

Cannot complete the install because of a conflicting dependency.
  Software being installed: Teiid Designer 8.3.1.Final-v20140122-1920-B21 (org.teiid.designer.feature.feature.group 8.3.1.Final-v20140122-1920-B21)
  Software currently installed: JBoss Developer Studio (Branded Product) 8.0.0.Alpha2-v20140214-1707-B71 (com.jboss.devstudio.core.package 8.0.0.Alpha2-v20140214-1707-B71)
  Only one of the following can be installed at once: 
    Mbeans Plug-in 3.0.0.Alpha2-v20140212-1516-B15 (org.jboss.ide.eclipse.as.ui.mbeans 3.0.0.Alpha2-v20140212-1516-B15)
    Mbeans Plug-in 2.4.101.Final-v20131206-1843-B159 (org.jboss.ide.eclipse.as.ui.mbeans 2.4.101.Final-v20131206-1843-B159)
  Cannot satisfy dependency:
    From: JBoss Developer Studio (Core Features) 8.0.0.Alpha2-v20140214-1707-B71 (com.jboss.devstudio.core.feature.feature.group 8.0.0.Alpha2-v20140214-1707-B71)
    To: org.jboss.ide.eclipse.as.feature.feature.group [3.0.0.Alpha2-v20140212-1516-B15]
  Cannot satisfy dependency:
    From: JBoss Developer Studio (Branded Product) 8.0.0.Alpha2-v20140214-1707-B71 (com.jboss.devstudio.core.package 8.0.0.Alpha2-v20140214-1707-B71)
    To: com.jboss.devstudio.core.feature.feature.group [8.0.0.Alpha2-v20140214-1707-B71]
  Cannot satisfy dependency:
    From: JBossAS Tools 2.4.101.Final-v20131206-1843-B159 (org.jboss.ide.eclipse.as.feature.feature.group 2.4.101.Final-v20131206-1843-B159)
    To: org.jboss.ide.eclipse.as.ui.mbeans [2.4.101.Final-v20131206-1843-B159]
  Cannot satisfy dependency:
    From: JBossAS Tools 3.0.0.Alpha2-v20140212-1516-B15 (org.jboss.ide.eclipse.as.feature.feature.group 3.0.0.Alpha2-v20140212-1516-B15)
    To: org.jboss.ide.eclipse.as.ui.mbeans [3.0.0.Alpha2-v20140212-1516-B15]
  Cannot satisfy dependency:
    From: Teiid Designer 8.3.1.Final-v20140122-1920-B21 (org.teiid.designer.feature.feature.group 8.3.1.Final-v20140122-1920-B21)
    To: org.jboss.ide.eclipse.as.feature.feature.group [2.4.100,3.0.0)



Cannot complete the install because of a conflicting dependency.
  Software being installed: Teiid Runtime Clients 8.3.1.Final-v20140122-1920-B21 (org.teiid.designer.teiid.client.feature.feature.group 8.3.1.Final-v20140122-1920-B21)
  Software currently installed: JBoss Developer Studio (Branded Product) 8.0.0.Alpha2-v20140214-1707-B71 (com.jboss.devstudio.core.package 8.0.0.Alpha2-v20140214-1707-B71)
  Only one of the following can be installed at once: 
    Core Runtime 3.10.0.v20140123-0905 (org.eclipse.core.runtime 3.10.0.v20140123-0905)
    Core Runtime 3.9.0.v20130326-1255 (org.eclipse.core.runtime 3.9.0.v20130326-1255)
  Cannot satisfy dependency:
    From: JBoss Developer Studio (Branded Product) 8.0.0.Alpha2-v20140214-1707-B71 (com.jboss.devstudio.core.package 8.0.0.Alpha2-v20140214-1707-B71)
    To: toolingcom.jboss.devstudio.core.package.configuration [8.0.0.Alpha2-v20140214-1707-B71]
  Cannot satisfy dependency:
    From: JBoss AS Core Plug-in 2.4.101.Final-v20131206-1843-B159 (org.jboss.ide.eclipse.as.core 2.4.101.Final-v20131206-1843-B159)
    To: bundle org.eclipse.core.runtime [3.7.0,3.10.0)
  Cannot satisfy dependency:
    From: Teiid Runtime Clients 8.3.1.Final-v20140122-1920-B21 (org.teiid.designer.teiid.client.feature.feature.group 8.3.1.Final-v20140122-1920-B21)
    To: org.jboss.ide.eclipse.as.core [2.4.0,3.0.0)
  Cannot satisfy dependency:
    From: toolingcom.jboss.devstudio.core.package.configuration 8.0.0.Alpha2-v20140214-1707-B71
    To: toolinggtk.linux.x86_64org.eclipse.core.runtime [8.0.0.Alpha2-v20140214-1707-B71]
  Cannot satisfy dependency:
    From: toolinggtk.linux.x86_64org.eclipse.core.runtime 8.0.0.Alpha2-v20140214-1707-B71
    To: bundle org.eclipse.core.runtime 3.10.0.v20140123-0905


Cannot complete the install because of a conflicting dependency.
  Software being installed: Teiid Designer Runtime 8.3.1.Final-v20140122-1920-B21 (org.teiid.designer.runtime.feature.feature.group 8.3.1.Final-v20140122-1920-B21)
  Software currently installed: JBoss Developer Studio (Branded Product) 8.0.0.Alpha2-v20140214-1707-B71 (com.jboss.devstudio.core.package 8.0.0.Alpha2-v20140214-1707-B71)
  Only one of the following can be installed at once: 
    JBoss Server Tools - Runtimes Integration 3.0.0.Alpha2-v20140212-1516-B15 (org.jboss.tools.as.runtimes.integration 3.0.0.Alpha2-v20140212-1516-B15)
    JBoss Server Tools - Runtimes Integration 2.4.101.Final-v20131206-1843-B159 (org.jboss.tools.as.runtimes.integration 2.4.101.Final-v20131206-1843-B159)
  Cannot satisfy dependency:
    From: JBoss Developer Studio (Core Features) 8.0.0.Alpha2-v20140214-1707-B71 (com.jboss.devstudio.core.feature.feature.group 8.0.0.Alpha2-v20140214-1707-B71)
    To: org.jboss.ide.eclipse.as.feature.feature.group [3.0.0.Alpha2-v20140212-1516-B15]
  Cannot satisfy dependency:
    From: JBoss Developer Studio (Branded Product) 8.0.0.Alpha2-v20140214-1707-B71 (com.jboss.devstudio.core.package 8.0.0.Alpha2-v20140214-1707-B71)
    To: com.jboss.devstudio.core.feature.feature.group [8.0.0.Alpha2-v20140214-1707-B71]
  Cannot satisfy dependency:
    From: JBossAS Tools 3.0.0.Alpha2-v20140212-1516-B15 (org.jboss.ide.eclipse.as.feature.feature.group 3.0.0.Alpha2-v20140212-1516-B15)
    To: org.jboss.tools.as.runtimes.integration [3.0.0.Alpha2-v20140212-1516-B15]
  Cannot satisfy dependency:
    From: JBossAS Tools 2.4.101.Final-v20131206-1843-B159 (org.jboss.ide.eclipse.as.ui 2.4.101.Final-v20131206-1843-B159)
    To: bundle org.jboss.tools.as.runtimes.integration [2.4.0,3.0.0)
  Cannot satisfy dependency:
    From: Teiid Designer Runtime 8.3.1.Final-v20140122-1920-B21 (org.teiid.designer.runtime.feature.feature.group 8.3.1.Final-v20140122-1920-B21)
    To: org.jboss.ide.eclipse.as.ui [2.4.0,3.0.0)







Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Len DiMaggio 2014-02-19 03:02:55 UTC
See: https://issues.jboss.org/browse/JBTIS-241

Comment 2 kconner 2014-08-15 02:18:08 UTC
can't install jbdsis 7 on jbds 8


Note You need to log in before you can comment on or make changes to this bug.