Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066744 - GSSAPI Authentication fails with Bad configuration option: protocolkeepalives
Summary: GSSAPI Authentication fails with Bad configuration option: protocolkeepalives
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: x2goclient
Version: 20
Hardware: x86_64
OS: Linux
unspecified
unspecified
Target Milestone: ---
Assignee: Orion Poplawski
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-19 01:54 UTC by Chris Derichs
Modified: 2014-03-02 03:43 UTC (History)
1 user (show)

Fixed In Version: x2goclient-4.0.1.3-4.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-02 03:43:47 UTC


Attachments (Terms of Use)

Description Chris Derichs 2014-02-19 01:54:55 UTC
Description of problem:
When attempting to a server with the Kerberos 5 GSSAPI option check the connection fails with the error:
Connection Failed command-line: line 0: Bad configuration option: protocolkeepalives

Version-Release number of selected component (if applicable):
V. 4.0.1.3 (Qt - 4.8.5)

How reproducible:
Most times. (Sometimes I get a different timeout error)


Steps to Reproduce:
0: Setup two computers in the same Kerberos Realm where single sign-on works for SSH'ing between them without being prompted for credentials. x2goserver should be installed on the other.

1. Start x2goclient
2. Setup a new connection.
3. Fill in the Host, Login name, and check Kerberos 5 (GSSAPI)
4. Save then attempt to connect.
5. See error message.

Actual results:
Error message, connection fails

Expected results:
No error, connection opens.

Additional info:

It looks to me like the problem is in shhprocess.cpp
http://code.x2go.org/gitweb?p=x2goclient.git;a=blob;f=sshprocess.cpp;h=07c009f58911a439fed108c7b850d01514cc47cc;hb=HEAD

Lines 34- 38 are a macro related to the error message. It seems if it's not a Mac, -o ProtocolKeepalives=60 is put on the command line for ssh. On Fedora's version of ssh: ssh -o ProtocolKeepAlives=60 hostname fails with the same error but works with ssh -o ServerAliveInterval=60 (the option it puts in case of Mac.)

It seems for Fedora we'd always want  
#define KEEPALIVE_OPTION " -o ServerAliveInterval=60 "
not 
#define KEEPALIVE_OPTION " -o ProtocolKeepAlives=60 "

There's lots of instances of that module building launch strings for ssh using that MACRO but I'm not sure which one is actually the one being used.

Comment 1 Orion Poplawski 2014-02-19 03:16:51 UTC
Thank you very much for the excellent diagnosis.  New build coming shortly.

Comment 2 Fedora Update System 2014-02-19 04:55:55 UTC
x2goclient-4.0.1.3-4.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/x2goclient-4.0.1.3-4.fc20

Comment 3 Chris Derichs 2014-02-19 05:18:44 UTC
Update x2goclient-4.0.1.3-4.fc20 fixes this issue for me. Thanks.

Comment 4 Fedora Update System 2014-02-22 00:34:51 UTC
Package x2goclient-4.0.1.3-4.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing x2goclient-4.0.1.3-4.fc20'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2776/x2goclient-4.0.1.3-4.fc20
then log in and leave karma (feedback).

Comment 5 Fedora Update System 2014-03-02 03:43:47 UTC
x2goclient-4.0.1.3-4.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.