Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066718 - some games, which worked in F19, no longer work in F20 (radeonsi)
Summary: some games, which worked in F19, no longer work in F20 (radeonsi)
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: mesa
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 23:52 UTC by Elad Alfassa
Modified: 2014-03-15 15:26 UTC (History)
5 users (show)

Fixed In Version: mesa-10.0.3-1.20140206.fc20
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-03-15 15:26:11 UTC


Attachments (Terms of Use)
Kerbal apitrace (deleted)
2014-02-19 19:20 UTC, Elad Alfassa
no flags Details

Description Elad Alfassa 2014-02-18 23:52:37 UTC
some games, which worked in F19, no longer work in F20 -  they just show a black window. When updating mesa packages using sudo dnf info mesa-dri-drivers --enablerepo=rawhide, those games work again.

My GPU is Radeon 7770.

I consider this a regression, and since the fix is in rawhide already, I wonder, would backporting it to F20 be feasible?

I'm willing to provide developers who want to fix this bug with keys (or send them as a gift on Steam) to any the affected games (Proteus, Kerbal Space Program, Jazzpunk, Dust: An Elysian Tail, FEZ and more)

(note: I'm not sure if FEZ is affected, but I have a solid reason to believe it is, because this bug seems to affect mono based games and FEZ is based on mono)

This bug is important to me because it means people with this GPU (or GPUs form the same series) can't play games without updating to unstable rawhide. I personally don't like running a mix of rawhide & non rawhide packages.

Comment 1 Igor Gnatenko 2014-02-19 04:02:57 UTC
Hi,

what you mean about not working ? crashing, artefacting or what?

If we can find which patch fixes problem - I will contact with upstream and we will cherry-pick this patch to 9.x.

We can't merge mesa 10.[ to the f20, because there needed new xorg stack and 10.x in some cases really unstable.

Comment 2 Igor Gnatenko 2014-02-19 04:15:52 UTC
In the F19 we have mesa-9.2.4, but in the F20 we have mesa-9.2.5....
All commits between... Are you sure that you have no bugs with 9.2.4 ?
Try this build on F20: http://koji.fedoraproject.org/koji/taskinfo?taskID=6545865

4636e87191fddd492ed8c61ba61faf4b2d89b2e4 docs: Add release notes for 9.2.5
a32330eb93ad4cdb7f4c5bc4c730d7f3ff4042d0 Bump version to 9.2.5
83f1f6d2ef0aed8b5515d063361850fa7a261454 i965/fs: Gen4-5: Implement alpha test in shader for MRT
56b0e3271a26d90f760319434ccb518b205dc2bb i965/fs: Gen4-5: Setup discard masks for MRT alpha test
4f247c28e5e626772804f713e0ec72bb517bb0cc i965: Gen4-5: Include alpha func/ref in program key
711b15ddb9c7ba74dfcf667e8f8ace9d11e58746 i965: Gen4-5: Don't enable hardware alpha test with MRT
b62501680208863c71d0adddd8d679f78d19bfa8 st/xorg: Handle new DamageUnregister API which has only one argument
3d8f3eea5262873e2bc4886fa7dc7da805c20385 nv50: report 15 max inputs for fragment programs
a6524c6d81dc27b45a6e6c9020dbfcf74fb3d643 swrast: fix readback regression since inversion fix
a3b657a6078a146b0ae514879c2affc8e44d7f1e glx: don't fail out when no configs if we have visuals
f5a8a37c739cc437ac949cba586ff9db3b6d1dda mesa/swrast: fix inverted front buffer rendering with old-school swrast
f0dfdbfc79c458ecb13ddfd413dcc70e8957ae5b r300/compiler/tests: Fix line length check in test parser
961e2c8ada6659373c979d1b3f35abd07b9b52e7 r300/compiler/tests: Fix segfault
a15aa108ea637550741b13b7c74248a99b53237e glsl: Don't emit empty declaration warning for a struct specifier
767623bbf223a0dc6cb930fc5b5aa67ca131abe7 nv50: wait on the buf's fence before sticking it into pushbuf
94e7e35d6e3cc3f72c1e81309c3503c46ecea34c nouveau: avoid leaking fences while waiting
bd304ffc859534e8d899c19e98a06caa762f8589 nv50: Fix GPU_READING/WRITING bit removal
16c5f241411798ac4360ff8c3500c1d68c8a6127 i965: Add extra-alignment for non-msrt fast color clear for all hw (v2)
b60eb2e17446d0d581963d129ae6fcd98a9cb97f i965/hsw: Apply non-msrt fast color clear w/a to all HSW GTs
ebe8e9b01f245f90d31a2e54a83fc58a808e4b47 docs: Add md5sums for the 9.2.4 release

Comment 3 Elad Alfassa 2014-02-19 06:45:55 UTC
Not working in this case means black screen on startup. I dont know if they woek on current f19. They worked on F19 few months ago. I lack the exact details cause I did not have Fedora on that machinefor the last 4 months or morr.

I also need to test if the same issue happens on a fresh f20 with no updates installed, to try and nail down exactly when this regression occurred. 

I will also use apitrace to find what the games are doing when they freeze on a blank window. If you want to debug it yourself too, I can email you a download key for one of the affected games.

Comment 4 Igor Gnatenko 2014-02-19 07:13:54 UTC
have you tried build from comment #2 ?
http://koji.fedoraproject.org/koji/taskinfo?taskID=6545865

(In reply to Elad Alfassa from comment #3)
> I will also use apitrace to find what the games are doing when they freeze
> on a blank window. If you want to debug it yourself too, I can email you a
> download key for one of the affected games.
sounds good.

Comment 5 Elad Alfassa 2014-02-19 19:20:19 UTC
Created attachment 865184 [details]
Kerbal apitrace

I tried this build, same issue.

Now trying F20 and F19 Live CDs to try and see when it broke.

Attached is an apitrace of Kerbal Space Program.
I wanted to do a trace of something simpler, but apparently tracing 32bit apps in apitrace is impossible, and Kerbal is the only game I had which has a 64bit executable.

Comment 6 Elad Alfassa 2014-02-19 20:03:13 UTC
I can't boot 32bit Fedora livecds on this machine for some reason (and I can't test with 64bit because steam needs 32bit and installing them using yum on the live environment won't work because yum will fetch the newest versions, and what we want to test are the older versions).

Do you have any ideas on how to debug this without running 32bit fedora live?

Also, if you want me to send you a game key so you can debug this, just let me know which game(s) you want.

Comment 7 Fedora Update System 2014-03-10 06:12:15 UTC
mesa-10.0.3-1.20140206.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/mesa-10.0.3-1.20140206.fc20

Comment 8 Harald Reindl 2014-03-10 17:54:48 UTC
please take a look at the AutoQA messages

http://autoqa.fedoraproject.org/results/768584-autotest/virt09.qa/depcheck/results/mesa-10.0.3-1.201402.html

there are packages which needs a rebuild too
i upgraded today my both workstations (SandyBrdige/IvyBdrige) with Intel graphics and gave positive karma because all is fine on KDE with desktop effects, but there are for sure users with not that sripped down installs

[harry@srv-rhsoft:~]$ rpm -qa | wc -l
1415

Comment 9 Igor Gnatenko 2014-03-10 19:21:33 UTC
(In reply to Harald Reindl from comment #8)
> please take a look at the AutoQA messages
> 
> http://autoqa.fedoraproject.org/results/768584-autotest/virt09.qa/depcheck/
> results/mesa-10.0.3-1.201402.html
> 
> there are packages which needs a rebuild too
> i upgraded today my both workstations (SandyBrdige/IvyBdrige) with Intel
> graphics and gave positive karma because all is fine on KDE with desktop
> effects, but there are for sure users with not that sripped down installs
> 
> [harry@srv-rhsoft:~]$ rpm -qa | wc -l
> 1415

Yeah. I've noticed about this. I'll ask airlied for rebuilding vmware driver

Comment 10 Fedora Update System 2014-03-11 04:13:09 UTC
Package mesa-10.0.3-1.20140206.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mesa-10.0.3-1.20140206.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3719/mesa-10.0.3-1.20140206.fc20
then log in and leave karma (feedback).

Comment 11 Igor Gnatenko 2014-03-11 19:15:13 UTC
Updated bodhi update.
https://admin.fedoraproject.org/updates/FEDORA-2014-3719

There no more dependencies problem.

Comment 12 Fedora Update System 2014-03-12 12:23:45 UTC
Package mesa-10.0.3-1.20140206.fc20, xorg-x11-drv-vmware-13.0.1-3.20131207gita40cbd7b.fc20:
* should fix your issue,
* was pushed to the Fedora 20 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mesa-10.0.3-1.20140206.fc20 xorg-x11-drv-vmware-13.0.1-3.20131207gita40cbd7b.fc20'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-3719/xorg-x11-drv-vmware-13.0.1-3.20131207gita40cbd7b.fc20,mesa-10.0.3-1.20140206.fc20
then log in and leave karma (feedback).

Comment 13 Fedora Update System 2014-03-15 15:26:11 UTC
mesa-10.0.3-1.20140206.fc20, xorg-x11-drv-vmware-13.0.1-3.20131207gita40cbd7b.fc20 has been pushed to the Fedora 20 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.