Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066670 - RFE: require perl(LWP::Protocol::https)
Summary: RFE: require perl(LWP::Protocol::https)
Keywords:
Status: CLOSED NOTABUG
Alias: None
Product: Fedora
Classification: Fedora
Component: perl-libwww-perl
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Pisar
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 20:52 UTC by Bill Nottingham
Modified: 2014-03-17 03:34 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-19 07:21:52 UTC


Attachments (Terms of Use)

Description Bill Nottingham 2014-02-18 20:52:40 UTC
Description of problem:

Because
1) in general, users of perl-libwww-perl are going to want https support
2) it's used in such a way that code that tries to use https support with perl-LWP won't get an automatic requirement on it

Version-Release number of selected component (if applicable):

perl-libwww-perl-6.05-3.fc20.noarch

How reproducible:

100%

Steps to Reproduce:
1. attempt to debug https://bugzilla.redhat.com/show_bug.cgi?id=859607
2. instrument the code to see the request errors

Actual results:

oh, need a package for https support

Expected results:

https support out of the box.

Comment 1 Petr Pisar 2014-02-19 07:21:52 UTC
No. The libraries are separated by upstream as well as in Fedora on this very purpose: To have HTTPS optional. If your application cannot live without HTTPS, require 'perl(LWP::Protocol::https)' explicitly.

Comment 2 Bill Nottingham 2014-02-19 15:50:46 UTC
Maybe not a conversation for the bug, but what I don't get is *why* having https optional is a feature; I cannot think of other web clients that have it optional in this way.

Comment 3 Petr Pisar 2014-02-19 16:29:01 UTC
(1) It brings nontrivial amount of dependencies. Especially crypto dependencies.
(2) The whole idea of libwww is to be pluggable. There is support for FTP, Gopher, NNTP, etc. HTTPS is just another one.

Comment 4 Bill Nottingham 2014-02-19 17:47:01 UTC
1) Only additional dependencies over perl-libwww-perl (from installing in a chroot) are Mozilla-CA and itself, total of 22k.
2) Right, and ftp, gopher, nntp are all in the main package. The only other protocol split out is http 1.0.

Comment 5 Petr Pisar 2014-02-20 06:17:53 UTC
(1) You have lost the TLS implementation somewhere.

(2) Well, they do not require the whole bunch of TLS stuff.

I got a message yesterday that Fedora's rpm finally understands optional dependencies. I could try to utilize one of them.


Note You need to log in before you can comment on or make changes to this bug.