Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066648 - [abrt] dnf: i18n.py:38:write:UnicodeEncodeError: 'ascii' codec can't encode character u'\u02bc' in position 49: ordinal not in range(128)
Summary: [abrt] dnf: i18n.py:38:write:UnicodeEncodeError: 'ascii' codec can't encode c...
Keywords:
Status: CLOSED DUPLICATE of bug 1063022
Alias: None
Product: Fedora
Classification: Fedora
Component: dnf
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Packaging Maintenance Team
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:5f45863914c968272e335324f0b...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 19:32 UTC by Peter Oliver
Modified: 2014-02-19 07:38 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-19 07:38:52 UTC


Attachments (Terms of Use)
File: backtrace (deleted)
2014-02-18 19:32 UTC, Peter Oliver
no flags Details
File: environ (deleted)
2014-02-18 19:32 UTC, Peter Oliver
no flags Details

Description Peter Oliver 2014-02-18 19:32:27 UTC
Description of problem:
$ locale 
LANG=en_GB.UTF-8
LC_CTYPE="en_GB.UTF-8"
LC_NUMERIC="en_GB.UTF-8"
LC_TIME="en_GB.UTF-8"
LC_COLLATE="en_GB.UTF-8"
LC_MONETARY="en_GB.UTF-8"
LC_MESSAGES="en_GB.UTF-8"
LC_PAPER="en_GB.UTF-8"
LC_NAME="en_GB.UTF-8"
LC_ADDRESS="en_GB.UTF-8"
LC_TELEPHONE="en_GB.UTF-8"
LC_MEASUREMENT="en_GB.UTF-8"
LC_IDENTIFICATION="en_GB.UTF-8"
LC_ALL=
$ dnf -C search fonts | cat

Version-Release number of selected component:
dnf-0.4.13-2.fc20

Additional info:
reporter:       libreport-2.1.12
cmdline:        /usr/bin/python /usr/bin/dnf -C search font
executable:     /usr/bin/dnf
kernel:         3.12.10-300.fc20.x86_64
runlevel:       N 5
type:           Python
uid:            5000

Truncated backtrace:
i18n.py:38:write:UnicodeEncodeError: 'ascii' codec can't encode character u'\u02bc' in position 49: ordinal not in range(128)

Traceback (most recent call last):
  File "/usr/bin/dnf", line 35, in <module>
    main.user_main(sys.argv[1:], exit_code=True)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 242, in user_main
    errcode = main(args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 64, in main
    return _main(base, args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/main.py", line 124, in _main
    cli.run()
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1454, in run
    return self.command.run(self.base.extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/commands.py", line 988, in run
    return self.cli.search(extcmds)
  File "/usr/lib/python2.7/site-packages/dnf/cli/cli.py", line 1515, in search
    args)
  File "/usr/lib/python2.7/site-packages/dnf/cli/output.py", line 1118, in matchcallback
    print(msg)
  File "/usr/lib/python2.7/site-packages/dnf/i18n.py", line 38, in write
    self.stream.write(s.decode(self.encoding, 'replace'))
UnicodeEncodeError: 'ascii' codec can't encode character u'\u02bc' in position 49: ordinal not in range(128)

Local variables in innermost frame:
s: 'senamirmir-washra-fonts.noarch : Fonts for the Ge\xca\xbcez (Ethiopic) script'
self: <dnf.i18n.UnicodeStream object at 0x1ede950>

Comment 1 Peter Oliver 2014-02-18 19:32:33 UTC
Created attachment 864740 [details]
File: backtrace

Comment 2 Peter Oliver 2014-02-18 19:32:35 UTC
Created attachment 864741 [details]
File: environ

Comment 3 Parag Nemade 2014-02-19 04:15:11 UTC
looks similar of bug 1063022

Comment 4 Radek Holy 2014-02-19 07:38:52 UTC
Hello Peter, thank you for the report. Try dnf-0.4.14-1 or higher.

*** This bug has been marked as a duplicate of bug 1063022 ***


Note You need to log in before you can comment on or make changes to this bug.