Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066584 - Cannot run processes while jbpm-playground repository is not present
Summary: Cannot run processes while jbpm-playground repository is not present
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Business Central
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ER2
: 6.0.1
Assignee: Maciej Swiderski
QA Contact: Tomas Livora
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 16:42 UTC by Tomas Livora
Modified: 2018-12-04 17:33 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:01:47 UTC
Type: Bug


Attachments (Terms of Use)
Unable to complete task in task list (deleted)
2014-02-19 08:37 UTC, Jan Hrcek
no flags Details

Description Tomas Livora 2014-02-18 16:42:53 UTC
Description of problem:
It is not possible to run business processes unless the jbpm-playground repository is cloned.

Version-Release number of selected component (if applicable):
6.0.1 ER1

Steps to Reproduce:
1. Run a clean copy of BPMS.
2. Create a simple process in the example project.
3. Build and deploy the project.
4. Try to run your process.

Actual results:
There is no button to run the process.

Expected results:
There should be the start button as well as other form fields.

Additional info:
It seems that the application is expecting jbpm-playground as the default repository and if it is not there it somehow blocks starting of new process instances. The following warning which is probably related with this issue can be seen in the console output:

WARN  [org.jbpm.runtime.manager.impl.cdi.InjectableRegisterableItemsFactory] (MSC service thread 1-2) Exception while evalutating work item handler prodcuers WELD-000049 Unable to invoke [method] @PostConstruct public org.jbpm.console.ng.bd.service.VFSFileServiceImpl.init() on org.jbpm.console.ng.bd.service.VFSFileServiceImpl@3432b4a2

Comment 1 Sona Mala 2014-02-18 17:02:32 UTC
I found out that it needs any repository with name "jbpm-playground" in .niogit.

I have created a new repository with such name and form was shown correctly. The process runs as usual.

Comment 2 Jan Hrcek 2014-02-19 08:37:22 UTC
The problem manifests itself also in another place in the task list (although the root cause will probably be the same. See screenshot

Comment 3 Jan Hrcek 2014-02-19 08:37:56 UTC
Created attachment 865002 [details]
Unable to complete task in task list

Comment 4 Maciej Swiderski 2014-02-19 12:05:54 UTC
fixed by ensuring that VFS based implementation won't get in the way unless they are explicitly invoked

jbpm-console-ng
master:
https://github.com/droolsjbpm/jbpm-console-ng/commit/b6c261f07b03d3cae003b22c52e45b6338286299

6.0.x:
https://github.com/droolsjbpm/jbpm-console-ng/commit/2e8170f42e8c476701ee11c04cff935671465e06

Comment 5 Shay Matasaro 2014-02-20 19:15:13 UTC
we  have a BPMN customer who is unable to run his project which has a custom work handler (the case is attached)

The only visible error is :
Unable to invoke [method] @PostConstruct public org.jbpm.console.ng.bd.service.VFSFileServiceImpl.init() on org.jbpm.console.ng.bd.service.VFSFileServiceImpl@5e65de87

We have tried numerous workarounds , including:
1) creating a Jbpm-playground under .niogit

following https://bugzilla.redhat.com/show_bug.cgi?id=987823
2) use "-Dorg.kie.demo=false"

But , none of the options worked properly 

logs and reproducers are attached to the customer case

Is there a viable workaround for this issue ?

Comment 6 Maciej Swiderski 2014-02-20 19:19:18 UTC
it should be enough to create jbpm-playground repository from Adminsitration panel in business central. Just make sure that the repository is named exactly jbpm-playground.

Comment 7 Tomas Livora 2014-03-05 09:33:25 UTC
Verified on BPMS 6.0.1 ER2


Note You need to log in before you can comment on or make changes to this bug.