Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066581 - qemu-system-arm does not work
Summary: qemu-system-arm does not work
Keywords:
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: qemu
Version: rawhide
Hardware: arm
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Fedora Virtualization Maintainers
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks: ARMTracker
TreeView+ depends on / blocked
 
Reported: 2014-02-18 16:38 UTC by Richard W.M. Jones
Modified: 2015-08-14 09:14 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-08-14 09:14:32 UTC


Attachments (Terms of Use)
build.log (deleted)
2014-06-11 06:59 UTC, Richard W.M. Jones
no flags Details
root.log (deleted)
2014-06-11 06:59 UTC, Richard W.M. Jones
no flags Details

Description Richard W.M. Jones 2014-02-18 16:38:12 UTC
Description of problem:

Currently qemu-system-arm in Rawhide is unable to start VMs.

See for example this build log:

http://kojipkgs.fedoraproject.org//work/tasks/3336/6543336/build.log

At the end you'll see where we attempt to boot the current
kernel on qemu-system-arm.  It doesn't print any messages at
all, just exits abruptly after ~ 3 seconds.

Version-Release number of selected component (if applicable):

qemu 1.7.0-4.fc21

How reproducible:

100%

Steps to Reproduce:
1. Run libguestfs-test-tool

Additional info:

I notice that qemu-sanity-check isn't enabled in the arm build, so
I'm going to enable it there (informational only still) so we
can see if that very simple test also fails.

Comment 1 Richard W.M. Jones 2014-02-18 18:49:46 UTC
I have added qemu-sanity-check to the qemu build.

qemu works on i386 and x86-64 (as expected).  Unfortunately the
results are not useful on arm at the moment as I don't think
qemu-sanity-check is able to locate the right device tree or
kernel (bug 1066637).

Comment 2 Paolo Bonzini 2014-06-06 10:02:52 UTC
Please attach the build.log since it has expired.

Comment 3 Richard W.M. Jones 2014-06-10 20:17:48 UTC
This is quite an old bug and qemu has moved forwards a great
deal.  I've therefore kicked off another scratch build in Rawhide:

http://koji.fedoraproject.org/koji/taskinfo?taskID=7033643

If this build fails in the same way then I will attach the root/build logs.

Comment 4 Richard W.M. Jones 2014-06-11 06:59:10 UTC
Created attachment 907498 [details]
build.log

build.log from failed build.  Note you should scroll right to the
bottom of the output.

I cannot see any error from qemu-system-arm, it just doesn't start up.

Comment 5 Richard W.M. Jones 2014-06-11 06:59:38 UTC
Created attachment 907499 [details]
root.log

Comment 6 Peter Robinson 2014-08-13 13:54:56 UTC
So trying to do this on an ARMv7 device that is running in hyp mode I get issues as well.

qemu-common-2.1.0-0.5.rc3.fc21.armv7hl
qemu-system-arm-2.1.0-0.5.rc3.fc21.armv7hl
qemu-img-2.1.0-0.5.rc3.fc21.armv7hl
qemu-kvm-2.1.0-0.5.rc3.fc21.armv7hl
kernel-lpae-3.16.0-1.fc21.armv7hl
kernel-lpae-modules-3.16.0-1.fc21.armv7hl
kernel-lpae-core-3.16.0-1.fc21.armv7hl
libvirt-client-1.2.6-2.fc21.armv7hl
libvirt-daemon-1.2.6-2.fc21.armv7hl
libvirt-daemon-driver-interface-1.2.6-2.fc21.armv7hl
libvirt-daemon-driver-network-1.2.6-2.fc21.armv7hl
libvirt-daemon-driver-nodedev-1.2.6-2.fc21.armv7hl
libvirt-daemon-driver-nwfilter-1.2.6-2.fc21.armv7hl
libvirt-daemon-driver-qemu-1.2.6-2.fc21.armv7hl
libvirt-daemon-driver-secret-1.2.6-2.fc21.armv7hl
libvirt-daemon-driver-storage-1.2.6-2.fc21.armv7hl
libvirt-daemon-kvm-1.2.6-2.fc21.armv7hl
libvirt-python-1.2.6-1.fc21.armv7hl


# virt-install --name=f21-arm --file=/var/lib/libvirt/images/f21-arm.img --file-size=8 --nonsparse --graphics none --extra-args console=ttyS0 --vcpus=1 --ram=512 --location=http://mirror.bytemark.co.uk/fedora/linux/development/21/armhfp/os/ --network bridge=br0 --os-type=linux --os-variant fedora20

Starting install...
Retrieving file .treeinfo...                                                                                                   |  53 kB  00:00:00 !!! 
Retrieving file vmlinuz...                                                                                                     |  10 MB  00:00:04 !!! 
Retrieving file initrd.img...                                                                                                  |  63 MB  00:00:26 !!! 
ERROR    internal error: early end of file from monitor: possible problem:
KVM is not supported for this guest CPU type
kvm_init_vcpu failed: Invalid argument

Domain installation does not appear to have been successful.
If it was, you can restart your domain by running:
  virsh --connect qemu:///system start f21-arm
otherwise, please restart your installation.
[root@cubietruck ~]#

Comment 7 Jaroslav Reznik 2015-03-03 15:29:52 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22

Comment 8 Richard W.M. Jones 2015-08-13 20:35:20 UTC
I re-enabled the tests on arm and aarch64, so let's see what happens.

Comment 9 Richard W.M. Jones 2015-08-14 09:14:32 UTC
It took (literally) 12 hours to run the tests on ARM, but it
did work.  I'm probably going to disable the tests again however ..


Note You need to log in before you can comment on or make changes to this bug.