Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066552 - Host-controller and process-controller log files are not created for some special characters on path
Summary: Host-controller and process-controller log files are not created for some spe...
Keywords:
Status: CLOSED WONTFIX
Alias: None
Product: JBoss Enterprise Application Platform 6
Classification: JBoss
Component: Logging
Version: 6.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: EAP 6.4.0
Assignee: James Perkins
QA Contact: Nikoleta Ziakova
Russell Dickenson
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 15:50 UTC by Petr Kremensky
Modified: 2015-11-24 08:15 UTC (History)
3 users (show)

Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-10-29 15:18:56 UTC
Type: Bug


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
JBoss Issue Tracker JBEAP-251 Major Closed Host-controller and process-controller log files are not created for some special characters on path 2015-11-24 08:15:58 UTC

Description Petr Kremensky 2014-02-18 15:50:40 UTC
Description of problem:
 Logging of host-controller and process-controller is not working once the $EAP_HOME is one of the following directories:
  - jboss%eap
  - jboss#eap [*]
  - jboss?eap [*]

[*] - Unable to read the logging configuration message on server start and some console logs from Host Controller, but no logs to file

Version-Release number of selected component (if applicable):
 EAP 6.3.0.DR0

How reproducible:
 Always

Steps to Reproduce:
 1. Re-name the $JBOSS_HOME directory to jboss%eap
 2. start the domain

Actual results:
 No logs from host-controller and process-controller (neither to console nor to file)

Expected results:
 Host-controller and process-controller is logging as usual.

Additional info:
 Not a regression against EAP 6.2

Comment 1 Nikoleta Ziakova 2014-08-13 11:16:42 UTC
Proposing for EAP 6.4.0

Comment 2 James Perkins 2014-09-16 18:03:34 UTC
The issue is the configuration file locator opens the stream via a URL. Since #, % and ? mean something to a URL and aren't encoded this results in the error. But once the logging subsystem kicks it logging works as it should.

Since the path value comes from the scripts there's not really a good way to encode the path so it would work as a URL.

I'll leave this open for now while I give it a little more thought.

Comment 3 James Perkins 2014-10-29 00:07:09 UTC
These paths would have to be encoded in the startup scripts. We've had no shortage of issues with the scripts in this release and I'd hesitate to add more untested logic to them, if it's even possible. Petr what do you think?

Comment 4 Petr Kremensky 2014-10-29 07:42:56 UTC
I agree with you. This is a low priority issue and I would also like to avoid adding any new logic to scripts now.

Comment 6 JBoss JIRA Server 2015-07-10 07:31:40 UTC
Bartosz Baranowski <bbaranow@redhat.com> updated the status of jira JBEAP-251 to Closed

Comment 7 JBoss JIRA Server 2015-07-10 07:31:46 UTC
Bartosz Baranowski <bbaranow@redhat.com> updated the status of jira JBEAP-251 to Reopened

Comment 8 JBoss JIRA Server 2015-07-10 07:32:04 UTC
Bartosz Baranowski <bbaranow@redhat.com> updated the status of jira JBEAP-251 to Resolved

Comment 9 JBoss JIRA Server 2015-11-24 08:15:58 UTC
Marek Kopecký <mkopecky@redhat.com> updated the status of jira JBEAP-251 to Closed


Note You need to log in before you can comment on or make changes to this bug.