Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066526 - devenv_4389 developers/jenkins is redirecting to 400 error page
Summary: devenv_4389 developers/jenkins is redirecting to 400 error page
Keywords:
Status: CLOSED DUPLICATE of bug 1065881
Alias: None
Product: OpenShift Online
Classification: Red Hat
Component: Website
Version: 2.x
Hardware: Unspecified
OS: Unspecified
unspecified
low
Target Milestone: ---
: ---
Assignee: Clayton Coleman
QA Contact: libra bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 15:07 UTC by David Morrison
Modified: 2015-05-15 01:33 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-19 02:10:34 UTC


Attachments (Terms of Use)

Description David Morrison 2014-02-18 15:07:43 UTC
Description of problem:

https://<server>/developers/jenkins is redirecting to http://<server>/jenkins/? and creating a 400 error.

Version-Release number of selected component (if applicable): 

devenv_4389

How reproducible:

Very reproducible.

Steps to Reproduce:
1. Create a fresh devenv
2. Navigate to https://<server>/developers/jenkins

Actual results:

400 error page

Expected results:

no 400 error page

Additional info:

Drupal redirects /developers/jenkins to /jenkins, because it has content there.
On the devenv, /jenkins is reverse-proxied to the jenkins server on the devenv.
Check jenkins server config on the devenv.

On INT, /developers/jenkins redirects to:
https://www.int.openshift.com/jenkins which works correctly

Devenvs have their own jenkins instance, e.g.
https://ec2-54-234-224-39.compute-1.amazonaws.com:8118/jenkins so I
think that config is conflicting with the drupal-provided content:
ProxyPass           /jenkins    http://127.0.0.1:8081/jenkins
ProxyPassReverse    /jenkins    http://127.0.0.1:8081/jenkins

Comment 1 Yujie Zhang 2014-02-19 02:10:34 UTC

*** This bug has been marked as a duplicate of bug 1065881 ***


Note You need to log in before you can comment on or make changes to this bug.