Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066524 - Using <timer name=hpet present=no> causes qemu on ppc64 to break, "Option no-hpet not supported for this target"
Summary: Using <timer name=hpet present=no> causes qemu on ppc64 to break, "Option no-...
Keywords:
Status: CLOSED DUPLICATE of bug 1066145
Alias: None
Product: Virtualization Tools
Classification: Community
Component: libvirt
Version: unspecified
Hardware: ppc64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Libvirt Maintainers
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 15:04 UTC by Richard W.M. Jones
Modified: 2014-02-18 15:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of: 1066145
Environment:
Last Closed: 2014-02-18 15:07:45 UTC


Attachments (Terms of Use)

Description Richard W.M. Jones 2014-02-18 15:04:38 UTC
+++ This bug was initially created as a clone of Bug #1066145 +++

Description of problem:

[Same thing happens on ppc64]

qemu-system-ppc64 has an annoying bug since forever where the -help
output mentioned -no-hpet, but if you actually use this flag, qemu
helpfully prints:

  Option no-hpet not supported for this target

If you use the libvirt XML on an POWER 7 guest:

  <timer name=hpet present=no>

meaning "don't include an HPET device", then libvirt adds -no-hpet
to the command line, and qemu-system-arm won't start up.

I have worked around this in libguestfs by not including this
XML fragment on ppc64, but this still looks like it is a bug in
libvirt (and qemu of course).

Version-Release number of selected component (if applicable):

libvirt from git today

How reproducible:

100%

Steps to Reproduce:
1. Compile libvirt from git on POWER.
2. Run: ~/d/libvirt/run libguestfs-test-tool

Actual results:

LC_ALL=C PATH=/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/home/rjones/.local/bin:/home/rjones/bin HOME=/home/rjones USER=rjones LOGNAME=rjones QEMU_AUDIO_DRV=none TMPDIR=/var/tmp /usr/bin/qemu-system-ppc64 -name guestfs-6iushxm648pz1e3q -S -machine pseries,accel=tcg,usb=off -m 768 -realtime mlock=off -smp 1,sockets=1,cores=1,threads=1 -uuid 92e4cbb4-bd61-4efa-b47c-1f22fe2f4145 -nographic -no-user-config -nodefaults -chardev socket,id=charmonitor,path=/home/rjones/.config/libvirt/qemu/lib/guestfs-6iushxm648pz1e3q.monitor,server,nowait -mon chardev=charmonitor,id=monitor,mode=control -rtc base=utc,driftfix=slew -no-hpet -no-reboot -kernel /var/tmp/.guestfs-1005/kernel.6807 -initrd /var/tmp/.guestfs-1005/initrd.6807 -append panic=1 console=ttyS0 udevtimeout=600 no_timer_check acpi=off printk.time=1 cgroup_disable=memory root=/dev/sdb selinux=0 guestfs_verbose=1 TERM=xterm-256color -device virtio-scsi-pci,id=scsi0,bus=pci,addr=0x1 -device virtio-serial-pci,id=virtio-serial0,bus=pci,addr=0x3 -usb -drive file=/tmp/libguestfszJaaPR/scratch.1,if=none,id=drive-scsi0-0-0-0,format=raw,cache=unsafe -device scsi-hd,bus=scsi0.0,channel=0,scsi-id=0,lun=0,drive=drive-scsi0-0-0-0,id=scsi0-0-0-0,bootindex=1 -drive file=/tmp/libguestfszJaaPR/overlay2,if=none,id=drive-scsi0-0-1-0,format=qcow2,cache=unsafe -device scsi-hd,bus=scsi0.0,channel=0,scsi-id=1,lun=0,drive=drive-scsi0-0-1-0,id=scsi0-0-1-0 -chardev socket,id=charserial0,path=/tmp/libguestfszJaaPR/console.sock -device spapr-vty,chardev=charserial0,reg=0x30000000 -chardev socket,id=charchannel0,path=/tmp/libguestfszJaaPR/guestfsd.sock -device virtserialport,bus=virtio-serial0.0,nr=1,chardev=charchannel0,id=channel0,name=org.libguestfs.channel.0 -device virtio-balloon-pci,id=balloon0,bus=pci,addr=0x4
Domain id=2 is tainted: custom-argv
Option no-hpet not supported for this target

Expected results:

Should probably ignore this.

Additional info:

Comment 1 Daniel Berrange 2014-02-18 15:07:45 UTC
Don't really need to clone the bug per architecture.

*** This bug has been marked as a duplicate of bug 1066145 ***


Note You need to log in before you can comment on or make changes to this bug.