Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066499 - [abrt] WARNING: CPU: 0 PID: 1727 at fs/cifs/transport.c:313 smb_send_rqst+0x215/0x270 [cifs]()
Summary: [abrt] WARNING: CPU: 0 PID: 1727 at fs/cifs/transport.c:313 smb_send_rqst+0x2...
Keywords:
Status: CLOSED DUPLICATE of bug 1068862
Alias: None
Product: Fedora
Classification: Fedora
Component: kernel
Version: 20
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Kernel Maintainer List
QA Contact: Fedora Extras Quality Assurance
URL: https://retrace.fedoraproject.org/faf...
Whiteboard: abrt_hash:a80e83a5b491a2a45e9312e27d5...
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 14:35 UTC by Marcus Moeller
Modified: 2014-02-28 22:21 UTC (History)
10 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-28 16:58:27 UTC


Attachments (Terms of Use)
File: dmesg (deleted)
2014-02-18 14:35 UTC, Marcus Moeller
no flags Details

Description Marcus Moeller 2014-02-18 14:35:12 UTC
Description of problem:
cifs mounts do no longer work with 3.13.3-201.fc20.x86_64. Following additional errors are logged:

[   36.781394] CIFS VFS: Error connecting to socket. Aborting operation.
[   36.781533] CIFS VFS: cifs_mount failed w/return code = -5
[   36.783162] systemd-readahead[420]: open(/nas/install) failed: No such device
[   36.791912] CIFS VFS: Error connecting to socket. Aborting operation.
[   36.792016] CIFS VFS: cifs_mount failed w/return code = -111
[   36.793721] systemd-readahead[420]: open(/nas/setup3) failed: No such device

Additional info:
reporter:       libreport-2.1.12
WARNING: CPU: 0 PID: 1727 at fs/cifs/transport.c:313 smb_send_rqst+0x215/0x270 [cifs]()
Send length mismatch(send_length=72 smb_buf_length=2164260932)
Modules linked in: nls_utf8 cifs nfsv3 nfs_acl nfsv4 dns_resolver nfs lockd sunrpc fscache uvcvideo videobuf2_vmalloc videobuf2_memops btusb videobuf2_core videodev media bnep bluetooth cdc_mbim cdc_ncm cdc_acm asix cdc_wdm usbnet mii binfmt_misc ip6t_REJECT nf_conntrack_ipv6 nf_conntrack_ipv4 nf_defrag_ipv6 nf_defrag_ipv4 ip6table_filter xt_conntrack ip6_tables nf_conntrack iTCO_wdt iTCO_vendor_support snd_hda_codec_hdmi snd_hda_codec_realtek x86_pkg_temp_thermal arc4 coretemp snd_hda_intel kvm_intel snd_hda_codec kvm iwldvm snd_hwdep snd_seq mac80211 crct10dif_pclmul snd_seq_device crc32_pclmul crc32c_intel snd_pcm iwlwifi ghash_clmulni_intel cfg80211 microcode joydev serio_raw snd_page_alloc sdhci_pci i2c_i801 sdhci mmc_core snd_timer mei_me mei lpc_ich shpchp mfd_core wmi thinkpad_acpi snd tpm_tis soundcore tpm rfkill i915 i2c_algo_bit drm_kms_helper drm i2c_core video
CPU: 0 PID: 1727 Comm: mount.cifs Not tainted 3.13.3-201.fc20.x86_64 #1
Hardware name: LENOVO 34602SG/34602SG, BIOS G6ET93WW (2.53 ) 02/04/2013
 0000000000000009 ffff8801f0357bb8 ffffffff81686b48 ffff8801f0357c00
 ffff8801f0357bf0 ffffffff8106d47d ffff8801f0357d08 ffff88021211d800
 ffff8801f0357cd0 0000000000000001 0000000000000000 ffff8801f0357c50
Call Trace:
 [<ffffffff81686b48>] dump_stack+0x45/0x56
 [<ffffffff8106d47d>] warn_slowpath_common+0x7d/0xa0
 [<ffffffff8106d4ec>] warn_slowpath_fmt+0x4c/0x50
 [<ffffffffa0780d55>] smb_send_rqst+0x215/0x270 [cifs]
 [<ffffffff815f38b8>] ? __inet_stream_connect+0x208/0x320
 [<ffffffffa0780ded>] smb_sendv+0x3d/0x40 [cifs]
 [<ffffffffa0780e18>] smb_send+0x28/0x30 [cifs]
 [<ffffffffa076b01d>] generic_ip_connect+0x30d/0x3e0 [cifs]
 [<ffffffff8119e765>] ? __kmalloc+0x55/0x240
 [<ffffffffa076f4fc>] cifs_mount+0x84c/0xae0 [cifs]
 [<ffffffffa075dfa0>] cifs_do_mount+0xa0/0x4d0 [cifs]
 [<ffffffff811bc8d9>] mount_fs+0x39/0x1b0
 [<ffffffff811d6d83>] vfs_kern_mount+0x63/0xf0
 [<ffffffff811d939e>] do_mount+0x23e/0xac0
 [<ffffffff8114ef74>] ? __get_free_pages+0x14/0x50
 [<ffffffff811d8fe6>] ? copy_mount_options+0x36/0x170
 [<ffffffff811d9f43>] SyS_mount+0x83/0xc0
 [<ffffffff81695b29>] system_call_fastpath+0x16/0x1b

Comment 1 Marcus Moeller 2014-02-18 14:35:18 UTC
Created attachment 864587 [details]
File: dmesg

Comment 2 Marcus Moeller 2014-02-21 09:15:10 UTC
Restarting the Samba SERVER did solve the problem.

Comment 3 Anton Potekhin 2014-02-21 09:42:41 UTC
After restarting samba server i still have this bug.

Comment 4 Marcus Moeller 2014-02-27 11:59:40 UTC
Happened again here, too. Even after Server restart.

Comment 5 Mikhail Sokol 2014-02-28 08:06:55 UTC
I join the same:

Feb 28 09:56:46 proton kernel: [ 1281.094446] ------------[ cut here ]------------
Feb 28 09:56:46 proton kernel: [ 1281.094478] WARNING: CPU: 0 PID: 2541 at fs/cifs/transport.c:313 smb_send_rqst+0x201/0x260 [cifs]()
Feb 28 09:56:46 proton kernel: [ 1281.094483] Send length mismatch(send_length=72 smb_buf_length=2164260932)
Feb 28 09:56:46 proton kernel: [ 1281.094486] Modules linked in: nls_utf8 cifs dns_resolver fscache nvidia(POF) fuse snd_hda_codec_hdmi coretemp snd_hda_codec_via kvm_intel snd_hda_intel snd_hda_codec snd_hwdep snd_seq snd_seq_device snd_pcm drm kvm snd_page_alloc snd_timer snd crc32_pclmul r8169 crc32c_intel iTCO_wdt iTCO_vendor_support i2c_i801 i2c_core gpio_ich lpc_ich soundcore microcode mii ppdev serio_raw parport_pc parport asus_atk0110 acpi_cpufreq binfmt_misc vboxnetadp(OF) vboxnetflt(OF) vboxdrv(OF) ata_generic pata_acpi firewire_ohci firewire_core pata_via crc_itu_t         
Feb 28 09:56:46 proton kernel: [ 1281.094552] CPU: 0 PID: 2541 Comm: mount.cifs Tainted: PF       W  O 3.13.4-200.fc20.i686 #1                                                                       
Feb 28 09:56:46 proton kernel: [ 1281.094554] Hardware name: System manufacturer System Product Name/P7P55-M, BIOS 1101    09/04/2012                                                                
Feb 28 09:56:46 proton kernel: [ 1281.094555]  00000000 00000000 cd847d54 c09a6208 cd847d94 cd847d84 c0448dde f844ec58                                                                               
Feb 28 09:56:46 proton kernel: [ 1281.094560]  cd847db0 000009ed f84413c2 00000139 f8420c31 f8420c31 cd847e10 81000044                                                                               
Feb 28 09:56:46 proton kernel: [ 1281.094564]  cd847dec cd847d9c c0448e33 00000009 cd847d94 f844ec58 cd847db0 cd847de4                                                                               
Feb 28 09:56:46 proton kernel: [ 1281.094569] Call Trace:                                                                                                                                            
Feb 28 09:56:46 proton kernel: [ 1281.094577]  [<c09a6208>] dump_stack+0x41/0x52                                                                                                                     
Feb 28 09:56:46 proton kernel: [ 1281.094582]  [<c0448dde>] warn_slowpath_common+0x7e/0xa0                                                                                                           
Feb 28 09:56:46 proton kernel: [ 1281.094591]  [<f8420c31>] ? smb_send_rqst+0x201/0x260 [cifs]                                                                                                       
Feb 28 09:56:46 proton kernel: [ 1281.094600]  [<f8420c31>] ? smb_send_rqst+0x201/0x260 [cifs]                                                                                                       
Feb 28 09:56:46 proton kernel: [ 1281.094603]  [<c0448e33>] warn_slowpath_fmt+0x33/0x40                                                                                                              
Feb 28 09:56:46 proton kernel: [ 1281.094611]  [<f8420c31>] smb_send_rqst+0x201/0x260 [cifs]                                                                                                         
Feb 28 09:56:46 proton kernel: [ 1281.094620]  [<f8420cbc>] smb_sendv+0x2c/0x40 [cifs]                                                                                                               
Feb 28 09:56:46 proton kernel: [ 1281.094629]  [<f8420cf1>] smb_send+0x21/0x30 [cifs]                                                                                                                
Feb 28 09:56:46 proton kernel: [ 1281.094636]  [<f840ce54>] generic_ip_connect+0x2e4/0x3d0 [cifs]                                                                                                    
Feb 28 09:56:46 proton kernel: [ 1281.094643]  [<f84106ea>] ? cifs_mount+0x10a/0x960 [cifs]                                                                                                          
Feb 28 09:56:46 proton kernel: [ 1281.094650]  [<f8410c5f>] cifs_mount+0x67f/0x960 [cifs]                                                                                                            
Feb 28 09:56:46 proton kernel: [ 1281.094657]  [<f8400ed6>] cifs_do_mount+0x86/0x480 [cifs]                                                                                                          
Feb 28 09:56:46 proton kernel: [ 1281.094662]  [<c051168b>] ? __get_free_pages+0x2b/0x40                                                                                                             
Feb 28 09:56:46 proton kernel: [ 1281.094665]  [<c055b771>] mount_fs+0x31/0x170                                                                                                                      
Feb 28 09:56:46 proton kernel: [ 1281.094669]  [<c05726c5>] vfs_kern_mount+0x45/0xc0                                                                                                                 
Feb 28 09:56:46 proton kernel: [ 1281.094672]  [<c05746a0>] do_mount+0x1e0/0x8d0                                                                                                                     
Feb 28 09:56:46 proton kernel: [ 1281.094674]  [<c05743af>] ? copy_mount_options+0x2f/0x100                                                                                                          
Feb 28 09:56:46 proton kernel: [ 1281.094677]  [<c057502c>] SyS_mount+0x7c/0xb0                                                                                                                      
Feb 28 09:56:46 proton kernel: [ 1281.094681]  [<c09b354d>] sysenter_do_call+0x12/0x28
Feb 28 09:56:46 proton kernel: [ 1281.094683] ---[ end trace d3c670fe74781992 ]---
Feb 28 09:56:46 proton kernel: [ 1281.095913] CIFS VFS: Error connecting to socket. Aborting operation.
Feb 28 09:56:46 proton kernel: [ 1281.096050] CIFS VFS: cifs_mount failed w/return code = -5

Comment 6 mcisho 2014-02-28 12:13:31 UTC
Me to, since upgrade to Kernel 3.13.3-201.fc20.x86_64. The server (Samba) has been unchanged for years, it's running on a VIA system not supported by Fedora since F11. Reverting back to Kernel 3.12.10-300.fc20.x86_64 which works fine.

[   30.928734] ------------[ cut here ]------------
[   30.928746] WARNING: CPU: 0 PID: 767 at fs/cifs/transport.c:313 smb_send_rqst+0x215/0x270 [cifs]()
[   30.928748] Send length mismatch(send_length=72 smb_buf_length=2164260932)
[   30.928749] Modules linked in: nls_utf8 cifs dns_resolver fscache bnep bluetooth cfg80211 hwmon_vid x86_pkg_temp_thermal coretemp snd_usb_audio kvm_intel snd_usbmidi_lib snd_hda_codec_hdmi snd_hda_codec_realtek snd_hda_intel snd_hda_codec snd_rawmidi kvm snd_hwdep crct10dif_pclmul crc32_pclmul snd_seq snd_seq_device iTCO_wdt r8169 snd_pcm iTCO_vendor_support crc32c_intel eeepc_wmi asus_wmi snd_page_alloc snd_timer snd sparse_keymap rfkill uvcvideo videobuf2_vmalloc videobuf2_memops ghash_clmulni_intel videobuf2_core videodev mii joydev lpc_ich media soundcore mei_me mei microcode serio_raw shpchp mfd_core i2c_i801 binfmt_misc nouveau video mxm_wmi i2c_algo_bit usb_storage drm_kms_helper ttm drm i2c_core wmi
[   30.928780] CPU: 0 PID: 767 Comm: mount.cifs Not tainted 3.13.4-200.fc20.x86_64 #1
[   30.928781] Hardware name: System manufacturer System Product Name/P8H61 EVO, BIOS 0306 04/07/2011
[   30.928783]  0000000000000009 ffff880229ddfbb8 ffffffff81686b68 ffff880229ddfc00
[   30.928785]  ffff880229ddfbf0 ffffffff8106d47d ffff880229ddfd08 ffff880229e13400
[   30.928787]  ffff880229ddfcd0 0000000000000001 0000000000000000 ffff880229ddfc50
[   30.928789] Call Trace:
[   30.928795]  [<ffffffff81686b68>] dump_stack+0x45/0x56
[   30.928799]  [<ffffffff8106d47d>] warn_slowpath_common+0x7d/0xa0
[   30.928802]  [<ffffffff8106d4ec>] warn_slowpath_fmt+0x4c/0x50
[   30.928808]  [<ffffffffa05ccd55>] smb_send_rqst+0x215/0x270 [cifs]
[   30.928816]  [<ffffffff815f38d8>] ? __inet_stream_connect+0x208/0x320
[   30.928821]  [<ffffffffa05ccded>] smb_sendv+0x3d/0x40 [cifs]
[   30.928826]  [<ffffffffa05cce18>] smb_send+0x28/0x30 [cifs]
[   30.928830]  [<ffffffffa05b701d>] generic_ip_connect+0x30d/0x3e0 [cifs]
[   30.928834]  [<ffffffff8119e785>] ? __kmalloc+0x55/0x240
[   30.928839]  [<ffffffffa05bb4fc>] cifs_mount+0x84c/0xae0 [cifs]
[   30.928843]  [<ffffffffa05a9fa0>] cifs_do_mount+0xa0/0x4d0 [cifs]
[   30.928846]  [<ffffffff811bc8f9>] mount_fs+0x39/0x1b0
[   30.928849]  [<ffffffff811d6da3>] vfs_kern_mount+0x63/0xf0
[   30.928851]  [<ffffffff811d93be>] do_mount+0x23e/0xac0
[   30.928854]  [<ffffffff8114ef74>] ? __get_free_pages+0x14/0x50
[   30.928856]  [<ffffffff811d9006>] ? copy_mount_options+0x36/0x170
[   30.928858]  [<ffffffff811d9f63>] SyS_mount+0x83/0xc0
[   30.928862]  [<ffffffff81695b69>] system_call_fastpath+0x16/0x1b
[   30.928863] ---[ end trace 60de8e732ef0287a ]---

Comment 7 Anton Potekhin 2014-02-28 16:57:11 UTC
more infor about this bug https://bugzilla.redhat.com/show_bug.cgi?id=1068862

Comment 8 Josh Boyer 2014-02-28 16:58:27 UTC

*** This bug has been marked as a duplicate of bug 1068862 ***


Note You need to log in before you can comment on or make changes to this bug.