Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066483 - When problems panel is opened, form modeler is not rendered fully
Summary: When problems panel is opened, form modeler is not rendered fully
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BPMS Platform 6
Classification: Retired
Component: Form Modeler
Version: 6.0.1
Hardware: Unspecified
OS: Unspecified
high
high
Target Milestone: ER2
: 6.0.1
Assignee: Pere Fernàndez
QA Contact: Jan Hrcek
URL:
Whiteboard:
Depends On:
Blocks: 1051103
TreeView+ depends on / blocked
 
Reported: 2014-02-18 14:03 UTC by Jan Hrcek
Modified: 2014-08-06 20:03 UTC (History)
8 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 20:03:13 UTC
Type: Bug


Attachments (Terms of Use)
Steps to reproduce - video (deleted)
2014-02-18 14:03 UTC, Jan Hrcek
no flags Details
Collapsed form modeler (deleted)
2014-02-20 23:49 UTC, Pere Fernàndez
no flags Details

Description Jan Hrcek 2014-02-18 14:03:28 UTC
Created attachment 864574 [details]
Steps to reproduce - video

Description of problem:
When problems panel is opened and new form modeler panel is then opened, it is not rendered fully and it looks that the graphic ends based on how high the Problems panel was resized. Observe the Form Modeler's behavior in the video attached.

Version-Release number of selected component (if applicable):
BPMS 6.0.1 ER1

How reproducible:
Always

Steps to Reproduce:
1. Open Project authoring perspective.
2. Do something to make Problems panel appear (e.g. create new work item, make some mistake in it and save it - as I do in the video)
3. Expand the problems panel
4. Create a new form in form modeler.

Actual results:
Form modeler is not rendered fully - only the part that was not covered by problems panel is visible. Even closing the problems panel does not help.

Expected results:
Form modeler should be rendered fully independent on whether the problems panel is opened or closed.

Comment 1 Jan 2014-02-19 17:34:49 UTC
Could it be related to bz 1051103?

Comment 2 Jan Hrcek 2014-02-20 05:40:29 UTC
Jan, it definitely seems to be the same problem as in Bug 1051103. Try it yourself: you don't even need to switch perspective, just expand the problems panel upwards and then close & reopen the form modeler panel. You will see it is rendered only down to the problems panel, but not below.

Also, it seems to be happening in all browsers. I just checked and the problem is the same in latest Firefox, in latest Google Chrome and also in Internet Explorer 11.

Comment 3 Jan Hrcek 2014-02-20 05:48:28 UTC
One additional thing comes to my mind that might be helpful. This bugzilla seems to be recent problem (didn't see it before) - might it not be caused by fix to Bug 1037965?

Comment 4 Roger Martínez 2014-02-20 17:45:35 UTC
Fixed.

The problem was due the height of the panel was set to a static value in pixels instead of using %.

Commit in 6.0.x -> https://github.com/droolsjbpm/jbpm-form-modeler/commit/8cb655aaf997bd871e2d163f77e59ae37bc454ba

Commit in master -> https://github.com/droolsjbpm/jbpm-form-modeler/commit/fcc365ac447bcfe55045ec0c9befa6d43df031b9

Comment 5 Pere Fernàndez 2014-02-20 23:49:07 UTC
Form modeler appears collapsed opening a new form.

Comment 6 Pere Fernàndez 2014-02-20 23:49:45 UTC
Created attachment 865753 [details]
Collapsed form modeler

Comment 7 Roger Martínez 2014-02-21 12:25:39 UTC
Pere, you are right, it's not working fine in FF :(

Let me take a look at it.. thanks

Comment 8 Roger Martínez 2014-02-21 16:04:49 UTC
Using height as 100% was not supported by FF.

Anyway, adding a UF Page implies that our component is wrapped in a ScrollPanel, which do not support height in % values.

So the solution is to implement the RequiresResize interface to allow resizing the component with the exact height pixels.

Commit in master -> https://github.com/droolsjbpm/jbpm-form-modeler/commit/3c53f866f82f05cb26d2e0b145dff58c4c0b81d9

Commit in 6.0.x -> https://github.com/droolsjbpm/jbpm-form-modeler/commit/fb40cf6c8684947cd379f583b5ac0703a1d7ce50

Comment 9 Jan Hrcek 2014-03-03 17:05:20 UTC
Checked with the initial build of BPMS 6.0.1 ER2 and the issue is still present, still looks the same. I was using the latest firefox.

Comment 11 Edson Tirelli 2014-03-04 17:33:21 UTC
This was cherry-picked into the 6.0.1.ER2 tag:

https://github.com/jboss-integration/jbpm-form-modeler/commit/170a520

Comment 12 Jan Hrcek 2014-03-06 09:57:55 UTC
Ok, now it works correctly in all the browsers that had the issue. Verified with BPMS 6.0.1 ER2.


Note You need to log in before you can comment on or make changes to this bug.