Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066469 - NoClassDefFoundError on business-central startup
Summary: NoClassDefFoundError on business-central startup
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: JBoss BRMS Platform 6
Classification: Retired
Component: Business Central
Version: unspecified
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: ER2
: 6.0.1
Assignee: Jan
QA Contact: Tomas Schlosser
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 13:41 UTC by Tomas Schlosser
Modified: 2014-08-06 19:59 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-08-06 19:59:08 UTC
Type: Bug


Attachments (Terms of Use)
server.log (deleted)
2014-02-18 13:41 UTC, Tomas Schlosser
no flags Details

Description Tomas Schlosser 2014-02-18 13:41:40 UTC
Created attachment 864560 [details]
server.log

Description of problem:
When business-central is started, the exception is thrown. The class "javax.crypto.Cipher" is not found by "org.sonatype.plexus" classes.

Version-Release number of selected component (if applicable):
Fedora 20
Java 7 (fedora-2.4.5.1.fc20-x86_64 u51-b31)
EAP 6.1.1
BRMS 6.0.1.ER1 (bz-1065283 patch)

Steps to Reproduce:
1. unzip eap
2. unzip brms over it
3. start server (standalone.sh will do)

Actual results:
exception when the server is started

Expected results:
clean start

Additional info:
This problem seems to be reproducible only on Fedora 20 (so it might be higher Java version, Maven version or some other environment settings).

The problem can be fixed by adding
<module name="javax.api" export="false"/>
to
<EAP_HOME>/modules/system/layers/brms/org/sonatype/plexus/main/module.xml

Comment 3 Tomas Schlosser 2014-03-06 12:03:46 UTC
Verified the fix in BRMS 6.0.1 ER2


Note You need to log in before you can comment on or make changes to this bug.