Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066416 - SVG rendering in Konqueror stalls
Summary: SVG rendering in Konqueror stalls
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: kde-baseapps
Version: 7.0
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: rc
: 7.0
Assignee: Jan Grulich
QA Contact: Desktop QE
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 10:57 UTC by Martin
Modified: 2016-02-15 07:54 UTC (History)
3 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-02-15 07:54:11 UTC


Attachments (Terms of Use)
partial rendering (deleted)
2014-02-18 10:57 UTC, Martin
no flags Details
complete rendering (deleted)
2014-02-18 10:58 UTC, Martin
no flags Details

Description Martin 2014-02-18 10:57:13 UTC
Description of problem:
SVG rendering in Konqueror is stalled until I switch focus to another window.

Version-Release number of selected component (if applicable):
kde-baseapps-4.10.5-4.el7.x86_64

How reproducible:
always

Steps to Reproduce:
1. Open this in Konqueror: http://upload.wikimedia.org/wikipedia/commons/4/47/HatchSlackpathway2.svg
2. Switch to another window or open application launcher
3. Observer Konqueror window and compare it with results in step 1.

Actual results:
Rendering is completed only after window focus switch.

Expected results:
Rendering shouldn't stall.

Additional info:
tested on T420s using Intel GPU and driver.

Comment 1 Martin 2014-02-18 10:57:35 UTC
Created attachment 864450 [details]
partial rendering

Comment 2 Martin 2014-02-18 10:58:19 UTC
Created attachment 864451 [details]
complete rendering

Attached screenshots for comparison.

Comment 9 Jan Grulich 2016-02-15 07:54:11 UTC
Works for me in RHEL 7.2 with rebased kdelibs which probably fixed this issue.


Note You need to log in before you can comment on or make changes to this bug.