Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066413 - vmHotplugDisk failed with "VolumeError: Bad volume specification"
Summary: vmHotplugDisk failed with "VolumeError: Bad volume specification"
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: vdsm
Version: 3.3.0
Hardware: Unspecified
OS: Unspecified
unspecified
medium
Target Milestone: ---
: 3.3.3
Assignee: Nir Soffer
QA Contact: Aharon Canan
URL:
Whiteboard: storage
Depends On: 1044068
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 10:53 UTC by rhev-integ
Modified: 2016-02-10 18:49 UTC (History)
18 users (show)

Fixed In Version: vdsm-4.13.2-0.14.el6ev
Doc Type: Bug Fix
Doc Text:
Previously, the vmHotplugDisk action would fail with the error "VolumeError: Bad volume specification". This was caused by a multipath race condition that would result in a situation in which multipath was not given enough time to create the /dev/mapper entry for the LUN on the host on which the virtual machine was running. Now, the logic used to scan for device visibility has been revised so that multipath has the time required for creating the /dev/mapper entry for the LUN on the host on which the virtual machine is running.
Clone Of: 1044068
Environment:
Last Closed: 2014-05-27 08:57:25 UTC
oVirt Team: Storage
Target Upstream Version:
amureini: Triaged+


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2014:0548 normal SHIPPED_LIVE vdsm 3.3.3 bug fix update 2014-05-27 12:56:53 UTC
oVirt gerrit 25240 None None None Never
oVirt gerrit 25241 None None None Never
oVirt gerrit 25242 None None None Never
oVirt gerrit 25243 None None None Never

Comment 1 Allon Mureinik 2014-02-18 11:37:53 UTC
Nir, please handle the backporting.

Comment 2 Nir Soffer 2014-03-02 13:40:21 UTC
Remove upstream patches.

Comment 4 Aharon Canan 2014-05-07 14:48:44 UTC
Verified using is36

Verification steps:
1. create 2 unattached LUNs and a VM
2. attach one of the LUNs when the VM is down
3. start VM and install OS
4. attach another LUN and check VM can access it.

Comment 6 errata-xmlrpc 2014-05-27 08:57:25 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2014-0548.html


Note You need to log in before you can comment on or make changes to this bug.