Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066273 - Sending to google mail, evolution appears to hang
Summary: Sending to google mail, evolution appears to hang
Keywords:
Status: CLOSED DUPLICATE of bug 1066266
Alias: None
Product: Fedora
Classification: Fedora
Component: evolution
Version: 20
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Matthew Barnes
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 07:52 UTC by Johannes
Modified: 2014-02-23 09:59 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-19 08:06:58 UTC


Attachments (Terms of Use)
Wireshark communication (deleted)
2014-02-18 07:52 UTC, Johannes
no flags Details

Description Johannes 2014-02-18 07:52:57 UTC
Created attachment 864407 [details]
Wireshark communication

Description of problem:
For reason beyond this report sending to google mail is blocked by a firewall. 

Evolution is incapably of realizing this in a timely manner. In that time (minutes rater than seconds) it is not possible to close evolution, logoff or stop the computer. 

In the attached wireshark capture it is visible that retransmissions occur. Observe however that after the last retransmission is send, still a couple of minutes go by before evolution realizes the connectivity problem and reports an error. During that time it is not possible to cancel the transmission. The latter is reported in another bug report.

Comment 1 Milan Crha 2014-02-19 08:06:58 UTC
Thanks for a bug report. There is not much difference between the two cases (this and yours bug #1066266) from my point of view, both are about being unable to cancel pending network operations when it operates on a "zombie" socket (it's waiting for a network timeout actually). Let's deal with this in one bug report only.

*** This bug has been marked as a duplicate of bug 1066266 ***

Comment 2 Johannes 2014-02-23 09:59:44 UTC
No problem. I appologize for the noise. Sometimes it really isn't easy to find out were to put bug reports


Note You need to log in before you can comment on or make changes to this bug.