Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066271 - Example application "csharp.map.receiver" with three arguments fails
Summary: Example application "csharp.map.receiver" with three arguments fails
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise MRG
Classification: Red Hat
Component: qpid-cpp
Version: Development
Hardware: Unspecified
OS: Windows
medium
medium
Target Milestone: 3.1
: ---
Assignee: Chuck Rolke
QA Contact: Petra Svobodová
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 07:52 UTC by Petra Svobodová
Modified: 2015-04-14 13:47 UTC (History)
1 user (show)

Fixed In Version: qpid-cpp-0.30-2
Doc Type: Bug Fix
Doc Text:
An issue with how the `csharp.map.receiver` example application command line processing code looked for arguments prevented users from getting the correct result for argument three. The code has been improved so the program argument list is now parsed correctly, which allows users to pass values to argument three correctly.
Clone Of:
Environment:
Last Closed: 2015-04-14 13:47:28 UTC


Attachments (Terms of Use)


Links
System ID Priority Status Summary Last Updated
Apache JIRA QPID-5575 None None None Never
Red Hat Product Errata RHEA-2015:0805 normal SHIPPED_LIVE Red Hat Enterprise MRG Messaging 3.1 Release 2015-04-14 17:45:54 UTC

Description Petra Svobodová 2014-02-18 07:52:32 UTC
Description of problem:
Application "csharp.map.receiver" fails with unhandled exception "System.IndexOutOfRangeException: Index was outside the boun
ds of the array." if three arguments are given. 

There is a small issue in its source code on row number 46:
...
if (args.Length > 2)
  connectionOptions = args[3];
...

should be:
...
if (args.Length > 2)
  connectionOptions = args[2];
...


Version-Release number of selected component (if applicable):
qpid-cpp-win-3.22.35.1-1

How reproducible:
100%

Steps to Reproduce:
1. Unzip and compile C# examples.
2. Send a message: csharp.map.sender <broker_hostname> <address> <connection-options>
3. Try to receive the message: csharp.map.receiver <broker_hostname> <address> <connection-options>

Actual results:
C# example csharp.map.receiver fails with exception

Expected results:
C# example csharp.map.receiver should run without exceptions.

Additional info:

Comment 1 Chuck Rolke 2014-02-21 15:23:20 UTC
Fixed upstream at Committed revision r1570603.

Comment 3 Petra Svobodová 2014-12-10 12:18:49 UTC
Now "csharp.map.receiver" example application is able to accept all three arguments and run without exceptions.

Verified on qpid-cpp-win-3.30.4.1-1 compiled in Microsoft Visual Studio 2008 and 2010 on Windows 7-x64, Windows 8-x64, Windows Server 2008-x64, Windows Server 2008 R2 and Windows Server 2012 R2.

--> VERIFIED

Comment 5 errata-xmlrpc 2015-04-14 13:47:28 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHEA-2015-0805.html


Note You need to log in before you can comment on or make changes to this bug.