Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066202 - [rhel7] Clone process could not be cancelled
Summary: [rhel7] Clone process could not be cancelled
Keywords:
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: virt-manager
Version: 7.0
Hardware: x86_64
OS: Linux
medium
medium
Target Milestone: rc
: ---
Assignee: Pavel Hrdina
QA Contact: Virtualization Bugs
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-18 02:26 UTC by zhengqin
Modified: 2015-11-05 01:15 UTC (History)
5 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-11-05 01:15:30 UTC
Target Upstream Version:


Attachments (Terms of Use)

Description zhengqin 2014-02-18 02:26:27 UTC
Description of problem:

Clone process could not be cancelled if user don't want to do clone on 
RHEL7, but could cancel clone process on rhel6.

Since clone operation will take a long time, if user could not cancel 
clone process, that may be not good.




Version-Release number of selected component:
virt-manager-0.10.0-16.el7.noarch



How reproducible:
100%

steps:
1. start virt-manager
[root@localhost /]# virt-manager

2. For a shutoff original vm named "vm", cloning a vm named "vm_clone".


Actual results:
1. There is no cancel button or right-upper 'x' button to cancel clone 
process.


Expected Results:
1. A cancel button or right-upper 'x' button should be given when user 
don't want to do this long time operation.



Additional info:
1. This issue does NOT occur RHEL6.

Comment 1 zhengqin 2014-02-21 02:34:08 UTC
FYI,

On RHEL6, there is a right-upper 'x' button on clone window to cancel clone process.

Comment 4 Cole Robinson 2015-11-05 01:15:30 UTC
The RHEL6 'support' for this was a lie, you could close the window but the cloning wasn't cancelled.

To make this actually work, we need libvirt storage job support, so that support for cancelling those jobs. But IMO it's not worth tracking unless a customer is asking for it


Note You need to log in before you can comment on or make changes to this bug.