Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066137 - Unresolved external symbol references break loading of the ACL plugin
Summary: Unresolved external symbol references break loading of the ACL plugin
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Fedora
Classification: Fedora
Component: 389-ds-base
Version: 22
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Rich Megginson
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 19:49 UTC by Nalin Dahyabhai
Modified: 2015-04-29 19:15 UTC (History)
5 users (show)

Fixed In Version: 389-ds-base-1.3.2.12-1
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2015-04-29 19:15:54 UTC


Attachments (Terms of Use)
Add "const" in the right places to fix mismatches (deleted)
2014-02-17 19:49 UTC, Nalin Dahyabhai
no flags Details | Diff

Description Nalin Dahyabhai 2014-02-17 19:49:05 UTC
Created attachment 864264 [details]
Add "const" in the right places to fix mismatches

Description of problem:
Various functions in the directory server are declared with extern "C" linkage, causing the compiler to emit references to an unmangled symbol name, but because their definitions don't match the declarations, and the definitions are compiled using the C++ compiler, the implementations are emitted as mangled symbols.

Version-Release number of selected component (if applicable):
389-ds-base-1.3.2.11-2.fc21.x86_64

How reproducible:
Always

Steps to Reproduce:
1. Run setup-ds.pl

Actual results:
[17/Feb/2014:13:38:04 -0500] - Netscape Portable Runtime error -5977: /usr/lib64/dirsrv/libns-dshttpd.so.0: undefined symbol: aclDNSLookup
[17/Feb/2014:13:38:04 -0500] - Could not open library "/usr/lib64/dirsrv/plugins/libacl-plugin.so" for plugin ACL Plugin
[17/Feb/2014:13:38:04 -0500] - Unable to load plugin "cn=ACL Plugin,cn=plugins,cn=config"
[17/Feb/2014:14:16:22 -0500] - Netscape Portable Runtime error -5977: /usr/lib64/dirsrv/libns-dshttpd.so.0: undefined symbol: INTereport
[17/Feb/2014:14:16:22 -0500] - Could not open library "/usr/lib64/dirsrv/plugins/libacl-plugin.so" for plugin ACL Plugin
[17/Feb/2014:14:16:23 -0500] - Unable to load plugin "cn=ACL Plugin,cn=plugins,cn=config"

Comment 1 Noriko Hosoi 2014-02-17 19:57:39 UTC
Upstream ticket:
https://fedorahosted.org/389/ticket/47700

Comment 2 Jaroslav Reznik 2015-03-03 17:08:25 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 22 development cycle.
Changing version to '22'.

More information and reason for this action is here:
https://fedoraproject.org/wiki/Fedora_Program_Management/HouseKeeping/Fedora22


Note You need to log in before you can comment on or make changes to this bug.