Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066106 - foreman-installer: cannot create a cinder vg for openstack installation using foreman
Summary: foreman-installer: cannot create a cinder vg for openstack installation using...
Keywords:
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-foreman-installer
Version: 4.0
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
: 4.0
Assignee: Jason Guiditta
QA Contact: Ami Jeain
URL:
Whiteboard: storage
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 17:25 UTC by Dafna Ron
Modified: 2014-09-08 16:54 UTC (History)
4 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-09-08 16:54:41 UTC


Attachments (Terms of Use)

Description Dafna Ron 2014-02-17 17:25:31 UTC
Description of problem:

when we used packstack we had the ability to create a vg for cinder. 
CONFIG_CINDER_VOLUMES_CREATE=y
CONFIG_CINDER_VOLUMES_SIZE=20G

since we are moving to working with foreman we need this capability to exist in foreman as well. 

Please note that we install/destroy/reinstall our systems on a weekly basis and would like to have this option that was automated in packstack to create the vg using foreman when we add the cinder host. 

Version-Release number of selected component (if applicable):


How reproducible:

100%

Steps to Reproduce:
1. deploy a cinder host with foreman without manually creating a cinder vg
2. deploy cinder using packstack
3.

Actual results:

the cinder vg is not created and we have no ability to create it via foreman but we can create it via packstack. 

Expected results:

we need to add this capability to foreman (not only if sysadmin need it but also for our own testing). 

Additional info:

Comment 1 Mike Orazi 2014-09-08 16:54:41 UTC
This basic functionality is exposed in rhel-osp-installer.  There is probably additional RFEs that we may carry in the future.


Note You need to log in before you can comment on or make changes to this bug.