Note: This is a beta release of Red Hat Bugzilla 5.0. The data contained within is a snapshot of the live data so any changes you make will not be reflected in the production Bugzilla. Also email is disabled so feel free to test any aspect of the site that you want. File any problems you find or give feedback here.
Bug 1066104 - TortoiseHg installed with incompatible mercurial
Summary: TortoiseHg installed with incompatible mercurial
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: tortoisehg
Version: 19
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Mads Kiilerich
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1066278 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2014-02-17 17:06 UTC by Jon Dufresne
Modified: 2014-02-22 00:57 UTC (History)
3 users (show)

Fixed In Version: tortoisehg-2.11-2.fc19
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2014-02-22 00:57:47 UTC


Attachments (Terms of Use)

Description Jon Dufresne 2014-02-17 17:06:29 UTC
TortoiseHg Was recently upgraded, but it appears that it is not compatible with the current version of mercurial in the repository. TortoiseHg is unusable in this state.

When starting TortoiseHg I am presented with the following error before it exists immediately:

    #!python
    ** Mercurial version (2.6.3).  TortoiseHg version (2.11)
    ** Command: --version
    ** CWD: ...
    ** Encoding: UTF-8
    ** Extensions loaded: 
    ** Python version: 2.7.5 (default, Nov 12 2013, 16:18:42) [GCC 4.8.2 20131017 (Red Hat 4.8.2-1)]
    ** System: Linux localhost.localdomain 3.12.9-201.fc19.x86_64 #1 SMP Wed Jan 29 15:44:35 UTC 2014 x86_64
    ** Qt-4.8.4 PyQt-4.10.1 QScintilla-2.7.1
    
    This version of TortoiseHg requires Mercurial version 2.8.n to 2.9.n, but found 2.6.3

Comment 1 Fedora Update System 2014-02-18 01:24:08 UTC
tortoisehg-2.11-2.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/tortoisehg-2.11-2.fc19

Comment 2 Mads Kiilerich 2014-02-18 01:26:10 UTC
My bad. I misunderstood which Mercurial version was in f19.

Please, can you verify that http://koji.fedoraproject.org/koji/taskinfo?taskID=6541635 works?

Comment 3 Mads Kiilerich 2014-02-18 10:36:59 UTC
*** Bug 1066278 has been marked as a duplicate of this bug. ***

Comment 4 Jon Dufresne 2014-02-18 16:54:54 UTC
> Please, can you verify that http://koji.fedoraproject.org/koji/taskinfo?taskID=6541635 works?

Works great for me. Thanks.

Comment 5 Fedora Update System 2014-02-20 00:41:59 UTC
Package tortoisehg-2.11-2.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing tortoisehg-2.11-2.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2014-2720/tortoisehg-2.11-2.fc19
then log in and leave karma (feedback).

Comment 6 Fedora Update System 2014-02-22 00:57:47 UTC
tortoisehg-2.11-2.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.